summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-07-01 22:06:01 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-07-01 22:06:01 -0700
commitcbc4fa1728bf3098af59fb5f83208e3888362357 (patch)
tree5758d34ba183cb1657b54031033fba5b9d83ef7b
parentnet-irc/weechat: fix #730338 (diff)
downloadgentoo-cbc4fa1728bf3098af59fb5f83208e3888362357.tar.gz
gentoo-cbc4fa1728bf3098af59fb5f83208e3888362357.tar.bz2
gentoo-cbc4fa1728bf3098af59fb5f83208e3888362357.zip
net-irc/weechat: update live ebuild
migrate to cmake.eclass update deps make gnutls non-optional, remove ssl flag completely https://github.com/weechat/weechat/commit/e130ee7358564cfd5572ca0cf1ac6871425548ed Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--net-irc/weechat/weechat-9999.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/net-irc/weechat/weechat-9999.ebuild b/net-irc/weechat/weechat-9999.ebuild
index 0871e154ad26..a63694304e87 100644
--- a/net-irc/weechat/weechat-9999.ebuild
+++ b/net-irc/weechat/weechat-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python{3_6,3_7,3_8} )
-inherit cmake-utils python-single-r1 xdg-utils
+inherit cmake python-single-r1 xdg-utils
if [[ ${PV} == "9999" ]] ; then
inherit git-r3
@@ -26,14 +26,15 @@ PLUGINS="+alias +buflist +charset +exec +fifo +fset +logger +relay +scripts +spe
# dev-lang/v8 was dropped from Gentoo so we can't enable javascript support
SCRIPT_LANGS="guile lua +perl php +python ruby tcl"
LANGS=" cs de es fr it ja pl ru"
-IUSE="doc man nls +ssl test ${SCRIPT_LANGS} ${PLUGINS} ${INTERFACES} ${NETWORKS}"
+IUSE="doc man nls test ${SCRIPT_LANGS} ${PLUGINS} ${INTERFACES} ${NETWORKS}"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
dev-libs/libgcrypt:0=
- net-misc/curl[ssl]
+ net-libs/gnutls:=
sys-libs/ncurses:0=
- sys-libs/zlib
+ sys-libs/zlib:=
+ net-misc/curl[ssl]
charset? ( virtual/libiconv )
guile? ( >=dev-scheme/guile-2.0 )
lua? ( dev-lang/lua:0 )
@@ -42,7 +43,6 @@ RDEPEND="
php? ( >=dev-lang/php-7.0:*[embed] )
python? ( ${PYTHON_DEPS} )
ruby? ( || ( dev-lang/ruby:2.6 dev-lang/ruby:2.5 dev-lang/ruby:2.4 ) )
- ssl? ( net-libs/gnutls )
spell? ( app-text/aspell )
tcl? ( >=dev-lang/tcl-8.4.15:0= )
"
@@ -67,7 +67,7 @@ pkg_setup() {
}
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# install only required translations
local i
@@ -115,7 +115,6 @@ src_configure() {
-DENABLE_EXEC=$(usex exec)
-DENABLE_FIFO=$(usex fifo)
-DENABLE_FSET=$(usex fset)
- -DENABLE_GNUTLS=$(usex ssl)
-DENABLE_GUILE=$(usex guile)
-DENABLE_IRC=$(usex irc)
-DENABLE_LOGGER=$(usex logger)
@@ -140,7 +139,7 @@ src_configure() {
python_is_python3 || mycmakeargs+=( -DENABLE_PYTHON2=ON )
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_postinst() {