summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-06 20:47:27 +0000
committerSam James <sam@gentoo.org>2021-12-09 01:54:47 +0000
commitd078e3f6003f16db1509825b486198cddb0d98e1 (patch)
tree2224e41e258506eb7ab485489aef1f76fa9a337a
parentdev-cpp/termcolor: Change LICENSE to BSD. (diff)
downloadgentoo-d078e3f6003f16db1509825b486198cddb0d98e1.tar.gz
gentoo-d078e3f6003f16db1509825b486198cddb0d98e1.tar.bz2
gentoo-d078e3f6003f16db1509825b486198cddb0d98e1.zip
profiles/arch/powerpc/ppc32: drop obsolete webkit-gtk related masks
Bug: https://bugs.gentoo.org/769374 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--profiles/arch/powerpc/package.use.stable.mask7
-rw-r--r--profiles/arch/powerpc/ppc32/package.use.mask41
-rw-r--r--profiles/arch/powerpc/ppc32/use.mask10
3 files changed, 22 insertions, 36 deletions
diff --git a/profiles/arch/powerpc/package.use.stable.mask b/profiles/arch/powerpc/package.use.stable.mask
index 0d8205bcb52d..a01b8aed5e6c 100644
--- a/profiles/arch/powerpc/package.use.stable.mask
+++ b/profiles/arch/powerpc/package.use.stable.mask
@@ -87,13 +87,6 @@ app-arch/p7zip kde
dev-vcs/subversion kwallet
x11-misc/xscreensaver new-login
-# Pacho Ramos <pacho@gentoo.org> (2015-09-06)
-# webkit-gtk is going to stay in ~all but amd64/x86
-# that are the only arches upstream is taking care
->=x11-libs/wxGTK-3.0.2.0-r1 webkit
-dev-util/glade webkit
-dev-python/wxpython webkit
-
# Justin Lecher <jlec@gentoo.org> (2015-02-21)
# Needs stable GNOME-3
net-fs/netatalk tracker
diff --git a/profiles/arch/powerpc/ppc32/package.use.mask b/profiles/arch/powerpc/ppc32/package.use.mask
index eec13d0c4a91..d6929b9f383b 100644
--- a/profiles/arch/powerpc/ppc32/package.use.mask
+++ b/profiles/arch/powerpc/ppc32/package.use.mask
@@ -1,6 +1,24 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Sam James <sam@gentoo.org> (2021-12-08)
+# Masks involving webkit-gtk; webkit-gtk was dekeyworded on ppc for a while.
+# We haven't (yet?) restored keywords for all the bits we had to drop, so
+# keep masks here (for now?).
+# Needs unkeyworded gnome-extra/sushi
+gnome-base/nautilus previewer
+# needs mail-client/evolution, depends on net-libs/webkit-gtk
+app-office/planner eds
+# needs gnome-extra/sushi, depends on net-libs/webkit-gtk
+gnome-base/nautilus previewer
+# needs libgdata[gnome-online-accounts], depends on net-libs/webkit-gtk
+gnome-base/gvfs google
+gnome-base/gnome-control-center flickr
+# needs mail-client/evolution, depends on net-libs/webkit-gtk
+net-mail/lbdb evo
+# needs dev-util/devhelp, depends on net-libs/webkit-gtk
+dev-util/anjuta devhelp
+
# Daniel Pielmeier <billie@gentoo.org> (2021-11-07)
# gnome-base/librsvg has no stable keywords here, bug #807130
app-admin/conky lua-rsvg
@@ -69,29 +87,6 @@ dev-ml/cudf test
# gnome-base/librsvg, et al
>=media-gfx/eog-3.33.1 svg
-# Sergei Trofimovich <slyfox@gentoo.org> (2020-07-18)
-# net-libs/webkit-gtk has no ppc keywords
-app-editors/emacs xwidgets
-gnome-extra/evolution-data-server oauth
-app-office/gnucash gui doc
-dev-util/geany-plugins markdown
->=media-gfx/gthumb-3.10.0 http
-# needs mail-client/evolution, depends on net-libs/webkit-gtk
-app-office/planner eds
-# needs gnome-extra/sushi, depends on net-libs/webkit-gtk
-gnome-base/nautilus previewer
-# needs libgdata[gnome-online-accounts], depends on net-libs/webkit-gtk
-gnome-base/gvfs google
-gnome-base/gnome-control-center flickr
-# needs x11-libs/wxGTK[webkit]
-sci-misc/boinc X
-# needs mail-client/evolution, depends on net-libs/webkit-gtk
-net-mail/lbdb evo
-# needs dev-util/devhelp, depends on net-libs/webkit-gtk
-dev-util/anjuta devhelp
-# app-text/libgepub depends on webkit-gtk
-xfce-extra/tumbler epub
-
# Mikle Kolyada <zlogene@gentoo.org> (2020-06-08)
# clisp is keyworded on ppc
app-text/texlive-core -xindy
diff --git a/profiles/arch/powerpc/ppc32/use.mask b/profiles/arch/powerpc/ppc32/use.mask
index 760fc9331531..c2325ed7fe8b 100644
--- a/profiles/arch/powerpc/ppc32/use.mask
+++ b/profiles/arch/powerpc/ppc32/use.mask
@@ -4,6 +4,10 @@
# Unmask the flag which corresponds to ARCH.
-ppc
+# Sam James <sam@gentoo.org> (2021-12-07)
+# net-libs/gnome-online-accounts is not marked keyworded on ppc
+gnome-online-accounts
+
# Sam James <sam@gentoo.org> (2021-10-16)
# media-libs/openexr doesn't work on BE (bug #818424)
# ...and openscenegraph needs openexr.
@@ -18,12 +22,6 @@ llvm-libunwind
# gnome-shell requires rustified librsvg.
gnome-shell
-# Sergei Trofimovich <slyfox@gentoo.org> (2020-07-18)
-# net-libs/webkit-gtk has no ppc keywords
-webkit
-# net-libs/gnome-online-accounts depends on net-libs/webkit-gtk
-gnome-online-accounts
-
# James Le Cuirot <chewi@gentoo.org> (2015-01-12)
# Java is no longer supported on ppc.
java