summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2017-03-06 19:03:09 +0100
committerTupone Alfredo <tupone@gentoo.org>2017-03-06 19:03:09 +0100
commitd617c7ac0a6c51cb1f52d56e9d411e98d524790e (patch)
tree8907965a820f22cfb1f115f5c80d9c7f6f575e26
parentapp-misc/geneweb: patched for dev-lang/ocaml-4 (diff)
downloadgentoo-d617c7ac0a6c51cb1f52d56e9d411e98d524790e.tar.gz
gentoo-d617c7ac0a6c51cb1f52d56e9d411e98d524790e.tar.bz2
gentoo-d617c7ac0a6c51cb1f52d56e9d411e98d524790e.zip
app-misc/geneweb: remove 6.08 (for ocaml-3 version)
Package-Manager: portage-2.3.3
-rw-r--r--app-misc/geneweb/files/geneweb-6.08-gentoo.patch30
-rw-r--r--app-misc/geneweb/geneweb-6.08.ebuild74
2 files changed, 0 insertions, 104 deletions
diff --git a/app-misc/geneweb/files/geneweb-6.08-gentoo.patch b/app-misc/geneweb/files/geneweb-6.08-gentoo.patch
deleted file mode 100644
index 6e33da85a8eb..000000000000
--- a/app-misc/geneweb/files/geneweb-6.08-gentoo.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- geneweb-6.08/setup/setup.ml.old 2007-08-07 19:25:13.000000000 +0200
-+++ geneweb-6.08/setup/setup.ml 2007-08-07 19:24:59.000000000 +0200
-@@ -5,8 +5,8 @@
-
- value port = ref 2316;
- value default_lang = ref "en";
--value setup_dir = ref ".";
--value bin_dir = ref "";
-+value setup_dir = ref "/usr/share/geneweb";
-+value bin_dir = ref "/usr/bin";
- value lang_param = ref "";
- value only_file = ref "";
-
---- geneweb-6.08/tools/Makefile.inc.unix.old 2008-04-23 15:22:50.000000000 +0200
-+++ geneweb-6.08/tools/Makefile.inc.unix 2008-04-23 15:23:04.000000000 +0200
-@@ -5,11 +5,11 @@
- CAMLP5F=-DUNIX
- CAMLP5D=+camlp5
- LIBUNIX=-cclib -lunix
--OCAMLC=ocamlc.opt -warn-error A
--OCAMLOPT=ocamlopt.opt -warn-error A
-+OCAMLC=ocamlc.opt
-+OCAMLOPT=ocamlopt.opt
- OCAMLI=
- OCAMLD=
--STRIP=strip
-+STRIP=true
- RM=/bin/rm -f
- EXE=
- STATIC=-ccopt -static
diff --git a/app-misc/geneweb/geneweb-6.08.ebuild b/app-misc/geneweb/geneweb-6.08.ebuild
deleted file mode 100644
index 800269025fa9..000000000000
--- a/app-misc/geneweb/geneweb-6.08.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils user
-
-DESCRIPTION="Genealogy software program with a Web interface"
-HOMEPAGE="http://opensource.geneanet.org/projects/geneweb"
-SRC_URI="https://github.com/geneweb/geneweb/archive/v6.08.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+ocamlopt"
-
-RDEPEND="dev-lang/ocaml[ocamlopt?]
- dev-ml/camlp5[ocamlopt?]"
-DEPEND="${RDEPEND}
- !net-p2p/ghostwhitecrab"
-
-PATCHES=(
- "${FILESDIR}"/${P}-gentoo.patch
- "${FILESDIR}"/${P}-parallellbuild.patch )
-
-src_compile() {
- if use ocamlopt; then
- emake
- else
- emake OCAMLC=ocamlc OCAMLOPT=ocamlopt out
- # If using bytecode we dont want to strip the binary as it would remove
- # the bytecode and only leave ocamlrun...
- export STRIP_MASK="*/bin/*"
- fi
-}
-
-src_install() {
- dodoc ICHANGES
- emake distrib
- # Install doc
- cd distribution
- dodoc CHANGES.txt
- # Install binaries
- cd gw
- dobin gwc gwc1 gwc2 consang gwd gwu update_nldb ged2gwb ged2gwb2 gwb2ged gwsetup
- insinto /usr/lib/${PN}
- doins -r gwtp_tmp/*
- dodoc a.gwf
- insinto /usr/share/${PN}
- doins -r etc images lang setup gwd.arg only.txt
-
- cd ../..
-
- # Install binaries
- dobin src/check_base
- # Install manpages
- doman man/*
-
- # Install doc
- insinto /usr/share/doc/${PF}/contrib
- doins -r contrib/{gwdiff,misc}
-
- newinitd "${FILESDIR}/geneweb.initd" geneweb
- newconfd "${FILESDIR}/geneweb.confd" geneweb
-}
-
-pkg_postinst() {
- enewuser geneweb "" "/bin/bash" /var/lib/geneweb
- einfo "A CGI program has been installed in /usr/lib/${PN}. Follow the"
- einfo "instructions on the README in that directory to use it"
- einfo "For 64 bits architecture you need to rebuild the database"
- einfo "\"gwu foo > foo.gw \" will save the database (use the previous"
- einfo "version to do that). \"gwc2 foo.gw -o bar \" will restore it "
- einfo "(using the current package)"
-}