summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2016-03-04 11:56:37 +0100
committerFabian Groffen <grobian@gentoo.org>2016-03-04 11:56:37 +0100
commitd64c7f7c68164c8d99325dd8fba7efcd515b9b09 (patch)
treeaadde2715285b651660734cbf065f814117512c3
parentdev-java/nanoxml: Housekeeping. EAPI 5 bump. (diff)
downloadgentoo-d64c7f7c68164c8d99325dd8fba7efcd515b9b09.tar.gz
gentoo-d64c7f7c68164c8d99325dd8fba7efcd515b9b09.tar.bz2
gentoo-d64c7f7c68164c8d99325dd8fba7efcd515b9b09.zip
mail-mta/exim: fix TMPDIR patch for 4.86.2, drop for 4.87_rc5 as it's upstream, bug #576332
Package-Manager: portage-2.2.26
-rw-r--r--mail-mta/exim/exim-4.86.2.ebuild2
-rw-r--r--mail-mta/exim/exim-4.87_rc5.ebuild1
-rw-r--r--mail-mta/exim/files/exim-4.86.2-TMPDIR.patch68
3 files changed, 69 insertions, 2 deletions
diff --git a/mail-mta/exim/exim-4.86.2.ebuild b/mail-mta/exim/exim-4.86.2.ebuild
index afad1483e3e5..1e63f26ac6f6 100644
--- a/mail-mta/exim/exim-4.86.2.ebuild
+++ b/mail-mta/exim/exim-4.86.2.ebuild
@@ -87,7 +87,7 @@ src_prepare() {
epatch "${FILESDIR}"/exim-4.76-crosscompile.patch # 266591
epatch "${FILESDIR}"/exim-4.86-radius-type-fix.patch
epatch "${FILESDIR}"/exim-4.86-radius-include.patch
- epatch "${FILESDIR}"/exim-4.86-TMPDIR.patch # 63420
+ epatch "${FILESDIR}"/exim-4.86.2-TMPDIR.patch # 63420
if use maildir ; then
epatch "${FILESDIR}"/exim-4.20-maildir.patch
diff --git a/mail-mta/exim/exim-4.87_rc5.ebuild b/mail-mta/exim/exim-4.87_rc5.ebuild
index 2bcd19282d75..661bf5ea8096 100644
--- a/mail-mta/exim/exim-4.87_rc5.ebuild
+++ b/mail-mta/exim/exim-4.87_rc5.ebuild
@@ -85,7 +85,6 @@ src_prepare() {
epatch "${FILESDIR}"/exim-4.82-makefile-freebsd.patch # 235785
epatch "${FILESDIR}"/exim-4.87-as-needed-ldflags.patch # 352265, 391279
epatch "${FILESDIR}"/exim-4.76-crosscompile.patch # 266591
- epatch "${FILESDIR}"/exim-4.86-TMPDIR.patch # 63420
if use maildir ; then
epatch "${FILESDIR}"/exim-4.20-maildir.patch
diff --git a/mail-mta/exim/files/exim-4.86.2-TMPDIR.patch b/mail-mta/exim/files/exim-4.86.2-TMPDIR.patch
new file mode 100644
index 000000000000..9c05a24fe07f
--- /dev/null
+++ b/mail-mta/exim/files/exim-4.86.2-TMPDIR.patch
@@ -0,0 +1,68 @@
+Adapted for 4.86.2
+
+From c36cf51b85cfc86e46226c846914c8d915f9f3c0 Mon Sep 17 00:00:00 2001
+From: Alexander Tsoy <alexander@tsoy.me>
+Date: Tue, 2 Feb 2016 20:56:15 +0300
+Subject: [PATCH] Rename build-time option TMPDIR to EXIM_TMPDIR
+
+---
+ src/EDITME | 2 +-
+ src/config.h.defaults | 2 +-
+ src/exim.c | 12 ++++++------
+ 3 files changed, 8 insertions(+), 8 deletions(-)
+
+diff --git a/src/EDITME b/src/EDITME
+index 30a296e..6afe0c7 100644
+--- a/src/EDITME
++++ b/src/EDITME
+@@ -1123,7 +1123,7 @@ SYSTEM_ALIASES_FILE=/etc/aliases
+ # it replaces the value with what is defined here. Commenting this setting
+ # suppresses the check altogether.
+
+-TMPDIR="/tmp"
++EXIM_TMPDIR="/tmp"
+
+
+ #------------------------------------------------------------------------------
+diff --git a/src/config.h.defaults b/src/config.h.defaults
+index 14de083..c1cf1a9 100644
+--- a/src/config.h.defaults
++++ b/src/config.h.defaults
+@@ -150,7 +150,7 @@ it's a default value. */
+
+ #define TCP_WRAPPERS_DAEMON_NAME "exim"
+ #define TIMEZONE_DEFAULT
+-#define TMPDIR
++#define EXIM_TMPDIR
+
+ #define TRANSPORT_APPENDFILE
+ #define TRANSPORT_AUTOREPLY
+--- a/src/exim.c
++++ b/src/exim.c
+@@ -3887,20 +3887,20 @@
+ temporary files are created; Exim doesn't use these (apart from when delivering
+ to MBX mailboxes), but called libraries such as DBM libraries may require them.
+ If TMPDIR is found in the environment, reset it to the value defined in the
+-TMPDIR macro, if this macro is defined. */
++EXIM_TMPDIR macro, if this macro is defined. */
+
+-#ifdef TMPDIR
++#ifdef EXIM_TMPDIR
+ {
+ uschar **p;
+ if (environ) for (p = USS environ; *p != NULL; p++)
+ {
+ if (Ustrncmp(*p, "TMPDIR=", 7) == 0 &&
+- Ustrcmp(*p+7, TMPDIR) != 0)
++ Ustrcmp(*p+7, EXIM_TMPDIR) != 0)
+ {
+- uschar *newp = malloc(Ustrlen(TMPDIR) + 8);
+- sprintf(CS newp, "TMPDIR=%s", TMPDIR);
++ uschar *newp = malloc(Ustrlen(EXIM_TMPDIR) + 8);
++ sprintf(CS newp, "TMPDIR=%s", EXIM_TMPDIR);
+ *p = newp;
+- DEBUG(D_any) debug_printf("reset TMPDIR=%s in environment\n", TMPDIR);
++ DEBUG(D_any) debug_printf("reset TMPDIR=%s in environment\n", EXIM_TMPDIR);
+ }
+ }
+ }