summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-01 23:08:55 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-01 23:12:27 +0200
commitd954681544940c9d4637e04e3b10f49fca92f356 (patch)
tree4b234d90b2e07098226fd990c9ee541d14cb5a95
parentdev-python/flask-sqlalchemy: Enable py3.10 (diff)
downloadgentoo-d954681544940c9d4637e04e3b10f49fca92f356.tar.gz
gentoo-d954681544940c9d4637e04e3b10f49fca92f356.tar.bz2
gentoo-d954681544940c9d4637e04e3b10f49fca92f356.zip
x11-misc/qt5ct: Bump to 1.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--x11-misc/qt5ct/Manifest1
-rw-r--r--x11-misc/qt5ct/qt5ct-1.3.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/x11-misc/qt5ct/Manifest b/x11-misc/qt5ct/Manifest
index 8e33534161dc..d048b1957899 100644
--- a/x11-misc/qt5ct/Manifest
+++ b/x11-misc/qt5ct/Manifest
@@ -1 +1,2 @@
DIST qt5ct-1.2.tar.bz2 76052 BLAKE2B bff9dcd6176f856f262f908101f51be5bc5fa56cbf221fb6e1b66cf49867d721f4c1d5707bcd71cb20b1d27d53f5352bcaaa32ed7298f9fe349ac8a90b4a4e23 SHA512 044582440fc3ed8424970a30d7e1562396f9a1651f2c50adbdcb6ec73b35fb8dd23de419df29b92d21a45fea9af4e562b1294f5bfc329419f831775954f8ed6f
+DIST qt5ct-1.3.tar.bz2 80506 BLAKE2B eda2d69fcddf80553358d3c9e9bd0ef33355919c5b62912d8e79a84a36ee5a25d1dab553b6413d78e16ce69435861a01b298ae97202a77f1f50ed805f14445dd SHA512 9f4397d5cfc3dec14330759f213ae99b02ae36d3ea48dfdb3015c3b7d3fe12cde619af855d7320566ca32120e8689e4b39f78e4fdf9886e2472aef570beb75bd
diff --git a/x11-misc/qt5ct/qt5ct-1.3.ebuild b/x11-misc/qt5ct/qt5ct-1.3.ebuild
new file mode 100644
index 000000000000..419efe47f940
--- /dev/null
+++ b/x11-misc/qt5ct/qt5ct-1.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Qt5 configuration tool, similar to qtconfig for Qt4"
+HOMEPAGE="https://sourceforge.net/projects/qt5ct/"
+SRC_URI="https://download.sourceforge.net/qt5ct/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+dbus"
+
+RDEPEND="
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5=
+ dev-qt/qtwidgets:5
+ dbus? (
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5[dbus]
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ dev-qt/qtpaths:5
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-cmake.patch
+)
+
+src_install() {
+ cmake_src_install
+
+ newenvd - 98qt5ct <<< 'QT_QPA_PLATFORMTHEME=qt5ct'
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ ewarn "qt5ct configuration won't be applied to the currently running sessions."
+ ewarn "Please relogin."
+ fi
+ if ! has_version 'dev-qt/qtsvg:5'; then
+ elog
+ elog "For SVG icon themes, please install 'dev-qt/qtsvg:5'."
+ elog
+ fi
+}