summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-06-13 20:29:48 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-06-13 20:29:48 +0200
commite21b968d4a81d9bc79c5f1e83da799364c037069 (patch)
tree39d2df75f5285955748c6b30ab6b73b64a7dc0c9
parentapp-crypt/certbot: Sync live (diff)
downloadgentoo-e21b968d4a81d9bc79c5f1e83da799364c037069.tar.gz
gentoo-e21b968d4a81d9bc79c5f1e83da799364c037069.tar.bz2
gentoo-e21b968d4a81d9bc79c5f1e83da799364c037069.zip
app-crypt/certbot-nginx: Version bump to 0.15.0
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--app-crypt/certbot-nginx/Manifest1
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-0.15.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-crypt/certbot-nginx/Manifest b/app-crypt/certbot-nginx/Manifest
index b3219e14976c..70a3f57dc7bd 100644
--- a/app-crypt/certbot-nginx/Manifest
+++ b/app-crypt/certbot-nginx/Manifest
@@ -1 +1,2 @@
DIST certbot-0.14.1.tar.gz 851705 SHA256 7992fced742649e7b7668e4db7685de12248a4ffba66810cb336e9b6412e3567 SHA512 309e0e1d071960ae9a5cc4c9f965cc623b68d3d61f69282f21629514553a75af4d384d2c29fd3beee6eb8447c7b6651ce86c33c4f3916876fac7a91a08d2075d WHIRLPOOL f5a5be776f0a9bb9096a6e8dfa64942bd00583559cba64d3c1a5b991578bb8c7cac5076895e4291e1ec4c8fa767f026a90e0c1312c4f425ffcb5bf08bd0e9e40
+DIST certbot-0.15.0.tar.gz 942788 SHA256 87d306b1c013b472b8f548b38ccc476c125816435bb3b99e932fed09ac777296 SHA512 e884b34985a1128ce94d6b2be77af6ee86ded8b870e066f3f4bc22f78501f3f0a51060edcf75a11cd31dd525388adb8ccc4e2da0068b5b75be131d0fb0ca6844 WHIRLPOOL 01b172e8c7ac5d3678ee608b36d93f23943bf17f1e9c593cc1af3febcf0549b03961e69e537f099643dd9ee268497f76c2c18d8fa7a1d45753bc50e670375317
diff --git a/app-crypt/certbot-nginx/certbot-nginx-0.15.0.ebuild b/app-crypt/certbot-nginx/certbot-nginx-0.15.0.ebuild
new file mode 100644
index 000000000000..54f5cf0aa674
--- /dev/null
+++ b/app-crypt/certbot-nginx/certbot-nginx-0.15.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-nginx}/${PN%-nginx}/archive/v${PV}.tar.gz -> ${PN%-nginx}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+ S=${WORKDIR}/${PN%-nginx}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Nginx plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/setuptools-1.0[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ ~app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ ~app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-1.5.5[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"