summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2017-12-07 14:28:57 -0500
committerAnthony G. Basile <blueness@gentoo.org>2017-12-07 14:28:57 -0500
commite7ec64e07c110fd117d37b26c7ca668eba586f9a (patch)
treec48d170efe100c8c078c5f4965d120ac0b098311
parentdev-libs/openssl: Security cleanup (diff)
downloadgentoo-e7ec64e07c110fd117d37b26c7ca668eba586f9a.tar.gz
gentoo-e7ec64e07c110fd117d37b26c7ca668eba586f9a.tar.bz2
gentoo-e7ec64e07c110fd117d37b26c7ca668eba586f9a.zip
sys-boot/lilo: remove legacy HARDENED_CFLAGS, bug #621866
Package-Manager: Portage-2.3.13, Repoman-2.3.3
-rw-r--r--sys-boot/lilo/lilo-22.8-r2.ebuild10
-rw-r--r--sys-boot/lilo/lilo-23.2-r2.ebuild8
-rw-r--r--sys-boot/lilo/lilo-24.0-r1.ebuild8
-rw-r--r--sys-boot/lilo/lilo-24.1.ebuild8
-rw-r--r--sys-boot/lilo/lilo-24.2.ebuild8
5 files changed, 11 insertions, 31 deletions
diff --git a/sys-boot/lilo/lilo-22.8-r2.ebuild b/sys-boot/lilo/lilo-22.8-r2.ebuild
index 7ae95e523fe6..257a7a9a1136 100644
--- a/sys-boot/lilo/lilo-22.8-r2.ebuild
+++ b/sys-boot/lilo/lilo-22.8-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
inherit eutils flag-o-matic toolchain-funcs
@@ -48,16 +48,12 @@ src_compile() {
# lilo needs this. bug #140209
export LC_ALL=C
- # hardened automatic PIC plus PIE building should be suppressed
- # because of assembler instructions that cannot be compiled PIC
- HARDENED_CFLAGS="`test-flags-CC -fno-pic -nopie`"
-
# we explicitly prevent the custom CFLAGS for stability reasons
if use static; then
- emake CC="$(tc-getCC) ${HARDENED_CFLAGS}" lilo.static || die
+ emake CC="$(tc-getCC)" lilo.static || die
mv lilo.static lilo || die
else
- emake CC="$(tc-getCC) ${HARDENED_CFLAGS}" lilo || die
+ emake CC="$(tc-getCC)" lilo || die
fi
}
diff --git a/sys-boot/lilo/lilo-23.2-r2.ebuild b/sys-boot/lilo/lilo-23.2-r2.ebuild
index afbd4d2a7346..2be5f25cd507 100644
--- a/sys-boot/lilo/lilo-23.2-r2.ebuild
+++ b/sys-boot/lilo/lilo-23.2-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="2"
@@ -49,10 +49,6 @@ src_compile() {
# lilo needs this. bug #140209
export LC_ALL=C
- # hardened automatic PIC plus PIE building should be suppressed
- # because of assembler instructions that cannot be compiled PIC
- HARDENED_CFLAGS=$(test-flags-CC -fno-pic -nopie)
-
# we explicitly prevent the custom CFLAGS for stability reasons
if use static; then
local target=alles
@@ -60,7 +56,7 @@ src_compile() {
local target=all
fi
- emake CC="$(tc-getCC) ${LDFLAGS} ${HARDENED_CFLAGS}" ${target} || die
+ emake CC="$(tc-getCC) ${LDFLAGS}" ${target} || die
}
src_install() {
diff --git a/sys-boot/lilo/lilo-24.0-r1.ebuild b/sys-boot/lilo/lilo-24.0-r1.ebuild
index 4de878e34d33..b0639924ba39 100644
--- a/sys-boot/lilo/lilo-24.0-r1.ebuild
+++ b/sys-boot/lilo/lilo-24.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -49,10 +49,6 @@ src_compile() {
# lilo needs this. bug #140209
export LC_ALL=C
- # hardened automatic PIC plus PIE building should be suppressed
- # because of assembler instructions that cannot be compiled PIC
- HARDENED_CFLAGS=$(test-flags-CC -fno-pic -nopie)
-
# we explicitly prevent the custom CFLAGS for stability reasons
if use static; then
local target=alles
@@ -60,7 +56,7 @@ src_compile() {
local target=all
fi
- emake CC="$(tc-getCC) ${LDFLAGS} ${HARDENED_CFLAGS}" ${target} || die
+ emake CC="$(tc-getCC) ${LDFLAGS}" ${target} || die
}
src_install() {
diff --git a/sys-boot/lilo/lilo-24.1.ebuild b/sys-boot/lilo/lilo-24.1.ebuild
index 3d0cf52c05da..9431f2659608 100644
--- a/sys-boot/lilo/lilo-24.1.ebuild
+++ b/sys-boot/lilo/lilo-24.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -49,10 +49,6 @@ src_compile() {
# lilo needs this. bug #140209
export LC_ALL=C
- # hardened automatic PIC plus PIE building should be suppressed
- # because of assembler instructions that cannot be compiled PIC
- HARDENED_CFLAGS=$(test-flags-CC -fno-pic -nopie)
-
# we explicitly prevent the custom CFLAGS for stability reasons
if use static; then
local target=alles
@@ -60,7 +56,7 @@ src_compile() {
local target=all
fi
- emake CC="$(tc-getCC) ${LDFLAGS} ${HARDENED_CFLAGS}" ${target} || die
+ emake CC="$(tc-getCC) ${LDFLAGS}" ${target} || die
}
src_install() {
diff --git a/sys-boot/lilo/lilo-24.2.ebuild b/sys-boot/lilo/lilo-24.2.ebuild
index d075d6bf7517..854b8dba4364 100644
--- a/sys-boot/lilo/lilo-24.2.ebuild
+++ b/sys-boot/lilo/lilo-24.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -49,10 +49,6 @@ src_compile() {
# lilo needs this. bug #140209
export LC_ALL=C
- # hardened automatic PIC plus PIE building should be suppressed
- # because of assembler instructions that cannot be compiled PIC
- HARDENED_CFLAGS=$(test-flags-CC -fno-pic -nopie)
-
# we explicitly prevent the custom CFLAGS for stability reasons
if use static; then
local target=alles
@@ -60,7 +56,7 @@ src_compile() {
local target=all
fi
- emake CC="$(tc-getCC) ${LDFLAGS} ${HARDENED_CFLAGS}" ${target} || die
+ emake CC="$(tc-getCC) ${LDFLAGS}" ${target} || die
}
src_install() {