summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-12-29 15:17:32 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-12-29 15:17:32 +0100
commitef5af0ae93adbe5f549ad922756f3f566244d274 (patch)
treec0ae4e50340e19cda6b27b78fb8cfc9dcc37ec20
parentsci-libs/rtabmap: bump to 0.11.12 and update live ebuild (diff)
downloadgentoo-ef5af0ae93adbe5f549ad922756f3f566244d274.tar.gz
gentoo-ef5af0ae93adbe5f549ad922756f3f566244d274.tar.bz2
gentoo-ef5af0ae93adbe5f549ad922756f3f566244d274.zip
media-libs/smpeg: fix build with gcc6, bug #592450, patch by Peter Levine.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--media-libs/smpeg/files/smpeg-0.4.4-gcc6.patch25
-rw-r--r--media-libs/smpeg/smpeg-0.4.4-r10.ebuild5
2 files changed, 28 insertions, 2 deletions
diff --git a/media-libs/smpeg/files/smpeg-0.4.4-gcc6.patch b/media-libs/smpeg/files/smpeg-0.4.4-gcc6.patch
new file mode 100644
index 000000000000..4419bec4e2ee
--- /dev/null
+++ b/media-libs/smpeg/files/smpeg-0.4.4-gcc6.patch
@@ -0,0 +1,25 @@
+--- smpeg-0.4.4/audio/huffmantable.cpp.old 2016-09-21 17:28:34.497031221 -0400
++++ smpeg-0.4.4/audio/huffmantable.cpp 2016-09-21 17:30:24.346141555 -0400
+@@ -550,11 +550,11 @@
+
+ const HUFFMANCODETABLE MPEGaudio::ht[HTN]=
+ {
+- { 0, 0-1, 0-1, 0, 0, htd33},
++ { 0, (unsigned) 0-1, (unsigned) 0-1, 0, 0, htd33},
+ { 1, 2-1, 2-1, 0, 7,htd01},
+ { 2, 3-1, 3-1, 0, 17,htd02},
+ { 3, 3-1, 3-1, 0, 17,htd03},
+- { 4, 0-1, 0-1, 0, 0, htd33},
++ { 4, (unsigned) 0-1, (unsigned) 0-1, 0, 0, htd33},
+ { 5, 4-1, 4-1, 0, 31,htd05},
+ { 6, 4-1, 4-1, 0, 31,htd06},
+ { 7, 6-1, 6-1, 0, 71,htd07},
+@@ -564,7 +564,7 @@
+ {11, 8-1, 8-1, 0,127,htd11},
+ {12, 8-1, 8-1, 0,127,htd12},
+ {13,16-1,16-1, 0,511,htd13},
+- {14, 0-1, 0-1, 0, 0, htd33},
++ {14, (unsigned) 0-1, (unsigned) 0-1, 0, 0, htd33},
+ {15,16-1,16-1, 0,511,htd15},
+ {16,16-1,16-1, 1,511,htd16},
+ {17,16-1,16-1, 2,511,htd16},
diff --git a/media-libs/smpeg/smpeg-0.4.4-r10.ebuild b/media-libs/smpeg/smpeg-0.4.4-r10.ebuild
index c7dd365b6e10..4f4dba15b454 100644
--- a/media-libs/smpeg/smpeg-0.4.4-r10.ebuild
+++ b/media-libs/smpeg/smpeg-0.4.4-r10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -45,7 +45,8 @@ src_prepare() {
"${FILESDIR}"/${P}-mmx.patch \
"${FILESDIR}"/${P}-malloc.patch \
"${FILESDIR}"/${P}-format.patch \
- "${FILESDIR}"/${P}-missing-init.patch
+ "${FILESDIR}"/${P}-missing-init.patch \
+ "${FILESDIR}"/${P}-gcc6.patch
cd "${WORKDIR}"
epatch "${DISTDIR}"/${P}-gtkm4.patch.bz2