summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-12-28 00:08:59 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-12-28 00:25:52 +0100
commitf17092ff5e82c555e33e9e34e1f66eb15da1db74 (patch)
tree87a57683e4fa362eb58e15035ae623c02979c64f
parentprofiles: Lift package.mask for <app-text/poppler-0.62.0 (diff)
downloadgentoo-f17092ff5e82c555e33e9e34e1f66eb15da1db74.tar.gz
gentoo-f17092ff5e82c555e33e9e34e1f66eb15da1db74.tar.bz2
gentoo-f17092ff5e82c555e33e9e34e1f66eb15da1db74.zip
kde-misc/wacomtablet: 3.0.0_beta2 version bump (2.9.82 upstream)
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--kde-misc/wacomtablet/Manifest1
-rw-r--r--kde-misc/wacomtablet/wacomtablet-3.0.0_beta2.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/kde-misc/wacomtablet/Manifest b/kde-misc/wacomtablet/Manifest
index 84a7ab4b6511..bd2642528110 100644
--- a/kde-misc/wacomtablet/Manifest
+++ b/kde-misc/wacomtablet/Manifest
@@ -1,2 +1,3 @@
DIST 114856-wacomtablet-3.0.0~beta1.tar.xz 655684 BLAKE2B 666d1e60c7caa763a3e884936f800c122ea0e6151dea89bd44b5d50b203444b3429dac8b0376c5129f29b3103ff2d82ae353eaae7324c422e590c5a8dee88806 SHA512 cf95cbd8f3489bf0d18acfec72ca964685060ae7c7a554b118f5086a46a1e97be67f674f1bf1db6ce15638fcdcfca5043e7438af09ced8acd9fb601c44f433fb
+DIST wacomtablet-2.9.82.tar.xz 708508 BLAKE2B f9f10354f5db42e9acc43b05d00c168bd6f5200ea7d7f7fb4c7f0f3042ab2327d78145f6388e1c607528e14c6e6bd6a33929f952943dba330e02d761634ca37c SHA512 ba1b8d15ed4ce52c14ca0ac494cfb9200b9c891c6ac19ee5a306496e1c04f6abc8b83290bc31199a634ed8b4b4469dc185a967be183f1ed6b53956bc19038904
DIST wacomtablet-3.0.0_beta1_p20171107.tar.gz 629835 BLAKE2B 489c549e35c3a1f8ea3c139b122f3798b673d4d760f50ae871e9d7ef54ab85742770734c095096260fa0c2629f704ee98d1aaba13b1292cfcc9f74e9402b7532 SHA512 bcd8f23e4f02cea09e1fb82a3630370bd081ffb14f453789acb26a304690fbe916deb6063d0ae5f415b796928528f764339778b51a2010ffa684162c0bc9ff1e
diff --git a/kde-misc/wacomtablet/wacomtablet-3.0.0_beta2.ebuild b/kde-misc/wacomtablet/wacomtablet-3.0.0_beta2.ebuild
new file mode 100644
index 000000000000..9483bf055810
--- /dev/null
+++ b/kde-misc/wacomtablet/wacomtablet-3.0.0_beta2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PV="2.9.82" # avoid downgrade after upstream lowered version for beta2
+MY_P=${PN}-${MY_PV}
+KDE_HANDBOOK="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KControl module for Wacom tablets"
+HOMEPAGE="https://www.linux-apps.com/content/show.php?action=content&content=114856"
+SRC_URI="mirror://kde/unstable/${PN}/${MY_PV}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kglobalaccel)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep plasma)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ >=x11-drivers/xf86-input-wacom-0.20.0
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXi
+ x11-libs/libXrandr
+"
+DEPEND="${CDEPEND}
+ sys-devel/gettext
+ x11-proto/xproto
+"
+RDEPEND="${CDEPEND}
+ !kde-misc/wacomtablet:4
+"
+
+S="${WORKDIR}/${MY_P}"