summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2019-03-19 19:22:10 +0200
committerPatrice Clement <monsieurp@gentoo.org>2019-03-20 22:35:22 +0100
commitf2ff5819b7af9d93a882eb5c3951b4dcd7360567 (patch)
tree09a4412ed3c69c35014024572fb9def8cbe96171
parentmedia-sound/teamspeak-server: drop old version. (diff)
downloadgentoo-f2ff5819b7af9d93a882eb5c3951b4dcd7360567.tar.gz
gentoo-f2ff5819b7af9d93a882eb5c3951b4dcd7360567.tar.bz2
gentoo-f2ff5819b7af9d93a882eb5c3951b4dcd7360567.zip
dev-python/cssutils: add support for Python3.7, EAPI 7.
Closes: https://bugs.gentoo.org/679494 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/11354 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--dev-python/cssutils/cssutils-1.0.2-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/cssutils/cssutils-1.0.2-r1.ebuild b/dev-python/cssutils/cssutils-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..0542c6dff73a
--- /dev/null
+++ b/dev-python/cssutils/cssutils-1.0.2-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A CSS Cascading Style Sheets library"
+HOMEPAGE="https://pypi.org/project/cssutils/ https://bitbucket.org/cthedot/cssutils http://cthedot.de/cssutils/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # Disable test failing with dev-python/pyxml installed.
+ if has_version dev-python/pyxml; then
+ sed -e "s/test_linecol/_&/" \
+ -i src/cssutils/tests/test_errorhandler.py \
+ || die
+ fi
+
+ # requires old pbr, does it really?
+ sed \
+ -e '/tests_require/d' \
+ -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ ln -s "${S}/sheets" "${BUILD_DIR}/sheets" || die
+ # esetup.py test
+ # exclude tests that connect to the network
+ set -- nosetests \
+ -e test_parseUrl -e test_handlers -P "${BUILD_DIR}/lib/cssutils/tests"
+ echo "$@"
+ "$@" || die "Testing failed with ${EPYTHON}"
+}