summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2015-09-26 13:27:04 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2015-09-26 13:27:04 +0100
commitf48ffef3726fbd7e2d025382adbc810c6321055d (patch)
tree31c1bbbc0be08d728b5e107f60da3cffb6daea9b
parentdev-haskell/hsb2hs: amd64 x86 stable, bug #561100 (diff)
downloadgentoo-f48ffef3726fbd7e2d025382adbc810c6321055d.tar.gz
gentoo-f48ffef3726fbd7e2d025382adbc810c6321055d.tar.bz2
gentoo-f48ffef3726fbd7e2d025382adbc810c6321055d.zip
dev-haskell/aeson: disable USE=developer, bug #561100
Flag only enables -Werror. Reported-by: Paul Osmialowski Package-Manager: portage-2.2.20
-rw-r--r--dev-haskell/aeson/aeson-0.6.2.1.ebuild5
-rw-r--r--dev-haskell/aeson/aeson-0.7.0.6.ebuild5
-rw-r--r--dev-haskell/aeson/aeson-0.8.0.2.ebuild5
-rw-r--r--dev-haskell/aeson/aeson-0.9.0.1.ebuild5
-rw-r--r--dev-haskell/aeson/metadata.xml3
5 files changed, 12 insertions, 11 deletions
diff --git a/dev-haskell/aeson/aeson-0.6.2.1.ebuild b/dev-haskell/aeson/aeson-0.6.2.1.ebuild
index 030f1461470f..81c8ec6cee7f 100644
--- a/dev-haskell/aeson/aeson-0.6.2.1.ebuild
+++ b/dev-haskell/aeson/aeson-0.6.2.1.ebuild
@@ -5,6 +5,7 @@
EAPI=5
# ebuild generated by hackport 0.3.4.9999
+#hackport: flags: -developer
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
@@ -16,7 +17,7 @@ SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="amd64 x86"
-IUSE="developer"
+IUSE=""
RDEPEND=">=dev-haskell/attoparsec-0.8.6.1:=[profile?]
>=dev-haskell/blaze-builder-0.2.1.4:=[profile?]
@@ -38,5 +39,5 @@ DEPEND="${RDEPEND}
src_configure() {
haskell-cabal_src_configure \
- $(cabal_flag developer developer)
+ --flag=-developer
}
diff --git a/dev-haskell/aeson/aeson-0.7.0.6.ebuild b/dev-haskell/aeson/aeson-0.7.0.6.ebuild
index 222eaa47b052..d0ccc7a8bc6c 100644
--- a/dev-haskell/aeson/aeson-0.7.0.6.ebuild
+++ b/dev-haskell/aeson/aeson-0.7.0.6.ebuild
@@ -5,6 +5,7 @@
EAPI=5
# ebuild generated by hackport 0.4.9999
+#hackport: flags: -developer
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
@@ -16,7 +17,7 @@ SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="amd64 x86"
-IUSE="developer"
+IUSE=""
RDEPEND=">=dev-haskell/attoparsec-0.11.3.4:=[profile?]
>=dev-haskell/blaze-builder-0.2.1.4:=[profile?]
@@ -45,5 +46,5 @@ DEPEND="${RDEPEND}
src_configure() {
haskell-cabal_src_configure \
- $(cabal_flag developer developer)
+ --flag=-developer
}
diff --git a/dev-haskell/aeson/aeson-0.8.0.2.ebuild b/dev-haskell/aeson/aeson-0.8.0.2.ebuild
index 154ccf2231e6..896531926374 100644
--- a/dev-haskell/aeson/aeson-0.8.0.2.ebuild
+++ b/dev-haskell/aeson/aeson-0.8.0.2.ebuild
@@ -5,6 +5,7 @@
EAPI=5
# ebuild generated by hackport 0.4.4.9999
+#hackport: flags: -developer
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
@@ -16,7 +17,7 @@ SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
-IUSE="developer"
+IUSE=""
RDEPEND=">=dev-haskell/attoparsec-0.11.3.4:=[profile?]
>=dev-haskell/dlist-0.2:=[profile?]
@@ -40,5 +41,5 @@ DEPEND="${RDEPEND}
src_configure() {
haskell-cabal_src_configure \
- $(cabal_flag developer developer)
+ --flag=-developer
}
diff --git a/dev-haskell/aeson/aeson-0.9.0.1.ebuild b/dev-haskell/aeson/aeson-0.9.0.1.ebuild
index b3a0d2179de6..0032c175ff97 100644
--- a/dev-haskell/aeson/aeson-0.9.0.1.ebuild
+++ b/dev-haskell/aeson/aeson-0.9.0.1.ebuild
@@ -5,6 +5,7 @@
EAPI=5
# ebuild generated by hackport 0.4.5.9999
+#hackport: flags: -developer
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
@@ -16,7 +17,7 @@ SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
-IUSE="developer"
+IUSE=""
RDEPEND=">=dev-haskell/attoparsec-0.13.0.0:=[profile?]
>=dev-haskell/dlist-0.2:=[profile?]
@@ -42,5 +43,5 @@ DEPEND="${RDEPEND}
src_configure() {
haskell-cabal_src_configure \
- $(cabal_flag developer developer)
+ --flag=-developer
}
diff --git a/dev-haskell/aeson/metadata.xml b/dev-haskell/aeson/metadata.xml
index 469476ebde4e..e574d49e7e8b 100644
--- a/dev-haskell/aeson/metadata.xml
+++ b/dev-haskell/aeson/metadata.xml
@@ -64,9 +64,6 @@
(A note on naming: in Greek mythology, Aeson was the father of Jason.)
</longdescription>
- <use>
- <flag name="developer">Operate in developer mode.'</flag>
- </use>
<upstream>
<remote-id type="github">bos/aeson</remote-id>
</upstream>