summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-05-01 10:47:29 +0200
committerDavid Seifert <soap@gentoo.org>2017-05-01 10:48:27 +0200
commitf96504daab52bd8c531d1c859d5dd935fc97c607 (patch)
tree8765ff6a648d9e716b7dde053d6a0a3257a10d58
parentkde-plasma/plasma-workspace: Also remove kio_remote.po (diff)
downloadgentoo-f96504daab52bd8c531d1c859d5dd935fc97c607.tar.gz
gentoo-f96504daab52bd8c531d1c859d5dd935fc97c607.tar.bz2
gentoo-f96504daab52bd8c531d1c859d5dd935fc97c607.zip
media-sound/drumstick: Port to EAPI 6
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--media-sound/drumstick/drumstick-0.5.0.ebuild22
-rw-r--r--media-sound/drumstick/files/0.5.0-gcc6-narrowing.patch26
-rw-r--r--media-sound/drumstick/files/0.5.0-underlinking.patch4
3 files changed, 38 insertions, 14 deletions
diff --git a/media-sound/drumstick/drumstick-0.5.0.ebuild b/media-sound/drumstick/drumstick-0.5.0.ebuild
index ccd46d95d566..23e0adbaad10 100644
--- a/media-sound/drumstick/drumstick-0.5.0.ebuild
+++ b/media-sound/drumstick/drumstick-0.5.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=6
-inherit base cmake-utils fdo-mime gnome2-utils
+inherit fdo-mime gnome2-utils cmake-utils
DESCRIPTION="Qt4/C++ wrapper for ALSA sequencer"
HOMEPAGE="http://drumstick.sourceforge.net/"
@@ -14,7 +14,8 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE="dbus doc"
-RDEPEND="media-libs/alsa-lib
+RDEPEND="
+ media-libs/alsa-lib
dev-qt/qtgui:4
dev-qt/qtsvg:4
x11-misc/shared-mime-info
@@ -25,29 +26,26 @@ DEPEND="${RDEPEND}
app-doc/doxygen
app-text/docbook-xsl-stylesheets
dev-libs/libxslt
- )
-"
-
-DOCS=( AUTHORS ChangeLog NEWS README TODO )
+ )"
PATCHES=(
"${FILESDIR}"/${PV}-doc_automagicness.patch
"${FILESDIR}"/${PV}-underlinking.patch
+ "${FILESDIR}"/${PV}-gcc6-narrowing.patch
)
src_prepare() {
sed -i \
-e '/CMAKE_EXE_LINKER_FLAGS/d' \
CMakeLists.txt || die
- base_src_prepare
+ cmake-utils_src_prepare
}
src_configure() {
local mycmakeargs=(
- $(cmake-utils_use_use dbus)
- $(cmake-utils_use_with doc)
+ -DUSE_DBUS=$(usex dbus)
+ -DWITH_DOC=$(usex doc)
)
-
cmake-utils_src_configure
}
diff --git a/media-sound/drumstick/files/0.5.0-gcc6-narrowing.patch b/media-sound/drumstick/files/0.5.0-gcc6-narrowing.patch
new file mode 100644
index 000000000000..165db470592e
--- /dev/null
+++ b/media-sound/drumstick/files/0.5.0-gcc6-narrowing.patch
@@ -0,0 +1,26 @@
+Fix GCC 6 failures caused by -Wnarrowing
+
+--- a/utils/buildsmf/buildsmf.cpp
++++ b/utils/buildsmf/buildsmf.cpp
+@@ -53,8 +53,8 @@
+ m_engine->writeKeySignature(0, 2, major_mode); // D major (2 sharps)
+
+ // system exclusive event
+- static char gsreset[] = { 0xf0, 0x41, 0x10, 0x42, 0x12,
+- 0x40, 0x00, 0x7f, 0x00, 0x41, 0xf7 };
++ static char gsreset[] = { (char)0xf0, 0x41, 0x10, 0x42, 0x12,
++ 0x40, 0x00, 0x7f, 0x00, 0x41, (char)0xf7 };
+ m_engine->writeMidiEvent(0, system_exclusive, sizeof(gsreset), gsreset);
+
+ // some note events
+--- a/utils/testevents/testevents.cpp
++++ b/utils/testevents/testevents.cpp
+@@ -262,7 +262,7 @@
+ dumpEvent(new KeyPressEvent(5, 60, 124));
+ dumpEvent(new ChanPressEvent(6, 111));
+ dumpEvent(new PitchBendEvent(7, 1234));
+- char sysex[] = {0xf0, 0x41, 0x10, 0x42, 0x12, 0x40, 0, 0x7f, 0, 0x41, 0xf7};
++ char sysex[] = {(char)0xf0, 0x41, 0x10, 0x42, 0x12, 0x40, 0, 0x7f, 0, 0x41, (char)0xf7};
+ dumpEvent(new SysExEvent(QByteArray(sysex, sizeof(sysex))));
+ QString text = "This can be a copyright, song name, instrument, lyric...";
+ TextEvent te(text, 3);
diff --git a/media-sound/drumstick/files/0.5.0-underlinking.patch b/media-sound/drumstick/files/0.5.0-underlinking.patch
index 1bb5ae7da3bf..1ec4fd186029 100644
--- a/media-sound/drumstick/files/0.5.0-underlinking.patch
+++ b/media-sound/drumstick/files/0.5.0-underlinking.patch
@@ -1,5 +1,5 @@
---- utils/vpiano/CMakeLists.txt
-+++ utils/vpiano/CMakeLists.txt
+--- a/utils/vpiano/CMakeLists.txt
++++ b/utils/vpiano/CMakeLists.txt
@@ -1,3 +1,5 @@
+find_package(X11 REQUIRED)
+