summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2019-02-19 10:49:54 -0500
committerAnthony G. Basile <blueness@gentoo.org>2019-02-19 10:52:36 -0500
commitfb85935b024b19afbe2ce55d863b3e43b52e3d1e (patch)
tree2abe829c5c10c61ebed8dcdedc896963b03f1fbe
parentsys-apps/systemd: arm64 stable (bug #677944) (diff)
downloadgentoo-fb85935b024b19afbe2ce55d863b3e43b52e3d1e.tar.gz
gentoo-fb85935b024b19afbe2ce55d863b3e43b52e3d1e.tar.bz2
gentoo-fb85935b024b19afbe2ce55d863b3e43b52e3d1e.zip
sys-libs/queue-standalone: use insinto/doins instead of a direct cp
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--sys-libs/queue-standalone/queue-standalone-0.1-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/sys-libs/queue-standalone/queue-standalone-0.1-r1.ebuild b/sys-libs/queue-standalone/queue-standalone-0.1-r1.ebuild
new file mode 100644
index 000000000000..618545bae974
--- /dev/null
+++ b/sys-libs/queue-standalone/queue-standalone-0.1-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Install <sys/queue.h> from glibc."
+HOMEPAGE="https://www.gnu.org/software/libc/libc.html"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~x86"
+
+DEPEND="
+ !sys-libs/glibc
+ !sys-libs/uclibc"
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /usr/include/sys
+ doins "${FILESDIR}"/queue.h
+}