summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRodrigo Saboya <saboya@users.noreply.github.com>2019-10-05 11:33:44 -0300
committerZac Medico <zmedico@gentoo.org>2019-10-06 10:55:16 -0700
commitfee1f9715908668dac34d6f53ee81c59d23ce5c1 (patch)
treeb21400ff8a935608a288bf50d2966e2c07ea641d
parentnet-p2p/ktorrent: Drop 5.1.2-r1 (diff)
downloadgentoo-fee1f9715908668dac34d6f53ee81c59d23ce5c1.tar.gz
gentoo-fee1f9715908668dac34d6f53ee81c59d23ce5c1.tar.bz2
gentoo-fee1f9715908668dac34d6f53ee81c59d23ce5c1.zip
sys-apps/yarn: Bumping to 1.19.0
Closes: https://github.com/gentoo/gentoo/pull/13163 Closes: https://bugs.gentoo.org/696762 Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Rodrigo Saboya <saboya@gmail.com> Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--sys-apps/yarn/Manifest1
-rw-r--r--sys-apps/yarn/yarn-1.19.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-apps/yarn/Manifest b/sys-apps/yarn/Manifest
index be981e0d2fbc..dae8824ee59b 100644
--- a/sys-apps/yarn/Manifest
+++ b/sys-apps/yarn/Manifest
@@ -4,4 +4,5 @@ DIST yarn-v1.13.0.tar.gz 1169613 BLAKE2B 5fc730c0b456d67702ef5305223cfd933c4c8f1
DIST yarn-v1.15.2.tar.gz 1169927 BLAKE2B 1ebf899b1f34dd3b6fea4fa001b1edda62dd4c8964099b8a1bc858a1b28b7ccbab3aa3e229bc7882892763db414ed4f7cfbe2deb636d2a8675da87df1754a835 SHA512 0e1a9a19ed8571829db8ee36776841c9793bcbc936938d87deecd875604c4ef70d72058ac7bc429095ac540422917bda1103761b224daf3f026e8a9499a051af
DIST yarn-v1.16.0.tar.gz 1172930 BLAKE2B 1dbb754ae0af3b9666bb03057f587854407b3587fc4304e8282c759d5ea0cbee12eed58e526808893d3cf8e29c4ec69b13a28acccc6f6908bcdb8c9126d1a408 SHA512 71f7a6c8696758a035ce8a5452079b4cf7fc0b85a43c867e4c99a4970704009e2eea858fb49780cebb1a99a18687ff9bd5759ef16e75cb3008982e0059b591d6
DIST yarn-v1.17.3.tar.gz 1240577 BLAKE2B a5b0fdd014928181da63a322bdc030e4aefd4033d27f49a37225aa2cb3199339dd06e9f74aaa442bfb4692b0470fda40102a41b52a1369c8b84282bae5bc46a6 SHA512 0a003ca3b9d165a42f99e17f581c76142edff56ff45f9f53d8868b62a80ca3aeb7ef07e9e66304b0cdd85e826d294b299e998324a97f8061619ea4beb0e37b84
+DIST yarn-v1.19.0.tar.gz 1242633 BLAKE2B 55aacab6e44c0a44f39ef9e116444043784272ab3d328f44e818cc45a94203f6e73a6d66f51dbdec46a0694890817dde3148be0fc3c931de79c0e2164f5e755f SHA512 40b88ca23f991e8da44f5ef1d6dedeaceea0cd1fbdc526b9cfb2e67a2d6a60cd528f7ef088816febb910707fa792c86c3b47f4dc89970a57e410a5209ec32b79
DIST yarn-v1.9.4.tar.gz 937393 BLAKE2B 188e270b2a8b5b357b85101eda2552d675e3f41d30bc7b45266f34831cbcfc00feefe452c420f3aaefad7423c2af342d5fdb859ec6420faf689b680b5acda00f SHA512 1e3a908cf47a2fe46d7ce8db549b91cd0b3372c7c43c6b0029f1060b044a0a65e5bc3323f4ed6baf20bbbcb49ba358a6bb8f2691a591e4d3e8a01bc31372cb5b
diff --git a/sys-apps/yarn/yarn-1.19.0.ebuild b/sys-apps/yarn/yarn-1.19.0.ebuild
new file mode 100644
index 000000000000..6366d1485234
--- /dev/null
+++ b/sys-apps/yarn/yarn-1.19.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="${PN}-v${PV}"
+
+DESCRIPTION="Fast, reliable, and secure node dependency management"
+HOMEPAGE="https://yarnpkg.com"
+SRC_URI="https://github.com/yarnpkg/yarn/releases/download/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!dev-util/cmdtest
+ net-libs/nodejs"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ sed -i 's/"installationMethod": "tar"/"installationMethod": "portage"/g' "${S}/package.json" || die
+}
+
+src_install() {
+ local install_dir="/usr/$(get_libdir)/node_modules/yarn" path shebang
+ insinto "${install_dir}"
+ doins -r .
+ dosym "../$(get_libdir)/node_modules/yarn/bin/yarn.js" "/usr/bin/yarn"
+
+ while read -r -d '' path; do
+ read -r shebang < "${ED}${path}" || die
+ [[ "${shebang}" == \#\!* ]] || continue
+ fperms +x "${path}"
+ done < <(find "${ED}" -type f -printf '/%P\0' || die)
+}