summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-08-31 01:34:31 +0300
committerMart Raudsepp <leio@gentoo.org>2018-08-31 01:53:45 +0300
commit7439891c294714fa8fa9598defae766ece517c2b (patch)
treeb5e3609af95ceedddaaf8745409709900e7e4784 /app-accessibility
parentdev-util/re2c: bump up to 1.1.1 (diff)
downloadgentoo-7439891c294714fa8fa9598defae766ece517c2b.tar.gz
gentoo-7439891c294714fa8fa9598defae766ece517c2b.tar.bz2
gentoo-7439891c294714fa8fa9598defae766ece517c2b.zip
app-accessibility/at-spi2-core: bump to 2.26.2
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/at-spi2-core/Manifest1
-rw-r--r--app-accessibility/at-spi2-core/at-spi2-core-2.26.2.ebuild55
-rw-r--r--app-accessibility/at-spi2-core/files/2.26.2-fix-inverted-logic.patch28
3 files changed, 84 insertions, 0 deletions
diff --git a/app-accessibility/at-spi2-core/Manifest b/app-accessibility/at-spi2-core/Manifest
index 901f45fa8f7a..6ea0e4c38af5 100644
--- a/app-accessibility/at-spi2-core/Manifest
+++ b/app-accessibility/at-spi2-core/Manifest
@@ -1,2 +1,3 @@
DIST at-spi2-core-2.22.1.tar.xz 454048 BLAKE2B 5ee4cdb83815258d9be8b81870b590b2f85311acf75e3c830c00092cbe5dd66a07f933318ce7d4bc308308f6f87e46579b30948b67b8b7f753adc5e10589246b SHA512 2376b57ce744351ed09a13cd02f0c02264c0998860710cfcdac59f0efb78061512986f5d7305a2f6c594d70213722f81795620e8cd2c6587c6d3f1335477171f
DIST at-spi2-core-2.24.1.tar.xz 452440 BLAKE2B 2e3e262d507dadbdb8fc5bb1bd60d3dbe8a9c2946228b6dc551d0a9564684d96b1b6cbe29849c1d846b3106b5444a2c6880a10825ba20cca87893f6a52815023 SHA512 e7f354a90204f12d4e464a6b4e4cb27141af3715d7c5ec253bdd2ebe65bc7d191ae7b775c45470a1bd1fe2c0accdd4e84feeb5e1eb1a6c05f3e5e734371027be
+DIST at-spi2-core-2.26.2.tar.xz 494484 BLAKE2B 0c67cea9c0107fb6503a933de134eb662f192ae2a98734bde1b0629da151476858720d2dcb1791a00a44b61ae2ead945178fba659f88303c552567d7f3f9817b SHA512 6a8e158e30c37ce475467b6634aff046a318875271966d7bfa3e56052d0cd26cd37435d0b9ae14f079542b8b3e76088da5bd50ed39eb39f3f40394c55ed3f255
diff --git a/app-accessibility/at-spi2-core/at-spi2-core-2.26.2.ebuild b/app-accessibility/at-spi2-core/at-spi2-core-2.26.2.ebuild
new file mode 100644
index 000000000000..beb3feab8ee2
--- /dev/null
+++ b/app-accessibility/at-spi2-core/at-spi2-core-2.26.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 multilib-minimal
+
+DESCRIPTION="D-Bus accessibility specifications and registration daemon"
+HOMEPAGE="https://wiki.gnome.org/Accessibility"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+IUSE="X +introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
+
+# x11-libs/libSM is needed until upstream #719808 is solved either
+# making the dep unneeded or fixing their configure
+# Only libX11 is optional right now
+RDEPEND="
+ >=dev-libs/glib-2.36:2[${MULTILIB_USEDEP}]
+ >=sys-apps/dbus-1[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.32.0:= )
+ X? (
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXtst[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.25
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+"
+
+PATCHES=(
+ # disable teamspaces test since that requires Novell.ICEDesktop.Daemon
+ "${FILESDIR}/${PN}-2.0.2-disable-teamspaces-test.patch"
+ "${FILESDIR}/${PV}-fix-inverted-logic.patch"
+)
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ $(multilib_native_use_enable introspection) \
+ $(use_enable X x11)
+
+ # work-around gtk-doc out-of-source brokedness
+ if multilib_is_native_abi; then
+ ln -s "${S}"/doc/libatspi/html doc/libatspi/html || die
+ fi
+}
+
+multilib_src_compile() { gnome2_src_compile; }
+multilib_src_install() { gnome2_src_install; }
diff --git a/app-accessibility/at-spi2-core/files/2.26.2-fix-inverted-logic.patch b/app-accessibility/at-spi2-core/files/2.26.2-fix-inverted-logic.patch
new file mode 100644
index 000000000000..7aa10f8bfc2b
--- /dev/null
+++ b/app-accessibility/at-spi2-core/files/2.26.2-fix-inverted-logic.patch
@@ -0,0 +1,28 @@
+From c2e87fe00b596dba20c9d57d406ab8faa744b15a Mon Sep 17 00:00:00 2001
+From: Maya Rashish <maya@NetBSD.org>
+Date: Sat, 2 Dec 2017 13:24:29 +0200
+Subject: [PATCH] Fix inverted logic.
+
+Don't write more into a buffer than it can hold.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=791124
+---
+ bus/at-spi-bus-launcher.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/bus/at-spi-bus-launcher.c b/bus/at-spi-bus-launcher.c
+index 261353f..eb2b8e3 100644
+--- a/bus/at-spi-bus-launcher.c
++++ b/bus/at-spi-bus-launcher.c
+@@ -244,7 +244,7 @@ unix_read_all_fd_to_string (int fd,
+ {
+ ssize_t bytes_read;
+
+- while (max_bytes > 1 && (bytes_read = read (fd, buf, MAX (4096, max_bytes - 1))))
++ while (max_bytes > 1 && (bytes_read = read (fd, buf, MIN (4096, max_bytes - 1))))
+ {
+ if (bytes_read < 0)
+ return FALSE;
+--
+2.18.0
+