summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2018-04-20 14:06:36 +0200
committerMichał Górny <mgorny@gentoo.org>2018-04-20 14:51:18 +0200
commite640219f933f0afe410374722f721b4ea9a4c201 (patch)
treebde68834e360a4add79f2fac19198f0a27900515 /app-admin/filebeat
parentmedia-sound/teamspeak-server-bin: Group should be also created (diff)
downloadgentoo-e640219f933f0afe410374722f721b4ea9a4c201.tar.gz
gentoo-e640219f933f0afe410374722f721b4ea9a4c201.tar.bz2
gentoo-e640219f933f0afe410374722f721b4ea9a4c201.zip
app-admin/filebeat: bump to 5.6.9
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'app-admin/filebeat')
-rw-r--r--app-admin/filebeat/Manifest1
-rw-r--r--app-admin/filebeat/filebeat-5.6.9.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/app-admin/filebeat/Manifest b/app-admin/filebeat/Manifest
index aca912b54382..3a3256e0e6a2 100644
--- a/app-admin/filebeat/Manifest
+++ b/app-admin/filebeat/Manifest
@@ -1,4 +1,5 @@
DIST filebeat-5.5.2.tar.gz 18075191 BLAKE2B 9786cb8f3db003c86e4bc6d56fcac660b615e7e6ad82d0912f70c545f2af3caab605be739481355466438a1769c20b28db576d208af6b0af9620ce6408068215 SHA512 ad92b41a9ceaad6c6e6fc80d0adccd7fe03a7056d121484bcf35c6a46b2061a5ef6d32121dd12d59b51e7678769da5c405b1d549fa130631ae3f1989b78fba48
DIST filebeat-5.6.5.tar.gz 18145468 BLAKE2B 57f3320012d8c17b7b961dd6d843e982e3cc5fe0f39658ca5ccc2fb9056c8dd4527306b7cfe483d3fa39bef5892dd22c4f07f24aad1e804bd76cdda94b56a3e8 SHA512 f1c8ffa2521e0e15a14850199c3da83d8f8489d5f97364b205ee8120b56e2ae47055c78ed6a5ef2d0296f449339efa05f2d7bce7282b1e7f2e044d7ed3244d4c
+DIST filebeat-5.6.9.tar.gz 18209544 BLAKE2B 41891b984240af46fb3d9d7818203d7ef8fd5a089d7683877e3907061259442da4884976cfefcc90666699ebe3adb1ce6c87a026a50b07e218a5de6b642b9472 SHA512 2aa40afbd0f1c987aebf51d22aa03c87048766a4c7d41938ff27ffca841666d34cfbf08ae120d98d222a7d3ff447bbce9f1d65b434aef1c9d73c5019aa1558a1
DIST filebeat-6.0.1.tar.gz 15150919 BLAKE2B 40149de3257d78a737d71f59f8be91a3bd60185f716ecc89dbe373283ab6481afe709ff573efb8b1079f2c571c6de036bd705dd082c3cba1eda44d282409247c SHA512 baf21acf38409b398f261509d25d2b009342fdde1fcd824c99d16cc279355ae5eb029699a5a7e3b6e58abdbed4ef5fda1b4058ed94b807fd5964ad24828585e2
DIST filebeat-6.1.1.tar.gz 17061456 BLAKE2B 5a5d23618f8140f3815c499305d99ae3dc4c4caa49535043040387922f924ee49a9494b5139f34a70d74173d97332b92909fc74e2f91a2fc0f288ef5d1493ade SHA512 54e85cfce58ba724f6b2892f115ac9ef5b1bb89ce8dc6f2a977e50ccfc07cf95fc578e46e0cadd96acd90c59f4b01446851b93c519afa094ff6dcdb7e716219a
diff --git a/app-admin/filebeat/filebeat-5.6.9.ebuild b/app-admin/filebeat/filebeat-5.6.9.ebuild
new file mode 100644
index 000000000000..4537daa105ba
--- /dev/null
+++ b/app-admin/filebeat/filebeat-5.6.9.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Lightweight log shipper for Logstash and Elasticsearch"
+HOMEPAGE="https://www.elastic.co/products/beats"
+SRC_URI="https://github.com/elastic/beats/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+DEPEND=">=dev-lang/go-1.9.2"
+RDEPEND="!app-admin/filebeat-bin"
+
+S="${WORKDIR}/src/github.com/elastic/beats"
+
+src_unpack() {
+ mkdir -p "${S%/*}" || die
+ default
+ mv beats-${PV} "${S}" || die
+}
+
+src_compile() {
+ GOPATH="${WORKDIR}" emake -C "${S}/filebeat"
+}
+
+src_install() {
+ keepdir /var/{lib,log}/${PN}
+
+ fperms 0750 /var/{lib,log}/${PN}
+
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+
+ docinto examples
+ dodoc ${PN}/{filebeat.yml,filebeat.full.yml}
+
+ insinto "/etc/${PN}"
+ doins ${PN}/{filebeat.template.json,filebeat.template-es2x.json,filebeat.template-es6x.json}
+
+ exeinto "/usr/share/${PN}"
+ doexe libbeat/scripts/migrate_beat_config_1_x_to_5_0.py
+
+ dobin filebeat/filebeat
+}
+
+pkg_postinst() {
+ if [[ -n "${REPLACING_VERSIONS}" ]]; then
+ elog "Please read the migration guide at:"
+ elog "https://www.elastic.co/guide/en/beats/libbeat/5.0/upgrading.html"
+ elog ""
+ elog "The migration script:"
+ elog "${EROOT%/}/usr/share/filebeat/migrate_beat_config_1_x_to_5_0.py"
+ elog ""
+ fi
+
+ elog "Example configurations:"
+ elog "${EROOT%/}/usr/share/doc/${PF}/examples"
+}