summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-02-10 08:31:02 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-02-10 08:31:21 +0100
commit565861fc110056b320482b9e5ea798798e78ac80 (patch)
treefb3b59616d8aa890ba39a7cbdc7e7173357902da /app-admin/keepassxc
parentdev-libs/boost: arm64 ppc ppc64 stable (bug 590244). (diff)
downloadgentoo-565861fc110056b320482b9e5ea798798e78ac80.tar.gz
gentoo-565861fc110056b320482b9e5ea798798e78ac80.tar.bz2
gentoo-565861fc110056b320482b9e5ea798798e78ac80.zip
app-admin/keepassxc: Initial commit (bug #598601).
Thanks to Igor Krivenko for providing the initial ebuild. Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-admin/keepassxc')
-rw-r--r--app-admin/keepassxc/Manifest1
-rw-r--r--app-admin/keepassxc/keepassxc-2.1.1.ebuild65
-rw-r--r--app-admin/keepassxc/keepassxc-9999.ebuild65
-rw-r--r--app-admin/keepassxc/metadata.xml20
4 files changed, 151 insertions, 0 deletions
diff --git a/app-admin/keepassxc/Manifest b/app-admin/keepassxc/Manifest
new file mode 100644
index 000000000000..a9e32c469656
--- /dev/null
+++ b/app-admin/keepassxc/Manifest
@@ -0,0 +1 @@
+DIST keepassxc-2.1.1.tar.gz 3274143 SHA256 b0a737640070d80483b2ac436d87c2872a248f60f86b741e5413b0b8cda92eef SHA512 7ec2aab5b5e87036b3c778fd9b24612a35ac80243c009da9151f0a8aca9b7065c6652bc595be2958cd4fd96c5c8937cc7ce668c47d34267b7e014c3117a32e72 WHIRLPOOL 5cb6a85c58e28eeff8f11bb70a8b949e15e0f97769c73844474abab321c40f81c6a23b3efe1c05ce5e8e8623c7feb3e38d64cda88b13fedc651a722a3607806f
diff --git a/app-admin/keepassxc/keepassxc-2.1.1.ebuild b/app-admin/keepassxc/keepassxc-2.1.1.ebuild
new file mode 100644
index 000000000000..abb4ee36cb42
--- /dev/null
+++ b/app-admin/keepassxc/keepassxc-2.1.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+SCM=""
+[[ "${PV}" == 9999 ]] && SCM="git-r3"
+inherit cmake-utils ${SCM}
+unset SCM
+
+DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition"
+HOMEPAGE="https://github.com/keepassxreboot/keepassxc"
+
+if [[ "${PV}" != 9999 ]] ; then
+ SRC_URI="https://github.com/keepassxreboot/keepassxc/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+else
+ EGIT_REPO_URI="https://github.com/keepassxreboot/${PN}"
+fi
+
+LICENSE="LGPL-2.1 GPL-2 GPL-3"
+SLOT="0"
+IUSE="autotype debug http test"
+
+RDEPEND="
+ dev-libs/libgcrypt:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ net-libs/libmicrohttpd
+ sys-libs/zlib
+ autotype? (
+ dev-qt/qtx11extras:5
+ x11-libs/libXi
+ x11-libs/libXtst
+ )
+"
+ #yubikey? ( sys-auth/libyubikey )
+
+DEPEND="
+ ${RDEPEND}
+ dev-qt/linguist-tools:5
+ dev-qt/qtconcurrent:5
+ test? ( dev-qt/qttest:5 )
+"
+
+src_prepare() {
+ use test || \
+ sed -e "/^find_package(Qt5Test/d" -i CMakeLists.txt || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_GUI_TESTS=OFF
+ -DWITH_TESTS="$(usex test)"
+ -DWITH_XC_AUTOTYPE="$(usex autotype)"
+ -DWITH_XC_HTTP="$(usex http)"
+ #-DWITH_XC_YUBIKEY="$(usex yubikey)"
+ )
+ cmake-utils_src_configure
+}
diff --git a/app-admin/keepassxc/keepassxc-9999.ebuild b/app-admin/keepassxc/keepassxc-9999.ebuild
new file mode 100644
index 000000000000..df26042207bd
--- /dev/null
+++ b/app-admin/keepassxc/keepassxc-9999.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+SCM=""
+[[ "${PV}" == 9999 ]] && SCM="git-r3"
+inherit cmake-utils ${SCM}
+unset SCM
+
+DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition"
+HOMEPAGE="https://github.com/keepassxreboot/keepassxc"
+
+if [[ "${PV}" != 9999 ]] ; then
+ SRC_URI="https://github.com/keepassxreboot/keepassxc/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+else
+ EGIT_REPO_URI="https://github.com/keepassxreboot/${PN}"
+fi
+
+LICENSE="LGPL-2.1 GPL-2 GPL-3"
+SLOT="0"
+IUSE="autotype debug http test"
+
+RDEPEND="
+ dev-libs/libgcrypt:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ net-libs/libmicrohttpd
+ sys-libs/zlib
+ autotype? (
+ dev-qt/qtx11extras:5
+ x11-libs/libXi
+ x11-libs/libXtst
+ )
+"
+# yubikey? ( sys-auth/libyubikey )
+
+DEPEND="
+ ${RDEPEND}
+ dev-qt/linguist-tools:5
+ dev-qt/qtconcurrent:5
+ test? ( dev-qt/qttest:5 )
+"
+
+src_prepare() {
+ use test || \
+ sed -e "/^find_package(Qt5Test/d" -i CMakeLists.txt || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_GUI_TESTS=OFF
+ -DWITH_TESTS="$(usex test)"
+ -DWITH_XC_AUTOTYPE="$(usex autotype)"
+ -DWITH_XC_HTTP="$(usex http)"
+ #-DWITH_XC_YUBIKEY="$(usex yubikey)"
+ )
+ cmake-utils_src_configure
+}
diff --git a/app-admin/keepassxc/metadata.xml b/app-admin/keepassxc/metadata.xml
new file mode 100644
index 000000000000..fe942b6d2542
--- /dev/null
+++ b/app-admin/keepassxc/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+ </maintainer>
+ <use>
+ <flag name="autotype">Add support to autotype the passwords into other applications</flag>
+ <flag name="http">Add http support</flag>
+ </use>
+ <longdescription>
+ KeePassXC provides a safe location for your passwords and similar
+ data. It encrypts its databasee with AES either by passphrase or a key
+ file, compatible with a PDA and Windows version.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">keepassxreboot/keepassxc</remote-id>
+ </upstream>
+</pkgmetadata>