summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-24 00:31:33 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-31 11:09:36 +0100
commit8757085ff45841a5801ef65faa258bb2866233d8 (patch)
treef1892d691daa00dac9e4a11b570f96b2e4218ae0 /app-admin/keepassxc
parentprofiles: Unmask app-text/poppler-0.84.0 (diff)
downloadgentoo-8757085ff45841a5801ef65faa258bb2866233d8.tar.gz
gentoo-8757085ff45841a5801ef65faa258bb2866233d8.tar.bz2
gentoo-8757085ff45841a5801ef65faa258bb2866233d8.zip
*/*: Switch polynomial-c maintained packages to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-admin/keepassxc')
-rw-r--r--app-admin/keepassxc/keepassxc-2.4.3-r1.ebuild6
-rw-r--r--app-admin/keepassxc/keepassxc-2.5.0.ebuild6
-rw-r--r--app-admin/keepassxc/keepassxc-2.5.1.ebuild6
-rw-r--r--app-admin/keepassxc/keepassxc-9999.ebuild6
4 files changed, 12 insertions, 12 deletions
diff --git a/app-admin/keepassxc/keepassxc-2.4.3-r1.ebuild b/app-admin/keepassxc/keepassxc-2.4.3-r1.ebuild
index 914683fba0df..83eb419c1194 100644
--- a/app-admin/keepassxc/keepassxc-2.4.3-r1.ebuild
+++ b/app-admin/keepassxc/keepassxc-2.4.3-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg
+inherit cmake xdg
DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition"
HOMEPAGE="https://keepassxc.org"
@@ -66,7 +66,7 @@ src_prepare() {
use test || \
sed -e "/^find_package(Qt5Test/d" -i CMakeLists.txt || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -84,7 +84,7 @@ src_configure() {
if [[ "${PV}" == *_beta* ]] ; then
mycmakeargs+=( -DOVERRIDE_VERSION="${PV/_/-}" )
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_preinst() {
diff --git a/app-admin/keepassxc/keepassxc-2.5.0.ebuild b/app-admin/keepassxc/keepassxc-2.5.0.ebuild
index 75059bb064ab..344be63f0741 100644
--- a/app-admin/keepassxc/keepassxc-2.5.0.ebuild
+++ b/app-admin/keepassxc/keepassxc-2.5.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg
+inherit cmake xdg
DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition"
HOMEPAGE="https://keepassxc.org"
@@ -67,7 +67,7 @@ src_prepare() {
use test || \
sed -e "/^find_package(Qt5Test/d" -i CMakeLists.txt || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -86,7 +86,7 @@ src_configure() {
if [[ "${PV}" == *_beta* ]] ; then
mycmakeargs+=( -DOVERRIDE_VERSION="${PV/_/-}" )
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_preinst() {
diff --git a/app-admin/keepassxc/keepassxc-2.5.1.ebuild b/app-admin/keepassxc/keepassxc-2.5.1.ebuild
index 75059bb064ab..344be63f0741 100644
--- a/app-admin/keepassxc/keepassxc-2.5.1.ebuild
+++ b/app-admin/keepassxc/keepassxc-2.5.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg
+inherit cmake xdg
DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition"
HOMEPAGE="https://keepassxc.org"
@@ -67,7 +67,7 @@ src_prepare() {
use test || \
sed -e "/^find_package(Qt5Test/d" -i CMakeLists.txt || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -86,7 +86,7 @@ src_configure() {
if [[ "${PV}" == *_beta* ]] ; then
mycmakeargs+=( -DOVERRIDE_VERSION="${PV/_/-}" )
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_preinst() {
diff --git a/app-admin/keepassxc/keepassxc-9999.ebuild b/app-admin/keepassxc/keepassxc-9999.ebuild
index 75059bb064ab..344be63f0741 100644
--- a/app-admin/keepassxc/keepassxc-9999.ebuild
+++ b/app-admin/keepassxc/keepassxc-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg
+inherit cmake xdg
DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition"
HOMEPAGE="https://keepassxc.org"
@@ -67,7 +67,7 @@ src_prepare() {
use test || \
sed -e "/^find_package(Qt5Test/d" -i CMakeLists.txt || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -86,7 +86,7 @@ src_configure() {
if [[ "${PV}" == *_beta* ]] ; then
mycmakeargs+=( -DOVERRIDE_VERSION="${PV/_/-}" )
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_preinst() {