summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-05-16 11:08:33 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-05-16 11:09:31 +0200
commiteaae19a90dacd1d96a8c6c28de9b1968ee77cb88 (patch)
tree0c2c064bb1763c78e36813b9ba00698e41da699a /app-admin/keepassxc
parentsci-electronics/kicad: Fix configuration issue with >=CMake-3.11 (diff)
downloadgentoo-eaae19a90dacd1d96a8c6c28de9b1968ee77cb88.tar.gz
gentoo-eaae19a90dacd1d96a8c6c28de9b1968ee77cb88.tar.bz2
gentoo-eaae19a90dacd1d96a8c6c28de9b1968ee77cb88.zip
app-admin/keepassxc: Fixed compilation with qt-5.11
Thanks to Markus Rathgeb for reporting the bug and providing the fix. Closes: https://bugs.gentoo.org/655844 Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'app-admin/keepassxc')
-rw-r--r--app-admin/keepassxc/files/keepassxc-2.3.3-qt-5.11-edit-entry-widget-includes.patch10
-rw-r--r--app-admin/keepassxc/keepassxc-2.3.3.ebuild4
2 files changed, 14 insertions, 0 deletions
diff --git a/app-admin/keepassxc/files/keepassxc-2.3.3-qt-5.11-edit-entry-widget-includes.patch b/app-admin/keepassxc/files/keepassxc-2.3.3-qt-5.11-edit-entry-widget-includes.patch
new file mode 100644
index 000000000000..c382db5873fc
--- /dev/null
+++ b/app-admin/keepassxc/files/keepassxc-2.3.3-qt-5.11-edit-entry-widget-includes.patch
@@ -0,0 +1,10 @@
+--- a/src/gui/entry/EditEntryWidget.cpp
++++ b/src/gui/entry/EditEntryWidget.cpp
+@@ -32,6 +32,7 @@
+ #include <QMimeData>
+ #include <QEvent>
+ #include <QColorDialog>
++#include <QButtonGroup>
+
+ #include "autotype/AutoType.h"
+ #include "core/Config.h"
diff --git a/app-admin/keepassxc/keepassxc-2.3.3.ebuild b/app-admin/keepassxc/keepassxc-2.3.3.ebuild
index 69a100508278..3641f74e736c 100644
--- a/app-admin/keepassxc/keepassxc-2.3.3.ebuild
+++ b/app-admin/keepassxc/keepassxc-2.3.3.ebuild
@@ -47,6 +47,10 @@ DEPEND="
dev-qt/qtconcurrent:5
"
+PATCHES=(
+ "${FILESDIR}/${P}-qt-5.11-edit-entry-widget-includes.patch" #655844
+)
+
src_prepare() {
use test || \
sed -e "/^find_package(Qt5Test/d" -i CMakeLists.txt || die