summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/mktwpol/mktwpol-0.2.5.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/mktwpol/mktwpol-0.2.5.ebuild')
-rw-r--r--app-admin/mktwpol/mktwpol-0.2.5.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-admin/mktwpol/mktwpol-0.2.5.ebuild b/app-admin/mktwpol/mktwpol-0.2.5.ebuild
new file mode 100644
index 000000000000..ab566371055f
--- /dev/null
+++ b/app-admin/mktwpol/mktwpol-0.2.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Bash scripts to install tripwire and generate tripwire policy files"
+HOMEPAGE="https://sourceforge.net/projects/mktwpol"
+SRC_URI="mirror://sourceforge/mktwpol/${P}.tar.gz"
+
+LICENSE="CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="app-admin/tripwire"
+
+src_prepare() {
+ sed -i -e 's|/usr/local|/usr|' Makefile || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}
+
+pkg_postinst() {
+ elog
+ elog "Installation and setup of tripwire ..."
+ elog " - Run: \`twsetup.sh\`"
+ elog
+ elog "Maintenance of tripwire as packages are added and/or deleted ..."
+ elog " - Run: \`mktwpol.sh -u\` to update tripwire policy and database"
+ elog
+ elog "Mktwpol is packaged with multiple policy-rules-generating files."
+ elog "The default \"rules file\" is installed in /etc/tripwire"
+ elog "Alternatives are installed in /usr/share/doc/${P}"
+ elog "To use an alternative \"rules file\" ..."
+ elog "copy it to /etc/tripwire, uncompress it, and \`touch\` it ..."
+ elog
+ elog "\`cp /usr/share/doc/${P}/mktwpol*.rules.bz2 /etc/tripwire\`"
+ elog "\`bunzip2 /etc/tripwire/mktwpol*.rules.bz2\`"
+ elog
+ elog "mktwpol.sh uses the rules file with the most recent date."
+ elog "Use \`touch\` to choose between multiple rules files."
+ elog
+}