summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <tmozes@sygic.com>2018-04-26 14:14:58 +0200
committerUltrabug <ultrabug@gentoo.org>2018-05-07 09:39:18 +0200
commit58f3a56fc51cea34b07f078b1652467e45ecc240 (patch)
treea8a768ddb3bb4143379c79394f8501492dee7aab /app-admin/mongo-tools
parentmedia-video/dvdauthor: Use pkg-config to find freetype (diff)
downloadgentoo-58f3a56fc51cea34b07f078b1652467e45ecc240.tar.gz
gentoo-58f3a56fc51cea34b07f078b1652467e45ecc240.tar.bz2
gentoo-58f3a56fc51cea34b07f078b1652467e45ecc240.zip
app-admin/mongo-tools: bump to 3.4.14/3.6.4
Package-Manager: Portage-2.3.31, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/8150
Diffstat (limited to 'app-admin/mongo-tools')
-rw-r--r--app-admin/mongo-tools/Manifest2
-rw-r--r--app-admin/mongo-tools/mongo-tools-3.4.14.ebuild60
-rw-r--r--app-admin/mongo-tools/mongo-tools-3.6.4.ebuild61
3 files changed, 123 insertions, 0 deletions
diff --git a/app-admin/mongo-tools/Manifest b/app-admin/mongo-tools/Manifest
index ae713d8aafde..bf2f10c2a4ca 100644
--- a/app-admin/mongo-tools/Manifest
+++ b/app-admin/mongo-tools/Manifest
@@ -3,5 +3,7 @@ DIST mongo-tools-3.0.15.tar.gz 2413131 BLAKE2B 5f971d6b47685ef8db246a71f59a31a72
DIST mongo-tools-3.2.17.tar.gz 2719970 BLAKE2B 666b67d8abdd10f7fa7c557e3c3906fb3cc6bcfa0b97a05e39e5f1ea923d2beb5ec249b3b0a521c4cce4bd595bf18672d8bce38152f84825bb3fffb058fd3b29 SHA512 62c2540027e07b8276621e08d13657864d16021030e3c8f9bc0d351454319d448f889cf6a48b8467ea3270365376ed0c3beb42ceae3f28357910148c6b4054b2
DIST mongo-tools-3.4.10.tar.gz 4719399 BLAKE2B 8165248bf58f2ea2b02e365a3609c72b72e98dd5902f176e251fa2add1ad26e90900e06c35dc6db4dbe161e541bedfc1776f5e15bbb41dcc9a7be17800424362 SHA512 b861bb3fb1a32c3aa2efefcf6a13bb6d4783ac1a9b006c477fd04deb338cbf6b7adc3944bc6919513b92bd96b8500813ff4af49c9dec0719ebd2fdaa99bc39a5
DIST mongo-tools-3.4.13.tar.gz 4719488 BLAKE2B 27c7716b21f1a23408d0f31aee111c5877f5172121a987c234ff01eb2690bbc71bca4e00fc13b701ca6b91dce0c9aaae43c2239a60a52e130e1390bf5bafef60 SHA512 c233268328ef868ec06c9a9d83009141b39c84ba642e7de7dece3210717ba8de600f39896a30ed23d1577db9f4697c3a8d720cf35248bca2b00a17642b043237
+DIST mongo-tools-3.4.14.tar.gz 4719370 BLAKE2B 2add25ddf9b5b7d2ebecdd647dfb2c818643b16f623fd1faba36a8d6f5a181e80ad47de45fc56e462290f61f6c16c27a6b0587542315981537627256e69b4958 SHA512 a0d715fe36769740ba25e92b742b157dc264b141ddd56d64ca4c6f8ffea11df291ce871aaa723acdb8b7f5318ac1edb8c5fb9dd7bf2edfe08d4e7cef343abea7
DIST mongo-tools-3.6.2.tar.gz 4693924 BLAKE2B 61c44d579f6eb4013ee6c0118ebe89a2d454ef8cf6ad933479885cb71d169185272b03d9c63fa738d67bbd1b9efd4bc964eb17adcc5002508589d198cdb17752 SHA512 5ac2b1d2b33271f63c406c69bd8a576a21f4dcaa6f75839e0f907ebc9968f0e121eb3800e88da050c120856e7ddda4f12d551bb731d4acac0f5cf09f66fc948a
DIST mongo-tools-3.6.3.tar.gz 4693833 BLAKE2B fc7139984cf3dcb7b4ce6f6c2028296651aa59ac68d7068bdf748e28eeb65b1fd9b07580d0c93f3f41dbb01030a12433a07a04deadf28e0ff792387fa78ae4aa SHA512 7dba782c84a728aa9ceb28cbd9934f58b615dccfb238a9dbd63b18661ba4e74ddba21f93d9f12e6d80d293ebe42a82d31fa64448aacdba75bd07d964a5f631fc
+DIST mongo-tools-3.6.4.tar.gz 4693872 BLAKE2B 5d72b32fa8ad7bc106c6ea3c09a27a093b9a1ae2392b4fa534042c5461fdc2b958dcbbf32e0ed596be234921e2ee21cc8f6132d57ae870a234abfc7adbb3b2e9 SHA512 53d06fa4a1b58de8001d6bf6e85f7edc97ce2cfbbb69c1ab05219deaa05ad9dd77d93f98c5526b4f58644a766e1b0f123686358095f059c71a4277634603f23f
diff --git a/app-admin/mongo-tools/mongo-tools-3.4.14.ebuild b/app-admin/mongo-tools/mongo-tools-3.4.14.ebuild
new file mode 100644
index 000000000000..de23914b1110
--- /dev/null
+++ b/app-admin/mongo-tools/mongo-tools-3.4.14.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PV=${PV/_rc/-rc}
+MY_P=${PN}-r${MY_PV}
+
+DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
+HOMEPAGE="https://www.mongodb.org"
+SRC_URI="https://github.com/mongodb/mongo-tools/archive/r${MY_PV}.tar.gz -> mongo-tools-${MY_PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="sasl ssl"
+
+RDEPEND="!<dev-db/mongodb-3.0.0"
+DEPEND="${RDEPEND}
+ dev-lang/go:=
+ net-libs/libpcap
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? ( dev-libs/openssl:0= )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+
+ # do not substitute version because it uses git
+ sed -i '/^sed/,+3d' build.sh || die
+ sed -i '/^mv/d' build.sh || die
+
+ # build pie to avoid text relocations wrt #582854
+ # skip on ppc64 wrt #610984
+ if ! use ppc64; then
+ sed -i 's/\(go build\)/\1 -buildmode=pie/g' build.sh || die
+ fi
+
+ # ensure we use bash wrt #582906
+ sed -i 's@/bin/sh@/bin/bash@g' build.sh || die
+}
+
+src_compile() {
+ local myconf=()
+
+ if use sasl; then
+ myconf+=(sasl)
+ fi
+
+ if use ssl; then
+ myconf+=(ssl)
+ fi
+
+ ./build.sh ${myconf[@]} || die "build failed"
+}
+
+src_install() {
+ dobin bin/*
+}
diff --git a/app-admin/mongo-tools/mongo-tools-3.6.4.ebuild b/app-admin/mongo-tools/mongo-tools-3.6.4.ebuild
new file mode 100644
index 000000000000..f8c4a23a746a
--- /dev/null
+++ b/app-admin/mongo-tools/mongo-tools-3.6.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PV=${PV/_rc/-rc}
+MY_P=${PN}-r${MY_PV}
+
+DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
+HOMEPAGE="https://www.mongodb.org"
+SRC_URI="https://github.com/mongodb/mongo-tools/archive/r${MY_PV}.tar.gz -> mongo-tools-${MY_PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="sasl ssl"
+
+RDEPEND="!<dev-db/mongodb-3.0.0"
+DEPEND="${RDEPEND}
+ dev-lang/go:=
+ net-libs/libpcap
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? ( dev-libs/openssl:0= )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+
+ # do not substitute version because it uses git
+ sed -i '/^sed/,+3d' build.sh || die
+ sed -i '/^stty/d' build.sh || die
+ sed -i '/^mv/d' build.sh || die
+
+ # build pie to avoid text relocations wrt #582854
+ # skip on ppc64 wrt #610984
+ if ! use ppc64; then
+ sed -i 's/\(go build\)/\1 -buildmode=pie/g' build.sh || die
+ fi
+
+ # ensure we use bash wrt #582906
+ sed -i 's@/bin/sh@/bin/bash@g' build.sh || die
+}
+
+src_compile() {
+ local myconf=()
+
+ if use sasl; then
+ myconf+=(sasl)
+ fi
+
+ if use ssl; then
+ myconf+=(ssl)
+ fi
+
+ ./build.sh ${myconf[@]} || die "build failed"
+}
+
+src_install() {
+ dobin bin/*
+}