summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/puppet-lint
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/puppet-lint')
-rw-r--r--app-admin/puppet-lint/Manifest2
-rw-r--r--app-admin/puppet-lint/metadata.xml10
-rw-r--r--app-admin/puppet-lint/puppet-lint-0.3.2.ebuild22
-rw-r--r--app-admin/puppet-lint/puppet-lint-1.1.0.ebuild25
4 files changed, 59 insertions, 0 deletions
diff --git a/app-admin/puppet-lint/Manifest b/app-admin/puppet-lint/Manifest
new file mode 100644
index 000000000000..6910d4cc0f4e
--- /dev/null
+++ b/app-admin/puppet-lint/Manifest
@@ -0,0 +1,2 @@
+DIST puppet-lint-0.3.2.gem 32768 SHA256 ac3051cf39e27fd8ea80a60cb6ca63451b36de3cc2aa0fc768eea8906774da0d SHA512 87a85186f768b48d1043ce2ecc87fd3d3a2aa2ce9a52f91a3a35982310cb88241306eb5bf97f182a1af0928d2a2d6fc278e33dc94849a1f989007958c0c2e7b3 WHIRLPOOL b38c83d84a496a8e5230250293000c796935d0618ee7e0a98db3b7fa752f16364b884f7a8c37fabb710ba047b5a653118f57de0676ac86eeea66e52f3d632b9a
+DIST puppet-lint-1.1.0.gem 43520 SHA256 739f566cd4f1e77b92c1191217fdb59ce12353f3ec2703f30933d2bba877b35b SHA512 65b72ace2d5d9d22994ef9ed2ae2d544c4bf7d24a16b573e04b14668de69c56139949a936ed607045e5a6f11d0260a4d2773b2faab296e21f2e6b81e44f9be6a WHIRLPOOL 5d94bed7cee54617ccf68297dd9668832ea042bb818348e1482a5dea4843e7c2fbc76493ee2ae2ae003735daa09238650ab6b7e47111ad63808a12c87b0b62cf
diff --git a/app-admin/puppet-lint/metadata.xml b/app-admin/puppet-lint/metadata.xml
new file mode 100644
index 000000000000..e2e74b8fd613
--- /dev/null
+++ b/app-admin/puppet-lint/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!--
+$Id$
+-->
+<pkgmetadata>
+<herd>sysadmin</herd>
+<herd>ruby</herd>
+<longdescription>Tim Sharpe's Puppet Linter. Enforces puppetlabs style.</longdescription>
+</pkgmetadata>
diff --git a/app-admin/puppet-lint/puppet-lint-0.3.2.ebuild b/app-admin/puppet-lint/puppet-lint-0.3.2.ebuild
new file mode 100644
index 000000000000..20f1107ffae0
--- /dev/null
+++ b/app-admin/puppet-lint/puppet-lint-0.3.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_EXTRADOC="README*"
+RUBY_FAKEGEM_DOCDIR="html"
+
+inherit eutils ruby-fakegem
+
+DESCRIPTION="A linter for puppet DSL"
+HOMEPAGE="http://puppet-lint.com/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64"
+
+ruby_add_rdepend "dev-ruby/rake"
diff --git a/app-admin/puppet-lint/puppet-lint-1.1.0.ebuild b/app-admin/puppet-lint/puppet-lint-1.1.0.ebuild
new file mode 100644
index 000000000000..562e60310792
--- /dev/null
+++ b/app-admin/puppet-lint/puppet-lint-1.1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit eutils ruby-fakegem
+
+DESCRIPTION="A linter for puppet DSL"
+HOMEPAGE="http://puppet-lint.com/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rspec-its:1
+ dev-ruby/rspec-collection_matchers:1 )"