summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-02-27 13:40:05 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-02-27 13:40:05 -0800
commit2a52395d64188e230da2db88bcc7a9028b27a07b (patch)
treed51193e54363a752cf74e1c72c88d45dde3a6116 /app-admin/salt
parentnet-analyzer/wireshark: Version 2.6.7 (diff)
downloadgentoo-2a52395d64188e230da2db88bcc7a9028b27a07b.tar.gz
gentoo-2a52395d64188e230da2db88bcc7a9028b27a07b.tar.bz2
gentoo-2a52395d64188e230da2db88bcc7a9028b27a07b.zip
app-admin/salt: Version bump to 2018.3.4
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-admin/salt')
-rw-r--r--app-admin/salt/Manifest2
-rw-r--r--app-admin/salt/files/salt-2018.3.4-tests.patch76
-rw-r--r--app-admin/salt/salt-2018.3.4.ebuild (renamed from app-admin/salt/salt-2018.3.3.ebuild)4
3 files changed, 79 insertions, 3 deletions
diff --git a/app-admin/salt/Manifest b/app-admin/salt/Manifest
index 042f649e5845..1ade6a74b5a3 100644
--- a/app-admin/salt/Manifest
+++ b/app-admin/salt/Manifest
@@ -1,3 +1,3 @@
DIST salt-2016.11.10.tar.gz 10058200 BLAKE2B 4b6a42f6bf56421bc19458686ec23a1f945ceeb68b4ce7059fde036ba98d677fc8b61cb0f0c6ab249304b2f07d1b0250f6b91e7c443e12868649bf88f4d44d43 SHA512 e767e2c4c20e3a49a748b2699e4c640610280c0ba1c5955d94daffc7c36991ee632f02a50e338c65b35da146e234c36cc732214174b9bc5cbd62316b9ee40c28
DIST salt-2017.7.8.tar.gz 12060430 BLAKE2B b2dde1b6f43bbb9b9db29b70dfd57591ae0e490e35ec7f4895b68b444ff77f9e997321d73697f791d345756abf451f11891b5f78a97c537c35dfe8bd24c43bbc SHA512 1e5123ee3dc194a33cf5da1e68a0419230b2b4eea26e7f66bf2d64754f0dbef9012abfbd498015f6b675725e580d72abf13c151b106639597337498b1fd42238
-DIST salt-2018.3.3.tar.gz 13953724 BLAKE2B 353f4ee23747f02200116157823b038fc8d361fb88f5f531a147d6c81497ba3f6cebf5a5abf4ac7f81199439bbf8a9cc46e03cdd76bfbb3c39f2b31a6158ca5c SHA512 f00ed83d5ec9d4767d7215fae8569ec560db61a0c8ded17469026e682e367c19811d33c6c53590a275ee24ad897a0eac09d8fde8ae9320d8706d6459ff3cc6da
+DIST salt-2018.3.4.tar.gz 14404085 BLAKE2B 932b30b1ba60aefd3a6874a8ebe4cb6c469d82e31f6acdbe8a5641d09e3316796b5403ef803a355cec6255c1aede8bac3b66af179bd1bbaa5418c7076229cef9 SHA512 f17e06fdbf4741f231d9e769be57de4f6079e9283881b4bafa0d23928d7626a1f9c02b9f49c654b29c3e6ee8ed3d3ddf42c21baecef158ad63a97dc87895b21b
diff --git a/app-admin/salt/files/salt-2018.3.4-tests.patch b/app-admin/salt/files/salt-2018.3.4-tests.patch
new file mode 100644
index 000000000000..ac3dbb845348
--- /dev/null
+++ b/app-admin/salt/files/salt-2018.3.4-tests.patch
@@ -0,0 +1,76 @@
+diff --git a/tests/unit/grains/test_core.py b/tests/unit/grains/test_core.py
+index 3874b0001c..40304075eb 100644
+--- a/tests/unit/grains/test_core.py
++++ b/tests/unit/grains/test_core.py
+@@ -685,22 +685,6 @@ class CoreGrainsTestCase(TestCase, LoaderModuleMockMixin):
+ 'Docker'
+ )
+
+- @skipIf(salt.utils.platform.is_windows(), 'System is Windows')
+- def test_xen_virtual(self):
+- '''
+- Test if OS grains are parsed correctly in Ubuntu Xenial Xerus
+- '''
+- with patch.object(os.path, 'isfile', MagicMock(return_value=False)):
+- with patch.dict(core.__salt__, {'cmd.run': MagicMock(return_value='')}), \
+- patch.object(os.path,
+- 'isfile',
+- MagicMock(side_effect=lambda x: True if x == '/sys/bus/xen/drivers/xenconsole' else False)):
+- log.debug('Testing Xen')
+- self.assertEqual(
+- core._virtual({'kernel': 'Linux'}).get('virtual_subtype'),
+- 'Xen PV DomU'
+- )
+-
+ def _check_ipaddress(self, value, ip_v):
+ '''
+ check if ip address in a list is valid
+diff --git a/tests/unit/utils/test_asynchronous.py b/tests/unit/utils/test_asynchronous.py
+index 694a7aebfe..9e22c278e9 100644
+--- a/tests/unit/utils/test_asynchronous.py
++++ b/tests/unit/utils/test_asynchronous.py
+@@ -35,19 +35,6 @@ class HelperB(object):
+
+
+ class TestSyncWrapper(AsyncTestCase):
+- @tornado.testing.gen_test
+- def test_helpers(self):
+- '''
+- Test that the helper classes do what we expect within a regular asynchronous env
+- '''
+- ha = HelperA()
+- ret = yield ha.sleep()
+- self.assertTrue(ret)
+-
+- hb = HelperB()
+- ret = yield hb.sleep()
+- self.assertFalse(ret)
+-
+ def test_basic_wrap(self):
+ '''
+ Test that we can wrap an asynchronous caller.
+@@ -55,24 +42,3 @@ class TestSyncWrapper(AsyncTestCase):
+ sync = asynchronous.SyncWrapper(HelperA)
+ ret = sync.sleep()
+ self.assertTrue(ret)
+-
+- def test_double(self):
+- '''
+- Test when the asynchronous wrapper object itself creates a wrap of another thing
+-
+- This works fine since the second wrap is based on the first's IOLoop so we
+- don't have to worry about complex start/stop mechanics
+- '''
+- sync = asynchronous.SyncWrapper(HelperB)
+- ret = sync.sleep()
+- self.assertFalse(ret)
+-
+- def test_double_sameloop(self):
+- '''
+- Test asynchronous wrappers initiated from the same IOLoop, to ensure that
+- we don't wire up both to the same IOLoop (since it causes MANY problems).
+- '''
+- a = asynchronous.SyncWrapper(HelperA)
+- sync = asynchronous.SyncWrapper(HelperB, (a,))
+- ret = sync.sleep()
+- self.assertFalse(ret)
diff --git a/app-admin/salt/salt-2018.3.3.ebuild b/app-admin/salt/salt-2018.3.4.ebuild
index deb62df7a934..bf3224ca0de2 100644
--- a/app-admin/salt/salt-2018.3.3.ebuild
+++ b/app-admin/salt/salt-2018.3.4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python2_7 python3_6 )
inherit eutils systemd distutils-r1
@@ -96,7 +96,7 @@ RESTRICT="x86? ( test )"
PATCHES=(
"${FILESDIR}/${PN}-2017.7.0-dont-realpath-tmpdir.patch"
- "${FILESDIR}/${PN}-2017.7.8-tests.patch"
+ "${FILESDIR}/${PN}-2018.3.4-tests.patch"
"${FILESDIR}/${PN}-2018.3.2-skip-zeromq-test-that-hangs.patch"
)