summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-11-29 16:32:48 -0600
committerAlex Brandt <alunduil@gentoo.org>2015-11-29 16:33:39 -0600
commit8d915f4da73c6e38012bf191303509963ab61934 (patch)
tree422e512c8e0f23e39d9d91e6a30eb72d731bac5a /app-admin/supernova/supernova-2.1.0.ebuild
parentwww-client/chromium: dev channel bump (48.0.2564.10) (diff)
downloadgentoo-8d915f4da73c6e38012bf191303509963ab61934.tar.gz
gentoo-8d915f4da73c6e38012bf191303509963ab61934.tar.bz2
gentoo-8d915f4da73c6e38012bf191303509963ab61934.zip
app-admin/supernova: add version 2.1.0
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-admin/supernova/supernova-2.1.0.ebuild')
-rw-r--r--app-admin/supernova/supernova-2.1.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-admin/supernova/supernova-2.1.0.ebuild b/app-admin/supernova/supernova-2.1.0.ebuild
new file mode 100644
index 000000000000..1339eff5ee14
--- /dev/null
+++ b/app-admin/supernova/supernova-2.1.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="novaclient wrapper for multiple nova environments"
+HOMEPAGE="https://github.com/rackerhacker/supernova"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples test"
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="
+ ${CDEPEND}
+ doc? ( >=dev-python/mkdocs-0.14.0[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND="
+ ${CDEPEND}
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ >=dev-python/keyring-0.9.2[${PYTHON_USEDEP}]
+ dev-python/python-novaclient[${PYTHON_USEDEP}]
+ dev-python/rackspace-novaclient[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+python_compile_all() {
+ if use doc; then
+ mkdocs build || die "docs failed to build"
+ fi
+}
+
+python_test() {
+ py.test || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( site/. )
+ use examples && local EXAMPLES=( example_configs/. )
+
+ distutils-r1_python_install_all
+
+ newbashcomp contrib/${PN}-completion.bash ${PN}
+}