summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/verynice
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/verynice')
-rw-r--r--app-admin/verynice/Manifest1
-rw-r--r--app-admin/verynice/files/verynice20
-rw-r--r--app-admin/verynice/files/verynice-1.1-build.patch73
-rw-r--r--app-admin/verynice/files/verynice.service8
-rw-r--r--app-admin/verynice/metadata.xml11
-rw-r--r--app-admin/verynice/verynice-1.1-r2.ebuild33
6 files changed, 146 insertions, 0 deletions
diff --git a/app-admin/verynice/Manifest b/app-admin/verynice/Manifest
new file mode 100644
index 000000000000..241c93d14ae1
--- /dev/null
+++ b/app-admin/verynice/Manifest
@@ -0,0 +1 @@
+DIST verynice-1.1.tar.gz 37576 SHA256 5830fd4ac14ba3677e49159adbb7cd61e3d42d1f0b9aa73e4ed0aa154af6cd8d SHA512 731fa22162bb4f48b943839ccf8ccdc769587e323da11e4a77ad14539a724ffbb89e5f4122e1ab36df3306c507afc958d1125160d34d9cbf55df4dc69e4a0139 WHIRLPOOL ed1b7790aa333497e869830b2aacc3fa2289864e363bef3362ffee115c8afa0eb36b8cc29f255d87b929bb3dec3f8d9e839f30668c4572bccfdfb61f95da07c3
diff --git a/app-admin/verynice/files/verynice b/app-admin/verynice/files/verynice
new file mode 100644
index 000000000000..165b6c114751
--- /dev/null
+++ b/app-admin/verynice/files/verynice
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ after checkroot root
+}
+
+start() {
+ ebegin "Starting verynice"
+ /usr/sbin/verynice -d /var/run/verynice.pid
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping verynice"
+ start-stop-daemon --stop --quiet --pidfile=/var/run/verynice.pid
+ eend $?
+}
diff --git a/app-admin/verynice/files/verynice-1.1-build.patch b/app-admin/verynice/files/verynice-1.1-build.patch
new file mode 100644
index 000000000000..a70202b99300
--- /dev/null
+++ b/app-admin/verynice/files/verynice-1.1-build.patch
@@ -0,0 +1,73 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Wed Dec 26 19:46:44 UTC 2012
+Subject: build system
+
+respect flags, add LDFLAGS to linker line
+fix install rules
+
+--- Makefile
++++ Makefile
+@@ -15,13 +15,15 @@
+ # along with this program; if not, write to the Free Software
+ # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+
+-CC = gcc
++CC ?= gcc
+
+
+ RPM_BUILD_ROOT=
+
+ # PREFIX is usually either /usr or /usr/local
+ PREFIX=/usr/local
++BINDIR=$(PREFIX)/sbin
++ETCDIR=/etc
+ TARGET=linux
+
+
+@@ -32,8 +34,8 @@
+ VERSION=1.1
+
+ #CFLAGS= -I../include/ -O3 -Wimplicit
+-CFLAGS= -I../include/ -g -Wimplicit -DPREFIX=\"$(PREFIX)\" -DTARGET_$(TARGET) -DVERSION=\"$(VERSION)\"
+-LINK = gcc
++CFLAGS += -Wimplicit
++CPPFLAGS = -I../include/ -DPREFIX=\"$(PREFIX)\" -DTARGET_$(TARGET) -DVERSION=\"$(VERSION)\"
+ AG = /home3/sdh4/anagram/ag_unix_dev/ag
+
+
+@@ -55,20 +57,15 @@
+ (cd .. ; tar cvzf verynice-$(VERSION).tar.gz verynice/ )
+
+ install:
+- $(INSTALL) -d $(RPM_BUILD_ROOT)$(PREFIX)/sbin
+- $(INSTALL) verynice $(RPM_BUILD_ROOT)$(PREFIX)/sbin
+- if [ $(PREFIX) = "/usr" ]; then \
+- mv -f $(RPM_BUILD_ROOT)/etc/verynice.conf $(RPM_BUILD_ROOT)/etc/verynice.conf~ ; \
+- $(INSTALL) verynice.conf $(RPM_BUILD_ROOT)/etc ; \
+- else \
+- $(INSTALL) -d $(RPM_BUILD_ROOT)$(PREFIX)/etc ; \
+- mv -f $(RPM_BUILD_ROOT)$(PREFIX)/etc/verynice.conf $(RPM_BUILD_ROOT)$(PREFIX)/etc/verynice.conf~ ; \
+- $(INSTALL) -m 644 verynice.conf $(RPM_BUILD_ROOT)$(PREFIX)/etc ; \
+- fi
++ $(INSTALL) -d $(RPM_BUILD_ROOT)$(BINDIR)
++ $(INSTALL) verynice $(RPM_BUILD_ROOT)$(BINDIR)
++ $(INSTALL) -d $(RPM_BUILD_ROOT)$(ETCDIR)
++ $(INSTALL) -m 644 verynice.conf $(RPM_BUILD_ROOT)$(ETCDIR)
+ $(INSTALL) -d $(RPM_BUILD_ROOT)$(PREFIX)/share
+ $(INSTALL) -d $(RPM_BUILD_ROOT)$(PREFIX)/share/doc
+ $(INSTALL) -d $(RPM_BUILD_ROOT)$(PREFIX)/share/doc/verynice-$(VERSION)
+- $(INSTALL) -m 644 verynice.html $(RPM_BUILD_ROOT)$(PREFIX)/share/doc/verynice-$(VERSION)
++ $(INSTALL) -d $(RPM_BUILD_ROOT)$(PREFIX)/share/doc/verynice-$(VERSION)/html
++ $(INSTALL) -m 644 verynice.html $(RPM_BUILD_ROOT)$(PREFIX)/share/doc/verynice-$(VERSION)/html
+ $(INSTALL) -m 644 README $(RPM_BUILD_ROOT)$(PREFIX)/share/doc/verynice-$(VERSION)
+ $(INSTALL) -m 644 README.SYN $(RPM_BUILD_ROOT)$(PREFIX)/share/doc/verynice-$(VERSION)
+ $(INSTALL) -m 644 COPYING $(RPM_BUILD_ROOT)$(PREFIX)/share/doc/verynice-$(VERSION)
+@@ -95,7 +92,7 @@
+ $(AG) $*
+
+ verynice: verynice.o config.o linklist.o stringstack.o
+- $(LINK) -g -o $@ $^ -lm
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ -lm
+
+
+
diff --git a/app-admin/verynice/files/verynice.service b/app-admin/verynice/files/verynice.service
new file mode 100644
index 000000000000..e85ef4c895b2
--- /dev/null
+++ b/app-admin/verynice/files/verynice.service
@@ -0,0 +1,8 @@
+[Unit]
+Description=A tool for dynamically adjusting the nice-level of processes
+
+[Service]
+ExecStart=/usr/sbin/verynice
+
+[Install]
+WantedBy=multi-user.target
diff --git a/app-admin/verynice/metadata.xml b/app-admin/verynice/metadata.xml
new file mode 100644
index 000000000000..bdc91aaef4c7
--- /dev/null
+++ b/app-admin/verynice/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>hasufell@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ A tool that can dynamically adjust the nice-level of processes under
+ Unix-like operating systems.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-admin/verynice/verynice-1.1-r2.ebuild b/app-admin/verynice/verynice-1.1-r2.ebuild
new file mode 100644
index 000000000000..4332b1288071
--- /dev/null
+++ b/app-admin/verynice/verynice-1.1-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils systemd toolchain-funcs
+
+DESCRIPTION="A tool for dynamically adjusting the nice-level of processes"
+HOMEPAGE="http://thermal.cnde.iastate.edu/~sdh4/verynice/"
+SRC_URI="http://thermal.cnde.iastate.edu/~sdh4/verynice/down/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake RPM_BUILD_ROOT="${D}" PREFIX=/usr
+}
+
+src_install(){
+ emake RPM_BUILD_ROOT="${D}" PREFIX=/usr VERSION=${PVR} install
+ doinitd "${FILESDIR}"/verynice
+ systemd_dounit "${FILESDIR}"/verynice.service
+}