summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-31 04:09:33 +0100
committerSam James <sam@gentoo.org>2021-07-31 23:13:38 +0100
commit2a330638070882a0a9635498c8e6d99aeeca65a8 (patch)
treef954880ff2656336c5a43d619cb9535db5130ea0 /app-admin
parentnet-vpn/openvpn: [QA] call tmpfiles_process in pkg_postinst (diff)
downloadgentoo-2a330638070882a0a9635498c8e6d99aeeca65a8.tar.gz
gentoo-2a330638070882a0a9635498c8e6d99aeeca65a8.tar.bz2
gentoo-2a330638070882a0a9635498c8e6d99aeeca65a8.zip
app-admin/puppet: [QA] call tmpfiles_process in pkg_postinst
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Revbump because the new tmpfiles inherit adds a new dependency (virtual/tmpfiles). Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/puppet/puppet-5.5.22-r1.ebuild (renamed from app-admin/puppet/puppet-5.5.22.ebuild)7
-rw-r--r--app-admin/puppet/puppet-7.8.0-r1.ebuild (renamed from app-admin/puppet/puppet-7.8.0.ebuild)7
-rw-r--r--app-admin/puppet/puppet-7.9.0-r1.ebuild (renamed from app-admin/puppet/puppet-7.9.0.ebuild)7
3 files changed, 12 insertions, 9 deletions
diff --git a/app-admin/puppet/puppet-5.5.22.ebuild b/app-admin/puppet/puppet-5.5.22-r1.ebuild
index d0814cc9e781..a33a8285cc88 100644
--- a/app-admin/puppet/puppet-5.5.22.ebuild
+++ b/app-admin/puppet/puppet-5.5.22-r1.ebuild
@@ -11,7 +11,7 @@ RUBY_FAKEGEM_TASK_DOC="doc:all"
RUBY_FAKEGEM_EXTRAINSTALL="locales"
-inherit ruby-fakegem
+inherit ruby-fakegem tmpfiles
DESCRIPTION="A system automation and configuration management software."
HOMEPAGE="https://puppet.com/"
@@ -88,8 +88,7 @@ all_ruby_install() {
doins "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
# tmpfiles stuff
- insinto /usr/lib/tmpfiles.d
- newins "${FILESDIR}/tmpfiles.d" "puppet.conf"
+ newtmpfiles "${FILESDIR}/tmpfiles.d" "puppet.conf"
# openrc init stuff
newinitd "${FILESDIR}"/puppet.init-4.x puppet
@@ -121,6 +120,8 @@ all_ruby_install() {
}
pkg_postinst() {
+ tmpfiles_process puppet.conf
+
elog
elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
elog "cause puppet to hang while installing packages."
diff --git a/app-admin/puppet/puppet-7.8.0.ebuild b/app-admin/puppet/puppet-7.8.0-r1.ebuild
index d3f1ad182f3d..9c67dbe4f524 100644
--- a/app-admin/puppet/puppet-7.8.0.ebuild
+++ b/app-admin/puppet/puppet-7.8.0-r1.ebuild
@@ -8,7 +8,7 @@ RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_TASK_DOC="doc:all"
RUBY_FAKEGEM_EXTRAINSTALL="locales"
-inherit ruby-fakegem
+inherit ruby-fakegem tmpfiles
DESCRIPTION="A system automation and configuration management software."
HOMEPAGE="https://puppet.com/"
@@ -85,8 +85,7 @@ all_ruby_install() {
doins "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
# tmpfiles stuff
- insinto /usr/lib/tmpfiles.d
- newins "${FILESDIR}/tmpfiles.d" "puppet.conf"
+ newtmpfiles "${FILESDIR}/tmpfiles.d" "puppet.conf"
# openrc init stuff
newinitd "${FILESDIR}"/puppet.init-4.x puppet
@@ -118,6 +117,8 @@ all_ruby_install() {
}
pkg_postinst() {
+ tmpfiles_process puppet.conf
+
elog
elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
elog "cause puppet to hang while installing packages."
diff --git a/app-admin/puppet/puppet-7.9.0.ebuild b/app-admin/puppet/puppet-7.9.0-r1.ebuild
index 125aa53e82ce..b097feb026ad 100644
--- a/app-admin/puppet/puppet-7.9.0.ebuild
+++ b/app-admin/puppet/puppet-7.9.0-r1.ebuild
@@ -8,7 +8,7 @@ RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_TASK_DOC="doc:all"
RUBY_FAKEGEM_EXTRAINSTALL="locales"
-inherit ruby-fakegem
+inherit ruby-fakegem tmpfiles
DESCRIPTION="A system automation and configuration management software."
HOMEPAGE="https://puppet.com/"
@@ -85,8 +85,7 @@ all_ruby_install() {
doins "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
# tmpfiles stuff
- insinto /usr/lib/tmpfiles.d
- newins "${FILESDIR}/tmpfiles.d" "puppet.conf"
+ newtmpfiles "${FILESDIR}/tmpfiles.d" "puppet.conf"
# openrc init stuff
newinitd "${FILESDIR}"/puppet.init-4.x puppet
@@ -118,6 +117,8 @@ all_ruby_install() {
}
pkg_postinst() {
+ tmpfiles_process puppet.conf
+
elog
elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
elog "cause puppet to hang while installing packages."