summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz N Tiram <oz.tiram@gmail.com>2019-04-07 11:12:18 +0200
committerPatrice Clement <monsieurp@gentoo.org>2019-04-14 20:16:30 +0200
commitb497cdf56b4b1c1c6596a3805080ff04b38d52b6 (patch)
tree08f33ec6a9973616430704402aac41607b28c189 /app-admin
parentapp-crypt/acme-sh: update live ebuild. (diff)
downloadgentoo-b497cdf56b4b1c1c6596a3805080ff04b38d52b6.tar.gz
gentoo-b497cdf56b4b1c1c6596a3805080ff04b38d52b6.tar.bz2
gentoo-b497cdf56b4b1c1c6596a3805080ff04b38d52b6.zip
app-admin/pwman3: version bump to 0.10.0.
Package-Manager: Portage-2.3.62, Repoman-2.3.11 Signed-off-by: Oz Tiram <oz.tiram@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/11623 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/pwman3/Manifest1
-rw-r--r--app-admin/pwman3/pwman3-0.10.0.ebuild38
-rw-r--r--app-admin/pwman3/pwman3-0.9.11.ebuild2
3 files changed, 40 insertions, 1 deletions
diff --git a/app-admin/pwman3/Manifest b/app-admin/pwman3/Manifest
index 66153c9bb7b4..6612c190c892 100644
--- a/app-admin/pwman3/Manifest
+++ b/app-admin/pwman3/Manifest
@@ -1 +1,2 @@
+DIST pwman3-0.10.0.tar.gz 75726 BLAKE2B ba7331bd3d36ac23d9151a5ebd4a343e2d8c523ba8b324850139a9ba4af8404ddf23380b3eaef523251e8f4137c5c56b6ab509c3927690fc612962ff872ea820 SHA512 a6dc24b2e1405a91f35a9a9155dde5409e35ce733bacee8858930d82443c09b8017e2701bc8c45688483b6c40554e4d6266f6cd21dc6f205b13f96e7de4f57c2
DIST pwman3-0.9.11.tar.gz 74364 BLAKE2B 9544b692e8853b7fb8e1b4d51093e72e04f8d82888a9278c94aaa27716026b348bb16f0fa9c52af2144395a4ffb242c8a48fc34252890e68477d2e3a70ea4a88 SHA512 2aa5a7b4d810d1bbc6aea34b728f89190570cbfbedc33f45cc1aa4d737ebbb9e993d2d372b44f956d5cdbc07f911f289fd77d7df167100e820455650f5b3e46a
diff --git a/app-admin/pwman3/pwman3-0.10.0.ebuild b/app-admin/pwman3/pwman3-0.10.0.ebuild
new file mode 100644
index 000000000000..c63d60465f40
--- /dev/null
+++ b/app-admin/pwman3/pwman3-0.10.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_5 python3_6 )
+PYTHON_REQ_USE="sqlite?"
+inherit distutils-r1
+
+DESCRIPTION="A lightweight password-manager with multiple database backends"
+HOMEPAGE="https://pwman3.github.io"
+SRC_URI="https://github.com/pwman3/pwman3/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="mongodb mysql postgres +sqlite test"
+
+CDEPEND="
+ >=dev-python/cryptography-2.3[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.3.0[${PYTHON_USEDEP}]
+ "
+
+DEPEND="
+ ${CDEPEND}
+ test? ( dev-python/pexpect[${PYTHON_USEDEP}] )
+ "
+
+RDEPEND="
+ ${CDEPEND}
+ mongodb? ( dev-python/pymongo[${PYTHON_USEDEP}] )
+ mysql? ( dev-python/pymysql[${PYTHON_USEDEP}] )
+ postgres? ( dev-python/psycopg[${PYTHON_USEDEP}] )
+ "
+
+python_test() {
+ esetup.py test
+}
diff --git a/app-admin/pwman3/pwman3-0.9.11.ebuild b/app-admin/pwman3/pwman3-0.9.11.ebuild
index 5c508edb053c..ba9a62305684 100644
--- a/app-admin/pwman3/pwman3-0.9.11.ebuild
+++ b/app-admin/pwman3/pwman3-0.9.11.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6