summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2015-08-09 22:20:27 -0700
committerZac Medico <zmedico@gentoo.org>2015-08-09 22:35:16 -0700
commitd318868e5af455ebfacb214d86e2a22a05298331 (patch)
tree3b31fa958a73463a859a92727a5e24f2f2d4b76c /app-admin
parentapp-admin/vault: inherit go-build for GOPATH setting with get_golibdir_gopath (diff)
downloadgentoo-d318868e5af455ebfacb214d86e2a22a05298331.tar.gz
gentoo-d318868e5af455ebfacb214d86e2a22a05298331.tar.bz2
gentoo-d318868e5af455ebfacb214d86e2a22a05298331.zip
app-admin/consul: inherit go-build for GOPATH setting with get_golibdir_gopath
Package-Manager: portage-2.2.20
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/consul/consul-0.5.2-r1.ebuild5
-rw-r--r--app-admin/consul/consul-0.5.2.ebuild5
-rw-r--r--app-admin/consul/consul-9999.ebuild5
3 files changed, 9 insertions, 6 deletions
diff --git a/app-admin/consul/consul-0.5.2-r1.ebuild b/app-admin/consul/consul-0.5.2-r1.ebuild
index 6fec48bdf537..a55ecdff9b5b 100644
--- a/app-admin/consul/consul-0.5.2-r1.ebuild
+++ b/app-admin/consul/consul-0.5.2-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit systemd user
+inherit golang-base systemd user
KEYWORDS="~amd64"
DESCRIPTION="A tool for service discovery, monitoring and configuration"
@@ -13,6 +13,7 @@ GO_PN="github.com/hashicorp/consul"
LICENSE="MPL-2.0"
SLOT="0"
IUSE="test web"
+RESTRICT="test"
DEPEND=">=dev-lang/go-1.4:=
dev-go/go-crypto:=
@@ -89,7 +90,7 @@ src_unpack() {
unpack_go_packages
# Create a writable GOROOT in order to avoid sandbox violations
# or other interference from installed instances.
- export GOPATH="${WORKDIR}" GOROOT="${WORKDIR}/goroot"
+ export GOPATH="${WORKDIR}:$(get_golibdir_gopath)" GOROOT="${WORKDIR}/goroot"
cp -sR "${EPREFIX}"/usr/lib/go "${GOROOT}" || die
while read -r path; do
rm -rf "${GOROOT}/src/${path#${WORKDIR}/src}" \
diff --git a/app-admin/consul/consul-0.5.2.ebuild b/app-admin/consul/consul-0.5.2.ebuild
index 9c47b7fa54e1..83890455ffa5 100644
--- a/app-admin/consul/consul-0.5.2.ebuild
+++ b/app-admin/consul/consul-0.5.2.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit systemd user
+inherit golang-base systemd user
KEYWORDS="~amd64"
DESCRIPTION="A tool for service discovery, monitoring and configuration"
@@ -13,6 +13,7 @@ GO_PN="github.com/hashicorp/consul"
LICENSE="MPL-2.0"
SLOT="0"
IUSE="test web"
+RESTRICT="test"
DEPEND=">=dev-lang/go-1.4
dev-go/go-crypto
@@ -89,7 +90,7 @@ src_unpack() {
unpack_go_packages
# Create a writable GOROOT in order to avoid sandbox violations
# or other interference from installed instances.
- export GOPATH="${WORKDIR}" GOROOT="${WORKDIR}/goroot"
+ export GOPATH="${WORKDIR}:$(get_golibdir_gopath)" GOROOT="${WORKDIR}/goroot"
cp -sR "${EPREFIX}"/usr/lib/go "${GOROOT}" || die
while read -r path; do
rm -rf "${GOROOT}/src/${path#${WORKDIR}/src}" \
diff --git a/app-admin/consul/consul-9999.ebuild b/app-admin/consul/consul-9999.ebuild
index 49971f1f012a..3c38c200dad4 100644
--- a/app-admin/consul/consul-9999.ebuild
+++ b/app-admin/consul/consul-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit git-r3 systemd user
+inherit git-r3 golang-base systemd user
KEYWORDS=""
DESCRIPTION="A tool for service discovery, monitoring and configuration"
@@ -14,6 +14,7 @@ EGIT_REPO_URI="git://${GO_PN}.git"
LICENSE="MPL-2.0"
SLOT="0"
IUSE="test web"
+RESTRICT="test"
DEPEND=">=dev-lang/go-1.4:=
dev-go/go-crypto:=
@@ -40,7 +41,7 @@ src_unpack() {
# Create a writable GOROOT in order to avoid sandbox violations
# or other interference from installed instances.
- export GOPATH="${WORKDIR}" GOROOT="${WORKDIR}/goroot"
+ export GOPATH="${WORKDIR}:$(get_golibdir_gopath)" GOROOT="${WORKDIR}/goroot"
cp -sR "${EPREFIX}"/usr/lib/go "${GOROOT}" || die
# Use latest versions of some packages, in case of incompatible