summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gentoo.org>2018-02-20 06:26:08 -0700
committerNicolas Bock <nicolasbock@gentoo.org>2018-02-20 14:50:17 -0700
commit65570f531cbd9bcde073314da9dba1ca45abee86 (patch)
treeb0753986439e86056bbb413d6b38d76eb8cccbcf /app-crypt/kbfs
parentx11-proto: Inherit multilib-build in empty packages (diff)
downloadgentoo-65570f531cbd9bcde073314da9dba1ca45abee86.tar.gz
gentoo-65570f531cbd9bcde073314da9dba1ca45abee86.tar.bz2
gentoo-65570f531cbd9bcde073314da9dba1ca45abee86.zip
app-crypt/kbfs: Version bump to 1.0.40
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-crypt/kbfs')
-rw-r--r--app-crypt/kbfs/Manifest1
-rw-r--r--app-crypt/kbfs/kbfs-1.0.40.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-crypt/kbfs/Manifest b/app-crypt/kbfs/Manifest
index 72551856de72..4c3a39bbedd3 100644
--- a/app-crypt/kbfs/Manifest
+++ b/app-crypt/kbfs/Manifest
@@ -1 +1,2 @@
DIST kbfs-1.0.36.tar.gz 5135197 BLAKE2B a0d40048d11347a72ac9fedb358be7bd8d425e9eafc32fce44e75583aa75fde00bee62d81e7d4bc1553aec3f72ca3af1dffd1ef710d897ce28cb26d152eab4aa SHA512 eb50c4fdd07e0d0e0bd62c48a60520fe48a6b64d97e6ac561d0c567e50c4863f9969697f78553360e6b42776af4974b086bd0be75db6de4c28a5c4a840725919
+DIST kbfs-1.0.40.tar.gz 5432507 BLAKE2B 4d3c55d3c081cb7fea44d302a1a5598df515f98f4f75bf3e0eee84c3151114247eb1a80ea2ff9bb6d10cc3612af25e283b114b26b24043fbfdd16f05d2fb0210 SHA512 c5391e710fc55130437ff5f42e00229ea06fd1bd5e535c814158a501f2b23ef43d65d27ebf57ec3c3b5d3c7cbbed43cd2baf8888af001a3b23a40cbc94d22883
diff --git a/app-crypt/kbfs/kbfs-1.0.40.ebuild b/app-crypt/kbfs/kbfs-1.0.40.ebuild
new file mode 100644
index 000000000000..71b20436cf6a
--- /dev/null
+++ b/app-crypt/kbfs/kbfs-1.0.40.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Keybase Filesystem (KBFS)"
+HOMEPAGE="https://keybase.io/docs/kbfs"
+SRC_URI="https://github.com/keybase/kbfs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="git"
+
+DEPEND="
+ >=dev-lang/go-1.6:0
+ >=app-crypt/keybase-1.0.36
+ "
+RDEPEND="
+ app-crypt/gnupg
+ sys-fs/fuse
+ "
+
+S="${WORKDIR}/src/github.com/keybase/kbfs"
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+ mkdir -p "$(dirname "${S}")" || die
+ mv "kbfs-${PV}" "${S}" || die
+}
+
+src_compile() {
+ GOPATH="${WORKDIR}" \
+ go build -v -x \
+ -tags production \
+ -o "${T}/kbfsfuse" \
+ github.com/keybase/kbfs/kbfsfuse
+ use git && \
+ GOPATH="${WORKDIR}" \
+ go build -v -x \
+ -tags production \
+ -o "${T}/git-remote-keybase" \
+ github.com/keybase/kbfs/kbfsgit/git-remote-keybase
+}
+
+src_install() {
+ dobin "${T}/kbfsfuse"
+ use git && \
+ dobin "${T}/git-remote-keybase"
+}