summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-12-03 04:15:25 -0500
committerMike Frysinger <vapier@gentoo.org>2015-12-03 04:15:43 -0500
commitc37dff06cc5632de78ff283857f211c0361d5582 (patch)
tree08e7e5bc03033d44d124ff1adb7e159f5d9f399f /app-crypt/letsencrypt
parentdev-python/{configargparse,configobj,pythondialog}: add arm love (diff)
downloadgentoo-c37dff06cc5632de78ff283857f211c0361d5582.tar.gz
gentoo-c37dff06cc5632de78ff283857f211c0361d5582.tar.bz2
gentoo-c37dff06cc5632de78ff283857f211c0361d5582.zip
app-crypt/{acme,letsencrypt}: add ebuilds for latest snapshot
Diffstat (limited to 'app-crypt/letsencrypt')
-rw-r--r--app-crypt/letsencrypt/Manifest1
-rw-r--r--app-crypt/letsencrypt/letsencrypt-0.0.0_pre20151123.ebuild51
-rw-r--r--app-crypt/letsencrypt/letsencrypt-9999.ebuild29
3 files changed, 73 insertions, 8 deletions
diff --git a/app-crypt/letsencrypt/Manifest b/app-crypt/letsencrypt/Manifest
new file mode 100644
index 000000000000..78c4d5188e3e
--- /dev/null
+++ b/app-crypt/letsencrypt/Manifest
@@ -0,0 +1 @@
+DIST letsencrypt-0.0.0.dev20151123.tar.gz 403690 SHA256 3f909ef521ab91eade4fa83f1f72c4b1cb74c9192144bc072d999248eb25e902 SHA512 e62cd4bf966b75e159949d84eda1005649dd4f11efbb1515601a5c6690e09ea1cc73bb3f535b6b20655752b7218fa3f02cf50e4cb12a335d76b10461e385aa96 WHIRLPOOL 5352083e3eabe69ea07b830fcdd3d9de2f431d5b8681c3484288feb2f6394d1c4dd9d46feffe08f7733015755e39df24e61293915877b97470339a3fa11c668c
diff --git a/app-crypt/letsencrypt/letsencrypt-0.0.0_pre20151123.ebuild b/app-crypt/letsencrypt/letsencrypt-0.0.0_pre20151123.ebuild
new file mode 100644
index 000000000000..ed22257e4dd7
--- /dev/null
+++ b/app-crypt/letsencrypt/letsencrypt-0.0.0_pre20151123.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/letsencrypt/letsencrypt.git"
+ inherit git-r3
+else
+ MY_PV="${PV/_pre/.dev}"
+ MY_P="${PN}-${MY_PV}"
+ SRC_URI="https://github.com/letsencrypt/letsencrypt/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="Let's Encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="https://github.com/letsencrypt/letsencrypt https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ dev-python/configargparse[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-0.7[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/parsedatetime[${PYTHON_USEDEP}]
+ >=dev-python/psutil-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.15[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ >=dev-python/pythondialog-3.2.2:python-2[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests -w ${PN}/tests || die
+}
diff --git a/app-crypt/letsencrypt/letsencrypt-9999.ebuild b/app-crypt/letsencrypt/letsencrypt-9999.ebuild
index c271da785b44..f62f8dfda28a 100644
--- a/app-crypt/letsencrypt/letsencrypt-9999.ebuild
+++ b/app-crypt/letsencrypt/letsencrypt-9999.ebuild
@@ -3,18 +3,27 @@
# $Id$
EAPI=5
-PYTHON_COMPAT=(python2_7)
-EGIT_REPO_URI="https://github.com/letsencrypt/letsencrypt.git"
+PYTHON_COMPAT=( python2_7 )
-inherit git-r3 distutils-r1
+inherit distutils-r1
-DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
+MY_PV="${PV/_pre/.dev}"
+MY_P="${PN}-${MY_PV}"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/letsencrypt/letsencrypt.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/letsencrypt/letsencrypt/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Let's Encrypt client to automate deployment of X.509 certificates"
HOMEPAGE="https://github.com/letsencrypt/letsencrypt https://letsencrypt.org/"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS=""
IUSE="test"
RDEPEND=">=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
@@ -31,9 +40,13 @@ RDEPEND=">=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/zope-component[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]"
-DEPEND="test? ( ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}] )
- dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"
python_test() {
nosetests -w ${PN}/tests || die