summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2018-07-17 18:17:01 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2018-07-17 18:35:23 -0400
commitd9fa4af0a25e38fd0c343e283b4956037f9540c9 (patch)
treed3a0ba625e67b069b2f319d806fb912599b4c222 /app-crypt/yubikey-manager
parentapp-crypt/certbot: 0.26.1 bup (diff)
downloadgentoo-d9fa4af0a25e38fd0c343e283b4956037f9540c9.tar.gz
gentoo-d9fa4af0a25e38fd0c343e283b4956037f9540c9.tar.bz2
gentoo-d9fa4af0a25e38fd0c343e283b4956037f9540c9.zip
app-crypt/yubikey-manager: bump to 0.7.1
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'app-crypt/yubikey-manager')
-rw-r--r--app-crypt/yubikey-manager/Manifest2
-rw-r--r--app-crypt/yubikey-manager/yubikey-manager-0.7.1.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/app-crypt/yubikey-manager/Manifest b/app-crypt/yubikey-manager/Manifest
index 2a0e3eea2a06..b4fa80000f94 100644
--- a/app-crypt/yubikey-manager/Manifest
+++ b/app-crypt/yubikey-manager/Manifest
@@ -4,3 +4,5 @@ DIST yubikey-manager-0.4.6.tar.gz 55065 BLAKE2B a0e8d85252836a6d99e68f637f423972
DIST yubikey-manager-0.5.0.tar.gz 59672 BLAKE2B e5dbd32ba644e7b20f03c1511a4ff608c0e6dc93c115edd50077a9a41699411a5fd0eff3d62af1fb13545d977037510f696cbd27150e21308624bfc8613f8bcb SHA512 3a503ced29a557c5adafdd1bc6025a405962cabab7388c96e8f5582165bd33111adeb3b77c7c928cbac905fb085d53ddaefbb12169b54e62b7337c1989636a8a
DIST yubikey-manager-0.6.0.tar.gz 77823 BLAKE2B 37d9a7e72135ba859521f209896c47423f3573b2f14a56956d145334124f7bf5a4259401a9e89e3f19b2e01a476b96a984e801a28a256815a7773baa44e71773 SHA512 fb49887f4646fe63874be9cb3510ef0d1f9b931ac5fb78f3cc82fb93ada94b36aa06fd91e2ee9d4ea868abedfc206dbedd02fa0c4385d5557d33e07e8099e761
DIST yubikey-manager-0.7.0.tar.gz 83385 BLAKE2B cd0c440f8ce81549e52dd8e546d82678c19d95d2257c878b48d69719031317943bcca4ee713c03ca8f3fa1de4363df629b09b005955a1217adb2dc5ce89400aa SHA512 0fec23dafd2502a1508648fc96f1dcc873eaf3ad089f87b1afd94b35391513ad3a799985fcbc201c2fb4a3a3e473d24483c04a6862117d211c4cb6b294f74be0
+DIST yubikey-manager-0.7.1-test-files.tar.xz 9756 BLAKE2B 5a2e2a2a58d04c8f9954c1d13d0892b4f7392785d6e83e6948e720606318860b93e70862cee0ee7f987c14c3fa49bb7ff20cdf2a5bfc09c1f08681346428c003 SHA512 7543a9e9cfbe7f9ec02c98397f5cbd77cb307d79985a4b060176ee26605767e74d8b18d4c036ff90aed9a0232bb1382908c75e876a911c2ceb35a12666699b94
+DIST yubikey-manager-0.7.1.tar.gz 71834 BLAKE2B 45b0366531c8a158b3d8ebcfa8b76d608c14dba02224d4e4962c3757446829e3dff5f5e0d0ceda67caab7c67ad0510e037770c58a50552c2c6971136cb75c806 SHA512 3e9105f1c033f9314b90cf209eb52f7879fa1ea69e9ae6dac8de0b24d7d2ff6e45b6dd530917535fa645d6eea461f5b4f23bb8deb103ffc27d1f3483cfa681c7
diff --git a/app-crypt/yubikey-manager/yubikey-manager-0.7.1.ebuild b/app-crypt/yubikey-manager/yubikey-manager-0.7.1.ebuild
new file mode 100644
index 000000000000..d1c0a714a0a5
--- /dev/null
+++ b/app-crypt/yubikey-manager/yubikey-manager-0.7.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+inherit readme.gentoo-r1 distutils-r1
+
+DESCRIPTION="Python library and command line tool for configuring a YubiKey"
+HOMEPAGE="https://developers.yubico.com/yubikey-manager/"
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.gz
+ test? ( https://dev.gentoo.org/~gokturk/distfiles/app-crypt/${PN}/${PN}-0.7.1-test-files.tar.xz )"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-python/fido2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/pyscard[${PYTHON_USEDEP}]
+ dev-python/pyusb[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7)
+ sys-auth/ykpers
+"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' 'python2_7')
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.7.0-fix-tests.patch
+)
+
+python_test() {
+ touch "${S}"/test/__init__.py || die
+ cp -r "${WORKDIR}/files" "${S}"/test/ || die
+ esetup.py test
+}
+
+python_install_all() {
+ local DOC_CONTENTS
+
+ distutils-r1_python_install_all
+
+ DOC_CONTENTS="
+ The 'openpgp' command may require the package 'app-crypt/ccid'
+ to be installed on the system. Furthermore, make sure that pcscd
+ daemon is running and has correct access permissions to USB
+ devices.
+ "
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}