summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Olivier Mercier <nemunaire@nemunai.re>2019-01-30 21:07:49 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-03 19:00:27 +0100
commit504a7ec746545a930667fb68808722c8f8e3cddb (patch)
tree5353f96bbb4b9a82c4bbc60f1e4e1c0f02078b36 /app-crypt
parentprofiles: x86: Drop obsolete app-office/libreoffice-bin mask (diff)
downloadgentoo-504a7ec746545a930667fb68808722c8f8e3cddb.tar.gz
gentoo-504a7ec746545a930667fb68808722c8f8e3cddb.tar.bz2
gentoo-504a7ec746545a930667fb68808722c8f8e3cddb.zip
app-crypt/moolticute: add missing dep + bump to 0.30.8
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Pierre-Olivier Mercier <nemunaire@nemunai.re> Closes: https://github.com/gentoo/gentoo/pull/10946 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/moolticute/Manifest1
-rw-r--r--app-crypt/moolticute/moolticute-0.30.8.ebuild66
-rw-r--r--app-crypt/moolticute/moolticute-9999.ebuild4
3 files changed, 69 insertions, 2 deletions
diff --git a/app-crypt/moolticute/Manifest b/app-crypt/moolticute/Manifest
index 1b3bd8b26d60..1c49058e47f0 100644
--- a/app-crypt/moolticute/Manifest
+++ b/app-crypt/moolticute/Manifest
@@ -1 +1,2 @@
DIST moolticute-0.30.1.tar.gz 5562456 BLAKE2B 104f4bd10edf4147d205fec69ec48eddf31150f898242819be25b83fa5f8ddcd51fd016aa2331b9b94fc8c60062745f0d06e5f0b4a30222c1cc44d54eccd6521 SHA512 463b549fbcdbdff3da51a0b781e7ff2c4ca33ebd22ff355b24f13db3c77b3f3fe38d3d97ff260829517d5d93c43b7d746ff58e3fca3d838f7e32de7066c5288a
+DIST moolticute-0.30.8.tar.gz 5587730 BLAKE2B a8ef141d7b8ed4d79a43652760626c4b608d7c92270a4d7f384bd240a5f90d6264d2714f3513acaa86f22135a1c885d6f713252ef69794e301a1b658aa1c47a3 SHA512 e5f848252d1deabfa8767284c2c34329a98f5849f8b2bdc62d454cc0e331d58fcd78e0845683931460c20be13d2f1baf3aee32a9f3244e769d5d4c222e182706
diff --git a/app-crypt/moolticute/moolticute-0.30.8.ebuild b/app-crypt/moolticute/moolticute-0.30.8.ebuild
new file mode 100644
index 000000000000..efd4c37a4de9
--- /dev/null
+++ b/app-crypt/moolticute/moolticute-0.30.8.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/mooltipass/moolticute.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/mooltipass/moolticute/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+inherit gnome2-utils qmake-utils udev
+
+DESCRIPTION="Mooltipass crossplatform daemon/tools"
+HOMEPAGE="https://github.com/mooltipass/moolticute"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/libusb-1.0.20
+ dev-qt/qtdbus:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qttest:5
+ dev-qt/qtwebsockets:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_prepare() {
+ default
+
+ # Fill version.h with package version
+ if [[ ${PV} != 9999* ]]; then
+ sed -i "s/\"git\"/\"v${PV/_/-}\"/" src/version.h || die
+ fi
+}
+
+src_configure() {
+ eqmake5 PREFIX="/usr" Moolticute.pro
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+
+ udev_dorules "${FILESDIR}/50-mooltipass.rule"
+ newinitd "${FILESDIR}/moolticuted.init" moolticuted
+}
+
+pkg_postinst() {
+ udev_reload
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-crypt/moolticute/moolticute-9999.ebuild b/app-crypt/moolticute/moolticute-9999.ebuild
index da3da6c6597f..efd4c37a4de9 100644
--- a/app-crypt/moolticute/moolticute-9999.ebuild
+++ b/app-crypt/moolticute/moolticute-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,7 +6,6 @@ EAPI=6
if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="https://github.com/mooltipass/moolticute.git"
inherit git-r3
- KEYWORDS=""
else
SRC_URI="https://github.com/mooltipass/moolticute/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm"
@@ -23,6 +22,7 @@ IUSE=""
RDEPEND="
>=dev-libs/libusb-1.0.20
+ dev-qt/qtdbus:5
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5