summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2016-04-01 19:50:21 +0200
committerWolfram Schlich <wschlich@gentoo.org>2016-04-01 19:50:33 +0200
commitf7269e7d8cc485672d2967df2af75a95e253015d (patch)
treede857eb54a6d21c16991c0a5f2624160d1ce2198 /app-crypt
parentprofiles: Add the-Click-license to MISC-FREE group. (diff)
downloadgentoo-f7269e7d8cc485672d2967df2af75a95e253015d.tar.gz
gentoo-f7269e7d8cc485672d2967df2af75a95e253015d.tar.bz2
gentoo-f7269e7d8cc485672d2967df2af75a95e253015d.zip
app-crypt/ccid: version bump. added USE=kobil-midentity for building and installing contrib/Kobil_mIDentity_switch.
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/ccid/Manifest1
-rw-r--r--app-crypt/ccid/ccid-1.4.22.ebuild65
-rw-r--r--app-crypt/ccid/metadata.xml1
3 files changed, 67 insertions, 0 deletions
diff --git a/app-crypt/ccid/Manifest b/app-crypt/ccid/Manifest
index 0dddcc9d7b5b..e26c8b203ff5 100644
--- a/app-crypt/ccid/Manifest
+++ b/app-crypt/ccid/Manifest
@@ -1,3 +1,4 @@
DIST ccid-1.4.15.tar.bz2 487625 SHA256 5436182246f15b3e78b1ad6707022b02dc400e3f50c4cb5e5d340a4e716d990a SHA512 393eb65db0fb31b58d4010c10cae6c7592078b02d0e77b7741330cc3b1e5dd768fa08dbaf75db39c547e3603fa70aa1c8aaf3b536266314f2f04d2ff2b6fb29c WHIRLPOOL 0dd511454cf8e39303318b61f9e2390f2ef27b763e80e9270f55ee15966ced8378f3f3ee5440b6380481f970f03ae37bbb2221da6c3d2d658622ea4cdc3aee3f
DIST ccid-1.4.18.tar.bz2 492113 SHA256 5fdba97a2d2eb1c652b7dd4aa0bb8cee4814bab0cf61aecb84b32b57272541aa SHA512 ff7e331431909fe9fffd4f7aae0a2395b3b755da9c898aa6a6b629f7f516c240b820669146791deb443c646dc8fc56f9100c9f987b3e7d13c24f24f81f06b1f0 WHIRLPOOL 86107ac379e5523c31aa1499e1ecd5a1f6dab5b7f748800b5a22ff2b6470e9bb590407cb8a98ad65870a832149fe8835aa42dff9a30027f0bce843640439ce1e
DIST ccid-1.4.20.tar.bz2 567553 SHA256 400cb865bb63eed6d7668b2d971cb4644038b9b7a6cda121450d0c6cf6251cbc SHA512 4ce0694e268fe962f5eb49d3d640333a4c7ef54af5f9939b3682341b19ffad7470f5e1816b3b3af1bce8cf31f4335c3177f7e6b8190e187125ce1da73692cbab WHIRLPOOL 2af0cc1887ab93da92f9c498982798b57e3711b864cc59446248fd59f96703b781cb65602e7c80ce2de194901cff12b52b9105ad404b4c04a3f45a5f38343ee7
+DIST ccid-1.4.22.tar.bz2 578835 SHA256 9c5c8be465b6d33316be7a7ea720c24a776e2d76be9072116d28fc9adf58c106 SHA512 621b0165226c3530b514dfb87eb8963be750cc274f4263dd739a24bfe431b463cffdd467d8c38b3e909ca2a6ae756e5fd414891a4b332ca687318639d721e0c8 WHIRLPOOL 5c7592234f4bbf41565000b512064892588ccd19415cc9357f7197af5a851b95c6a5257824ec2440c163495ba78b8ff9bde4be43121e4b8eb3dc3c7af1d4cdbc
diff --git a/app-crypt/ccid/ccid-1.4.22.ebuild b/app-crypt/ccid/ccid-1.4.22.ebuild
new file mode 100644
index 000000000000..500aaee0e654
--- /dev/null
+++ b/app-crypt/ccid/ccid-1.4.22.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+STUPID_NUM="4162"
+
+inherit eutils toolchain-funcs udev autotools-utils
+
+DESCRIPTION="CCID free software driver"
+HOMEPAGE="http://pcsclite.alioth.debian.org/ccid.html"
+SRC_URI="http://alioth.debian.org/frs/download.php/file/${STUPID_NUM}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="twinserial kobil-midentity +usb"
+
+RDEPEND=">=sys-apps/pcsc-lite-1.8.3
+ usb? ( virtual/libusb:1 )"
+DEPEND="${RDEPEND}
+ kernel_linux? ( virtual/pkgconfig )"
+
+DOCS=( README AUTHORS )
+
+src_configure() {
+ local myeconfargs=(
+ LEX=:
+ $(use_enable twinserial)
+ $(use_enable usb libusb)
+ )
+
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use kobil-midentity && autotools-utils_src_compile contrib/Kobil_mIDentity_switch
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use kobil-midentity; then
+ dosbin "${BUILD_DIR}"/contrib/Kobil_mIDentity_switch/Kobil_mIDentity_switch
+ doman contrib/Kobil_mIDentity_switch/Kobil_mIDentity_switch.8
+ fi
+
+ if use kernel_linux; then
+ # note: for eudev support, rules probably will always need to be
+ # installed to /usr
+
+ # ccid >=1.4.11 version changed the rules drastically in a minor
+ # release to no longer use the pcscd group. Using the old ones in
+ # the mean time.
+ udev_newrules "${FILESDIR}"/92_pcscd_ccid-2.rules 92-pcsc-ccid.rules
+
+ # disable Kobil_mIDentity_switch udev rule with USE=-kobil-midentity
+ if ! use kobil-midentity; then
+ sed -i -e '/Kobil_mIDentity_switch/s/^/#/' "$(_udev_get_udevdir)"/rules.d/92-pcsc-ccid.rules
+ fi
+
+ fi
+}
diff --git a/app-crypt/ccid/metadata.xml b/app-crypt/ccid/metadata.xml
index c0423396ac62..6a1239505f77 100644
--- a/app-crypt/ccid/metadata.xml
+++ b/app-crypt/ccid/metadata.xml
@@ -6,6 +6,7 @@
<name>Crypto</name>
</maintainer>
<use>
+ <flag name="kobil-midentity">Build and install Kobil_mIDentity_switch tool</flag>
<flag name="twinserial">Enable twinserial reader</flag>
</use>
</pkgmetadata>