summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2020-01-27 22:20:53 +0100
committerUlrich Müller <ulm@gentoo.org>2020-01-27 22:21:12 +0100
commit49c7c98657b29a3ea8865e4280b150c20b40c249 (patch)
treef6e6e7050144ef1788b833b31dcf3d90c84742f5 /app-doc/devmanual/devmanual-9999.ebuild
parentmedia-libs/libsdl2: Add jack USE flag (diff)
downloadgentoo-49c7c98657b29a3ea8865e4280b150c20b40c249.tar.gz
gentoo-49c7c98657b29a3ea8865e4280b150c20b40c249.tar.bz2
gentoo-49c7c98657b29a3ea8865e4280b150c20b40c249.zip
app-doc/devmanual: Update the live ebuild.
This accounts for several changes in the devmanual repository. Package-Manager: Portage-2.3.85, Repoman-2.3.20 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-doc/devmanual/devmanual-9999.ebuild')
-rw-r--r--app-doc/devmanual/devmanual-9999.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/app-doc/devmanual/devmanual-9999.ebuild b/app-doc/devmanual/devmanual-9999.ebuild
index 8ad5f06a357e..0cd5087804b2 100644
--- a/app-doc/devmanual/devmanual-9999.ebuild
+++ b/app-doc/devmanual/devmanual-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -16,12 +16,16 @@ else
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-macos"
fi
-LICENSE="CC-BY-SA-3.0"
+LICENSE="CC-BY-SA-4.0"
SLOT="0"
IUSE="+fallback"
-BDEPEND="dev-libs/libxslt
- media-gfx/imagemagick[truetype,svg,png]"
+BDEPEND="dev-libs/libxml2
+ dev-libs/libxslt
+ gnome-base/librsvg
+ media-fonts/open-sans"
+
+PATCHES=( "${FILESDIR}"/${PN}-eclasses.patch )
src_prepare() {
default
@@ -29,22 +33,18 @@ src_prepare() {
}
src_compile() {
- # Imagemagick uses inkscape (if present) to delegate
- # svg conversions.
- # Inkscape uses g_get_user_config_dir () which in turn
- # uses XDG_CONFIG_HOME to get the config directory for this
- # user. See bug 463380
- export XDG_CONFIG_HOME="${T}/inkscape_home"
- emake
+ emake build
+ use fallback || emake documents.js
}
src_install() {
# clean out XML/XSL before installing
find . \( \
-iname '*.xml' -o \
+ -iname '*.dtd' -o \
-iname '*.xsl' -o \
-iname '*.svg' \) -delete || die
- rm -r README.md xsl LICENSE Makefile || die
+ rm -r bin xsl .git* LICENSE Makefile README.md || die
local HTML_DOCS=( . )
einstalldocs