summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-03-14 13:35:21 +0100
committerMichał Górny <mgorny@gentoo.org>2019-03-14 13:35:21 +0100
commit0dded1c44940fa37150be78ea1ae4cc0cf5bbf95 (patch)
tree2e1736de015fee85303fd6f62d87140b8745f2a5 /app-doc
parentdev-util/debugedit: Apply GCC breakage workaround (diff)
downloadgentoo-0dded1c44940fa37150be78ea1ae4cc0cf5bbf95.tar.gz
gentoo-0dded1c44940fa37150be78ea1ae4cc0cf5bbf95.tar.bz2
gentoo-0dded1c44940fa37150be78ea1ae4cc0cf5bbf95.zip
app-doc/eclass-manpages: Switch the live ebuild to use git
Closes: https://bugs.gentoo.org/571284 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/eclass-manpages/eclass-manpages-99999999.ebuild35
1 files changed, 10 insertions, 25 deletions
diff --git a/app-doc/eclass-manpages/eclass-manpages-99999999.ebuild b/app-doc/eclass-manpages/eclass-manpages-99999999.ebuild
index ea11ad476084..7dfb0d7e0d2a 100644
--- a/app-doc/eclass-manpages/eclass-manpages-99999999.ebuild
+++ b/app-doc/eclass-manpages/eclass-manpages-99999999.ebuild
@@ -1,43 +1,28 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
+
+inherit git-r3
DESCRIPTION="Collection of Gentoo eclass manpages"
HOMEPAGE="https://www.gentoo.org/"
SRC_URI=""
+EGIT_REPO_URI="https://anongit.gentoo.org/git/repo/gentoo.git
+ https://github.com/gentoo/gentoo.git"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
IUSE=""
-DEPEND="
- || (
- sys-apps/portage
- sys-apps/portage-mgorny
- )"
-
-S=${WORKDIR}
-
-genit() {
- local e=${1:-${ECLASSDIR}}
- einfo "Generating man pages from: ${e}"
- # Need `bash` because the .sh isn't +x on the servers #451352
- env ECLASSDIR=${e} bash "${FILESDIR}"/eclass-to-manpage.sh || die
+src_unpack() {
+ git-r3_fetch
+ git-r3_checkout '' '' '' eclass
}
src_compile() {
- # First process any eclasses found in overlays. Then process
- # the main eclassdir last so that its output will clobber anything
- # that might have come from overlays. Main tree wins!
- local o e
- for o in $(portageq get_repos /) ; do
- e="$(portageq get_repo_path / ${o})/eclass"
- [[ -d ${e} ]] || continue
- genit "${e}" || die
- done
- genit || die
+ env ECLASSDIR="${S}/eclass" bash "${FILESDIR}"/eclass-to-manpage.sh || die
}
src_install() {