summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-04 08:18:59 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-04 08:18:59 +0100
commit993e2d1b65bc863e86e6c45b2977721cde97d4dc (patch)
tree6be30906486dd716fe94ac09cb7903f2e0047972 /app-editors/dhex/dhex-0.68.ebuild
parentdev-python/astroid: Update tests (diff)
downloadgentoo-993e2d1b65bc863e86e6c45b2977721cde97d4dc.tar.gz
gentoo-993e2d1b65bc863e86e6c45b2977721cde97d4dc.tar.bz2
gentoo-993e2d1b65bc863e86e6c45b2977721cde97d4dc.zip
app-editors/dhex: Fix for ncurses[tinfo]
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=564210 Package-Manager: portage-2.2.25 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'app-editors/dhex/dhex-0.68.ebuild')
-rw-r--r--app-editors/dhex/dhex-0.68.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/app-editors/dhex/dhex-0.68.ebuild b/app-editors/dhex/dhex-0.68.ebuild
index c8f3f05aa651..c2887641967b 100644
--- a/app-editors/dhex/dhex-0.68.ebuild
+++ b/app-editors/dhex/dhex-0.68.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=5
inherit eutils toolchain-funcs
@@ -17,7 +17,7 @@ SLOT="0"
KEYWORDS="amd64 ~arm ~mips x86"
IUSE=""
-DEPEND="sys-libs/ncurses"
+DEPEND="sys-libs/ncurses:="
RDEPEND="${DEPEND}"
S=${WORKDIR}/${MY_P}
@@ -27,7 +27,9 @@ src_prepare() {
}
src_compile() {
- emake CC="$(tc-getCC)"
+ emake \
+ CC="$(tc-getCC)" \
+ LIBS="$($(tc-getPKG_CONFIG) --libs ncurses)"
}
src_install() {