summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans Fredrik Nordhaug <hansfn@gmail.com>2021-12-22 09:37:07 +0100
committerJoonas Niilola <juippis@gentoo.org>2022-01-12 18:40:19 +0200
commit4045ba4373e50451e2f30a656deff4140fd13ab7 (patch)
treea8fe780c7bba6252bd02ee281a76a4c2a70798b8 /app-editors/featherpad
parentnet-libs/libbtbb: Drop 2018.12.1, EAPI6-- (diff)
downloadgentoo-4045ba4373e50451e2f30a656deff4140fd13ab7.tar.gz
gentoo-4045ba4373e50451e2f30a656deff4140fd13ab7.tar.bz2
gentoo-4045ba4373e50451e2f30a656deff4140fd13ab7.zip
app-editors/featherpad: Bump to 1.1.0
Also removed 0.18.0. Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans Fredrik Nordhaug <hansfn@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/23470 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-editors/featherpad')
-rw-r--r--app-editors/featherpad/Manifest2
-rw-r--r--app-editors/featherpad/featherpad-1.1.0.ebuild (renamed from app-editors/featherpad/featherpad-0.18.0.ebuild)21
2 files changed, 16 insertions, 7 deletions
diff --git a/app-editors/featherpad/Manifest b/app-editors/featherpad/Manifest
index bc637ef82232..854a2b25463c 100644
--- a/app-editors/featherpad/Manifest
+++ b/app-editors/featherpad/Manifest
@@ -1,3 +1,3 @@
-DIST featherpad-0.18.0.tar.gz 967643 BLAKE2B a8a84fa71232bdd9448ec4a9c921f8f452212dfb52ec518c3f340e9b600858a9cfca2d7729a0f58c9d1465b77bd28c836de78026c58ff94297de704e7bf670d8 SHA512 3e0d008792dd55bc5e57654f9b032f0a66a60c682499c684cfc3b182fdc57a654bb5fb195b458af66ddd8db929b31e7bfa789bd9bdf33d32454fbbcb090bcd91
DIST featherpad-1.0.0.tar.gz 1010200 BLAKE2B 22a11a0655ed57f7a7d53949e59c3b989a304b7c3db1f7308af0a52cc00a151cee505b02c19ece286da1be37e76c8874cee4102db3d881ef2c4ad48ecbb2f20a SHA512 9f7e24fa5e89e269693bc0a37f79d987e4914dde2d2b46bd0385886383dab8b35556fbc0f5c5b7b9a2c3a41694174ffa8532c48def87d2972fbc73c1e9c38bf3
DIST featherpad-1.0.1.tar.gz 1014744 BLAKE2B 1525b0894e47facdc51da0c6417d69b12d630bb0e6e8d7b3916b0c4e82380243b1b4dd0ddf82f7954d83edcd7b30346cff0305d98296b4aeccc1fe3cab325cd7 SHA512 8d1a07f8f32f63ec77e6bff8a39badd1eef87b0675096f964ff2fa770dda7c79ec9a1f788cbfa77528163aeb6c6067ca74e009293eca2e718dce92a48aef5f98
+DIST featherpad-1.1.0.tar.gz 1061070 BLAKE2B 78c7ddf0b7961a300fe2e425876bfaf32a1186eb88c2619202cb2f07a780aed3c2f8d1ced0e963b1868c94e890d1d809baae534fe1f3d06b3f3036aeeccf7414 SHA512 c734619ea8eda2709ccfa4d1b3c2ac541f32d52f31f0896ddf3c1c5733f175da9d955458a62a34221400a73003970cf796f59cf574b499831267b6f4d1a28d21
diff --git a/app-editors/featherpad/featherpad-0.18.0.ebuild b/app-editors/featherpad/featherpad-1.1.0.ebuild
index 6c98ead81b19..dd562f11fb34 100644
--- a/app-editors/featherpad/featherpad-0.18.0.ebuild
+++ b/app-editors/featherpad/featherpad-1.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 2021-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -8,21 +8,30 @@ inherit xdg cmake
DESCRIPTION="Lightweight Qt5 Plain-Text Editor for Linux"
HOMEPAGE="https://github.com/tsujan/FeatherPad"
SRC_URI="https://github.com/tsujan/FeatherPad/archive/V${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/FeatherPad-${PV}"
LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="+X"
-RDEPEND="app-text/hunspell
+RDEPEND="app-text/hunspell:=
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
dev-qt/qtprintsupport:5
dev-qt/qtsvg:5
dev-qt/qtwidgets:5
- dev-qt/qtx11extras:5
- x11-libs/libX11"
+ X? (
+ dev-qt/qtx11extras:5
+ x11-libs/libX11
+ )"
DEPEND="${RDEPEND}"
BDEPEND="dev-qt/linguist-tools:5"
-S="${WORKDIR}/FeatherPad-${PV}"
+src_configure() {
+ local mycmakeargs=(
+ -DWITHOUT_X11=$(usex !X)
+ )
+ cmake_src_configure
+}