summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2018-06-30 12:11:25 +1000
committerMichael Palimaka <kensington@gentoo.org>2018-06-30 12:11:40 +1000
commitc759c5a9f36433e44fec1635e1612d294c5199d1 (patch)
treeabc0c5051871b91dcb76f68a4296a43a213b0eb8 /app-editors/focuswriter/focuswriter-1.6.13.ebuild
parentnet-misc/cmst: remove 2017.09.19 (diff)
downloadgentoo-c759c5a9f36433e44fec1635e1612d294c5199d1.tar.gz
gentoo-c759c5a9f36433e44fec1635e1612d294c5199d1.tar.bz2
gentoo-c759c5a9f36433e44fec1635e1612d294c5199d1.zip
app-editors/focuswriter: version bump 1.6.13
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-editors/focuswriter/focuswriter-1.6.13.ebuild')
-rw-r--r--app-editors/focuswriter/focuswriter-1.6.13.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-editors/focuswriter/focuswriter-1.6.13.ebuild b/app-editors/focuswriter/focuswriter-1.6.13.ebuild
new file mode 100644
index 000000000000..f61c59e9ba31
--- /dev/null
+++ b/app-editors/focuswriter/focuswriter-1.6.13.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils qmake-utils xdg-utils
+
+DESCRIPTION="A fullscreen and distraction-free word processor"
+HOMEPAGE="https://gottcode.org/focuswriter/"
+SRC_URI="https://gottcode.org/${PN}/${P}-src.tar.bz2"
+
+LICENSE="LGPL-3 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# drop qtcore subslot when minimal Qt is 5.10
+RDEPEND="
+ app-text/hunspell:=
+ dev-qt/qtcore:5=
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsingleapplication[qt5(+),X]
+ dev-qt/qtwidgets:5
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ dev-qt/qtconcurrent:5
+ virtual/pkgconfig
+"
+
+DOCS=( ChangeLog CREDITS NEWS README )
+
+PATCHES=( "${FILESDIR}/${PN}-1.6.0-unbundle-qtsingleapplication.patch" )
+
+src_configure() {
+ eqmake5 PREFIX="${EPREFIX}/usr"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}