summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2020-04-21 18:14:08 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2020-04-25 21:29:54 +0200
commit8c98cd948cec2bd95aca32a239afcfa4b306fda0 (patch)
tree5d8181e9c0136b9a57a79a8d9cf9ceeed0d0e0a0 /app-editors/focuswriter
parentmedia-libs/ffmpegsource: migrate from libav (diff)
downloadgentoo-8c98cd948cec2bd95aca32a239afcfa4b306fda0.tar.gz
gentoo-8c98cd948cec2bd95aca32a239afcfa4b306fda0.tar.bz2
gentoo-8c98cd948cec2bd95aca32a239afcfa4b306fda0.zip
app-editors/focuswriter: add version 1.7.6
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/15458 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-editors/focuswriter')
-rw-r--r--app-editors/focuswriter/Manifest1
-rw-r--r--app-editors/focuswriter/focuswriter-1.7.6.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-editors/focuswriter/Manifest b/app-editors/focuswriter/Manifest
index a0f0a88ddf46..f19139a7a882 100644
--- a/app-editors/focuswriter/Manifest
+++ b/app-editors/focuswriter/Manifest
@@ -1,2 +1,3 @@
DIST focuswriter-1.7.2-src.tar.bz2 10310759 BLAKE2B 92f0cd0ec2bb29c41f2c98e52dcb2187a70bc1c0641aed521b3d577302937cf6560f3adf422372019c8726ca29a9978b5b4d9e56e4c0c26a65fdc5d6aa0b7767 SHA512 195ddf6579aa00af120644ef1ddc88a6aaf0a6003feefb7b3dd3ca72c4bb17440553a171ad469f2d25d90416fc0e1a03f1b9d43e3b5790dac180f18b4ed657bf
DIST focuswriter-1.7.5-src.tar.bz2 10311298 BLAKE2B c495aced12e2e4deea1b602a0d1e2f97adbf2c91edf94302978fbeca9e33807e20fc05db2758ee05fc4c54ee7281cca10b6c01b70f2859899a6b227235e7aed0 SHA512 b9b533180160c5395eee8b921cf05f56e13eb48db402d352359854b419bd5367f21bac1b07fb80d4bb59ab019a7051bb9aeb1321e35a8f9d250a9584475def8b
+DIST focuswriter-1.7.6-src.tar.bz2 10311965 BLAKE2B a1f1627df988d7660f6b90cf984d725ff2366754f01b0ce78e23756a98c716acafa8b4076f4749f117cba6eaabcb6ec61516c032a7ae770eb1b06466a358595e SHA512 45e0bc9b20c73b260aa42dcc9ee79515d3ad95d4c9586f60ab75fb404f73c7443484f238b3705ba3224b852a0d9b8b8db17d9145aebb77513f8597a01ab01d3b
diff --git a/app-editors/focuswriter/focuswriter-1.7.6.ebuild b/app-editors/focuswriter/focuswriter-1.7.6.ebuild
new file mode 100644
index 000000000000..da9506014d16
--- /dev/null
+++ b/app-editors/focuswriter/focuswriter-1.7.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils xdg
+
+DESCRIPTION="Fullscreen and distraction-free word processor"
+HOMEPAGE="https://gottcode.org/focuswriter/"
+SRC_URI="https://gottcode.org/${PN}/${P}-src.tar.bz2"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+"
+RDEPEND="
+ app-text/hunspell:=
+ >=dev-qt/qtcore-5.11:5
+ >=dev-qt/qtgui-5.11:5
+ >=dev-qt/qtmultimedia-5.11:5
+ >=dev-qt/qtprintsupport-5.11:5
+ dev-qt/qtsingleapplication[qt5(+),X]
+ >=dev-qt/qtwidgets-5.11:5
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ dev-qt/qtconcurrent:5
+"
+
+DOCS=( ChangeLog CREDITS README )
+
+PATCHES=( "${FILESDIR}/${PN}-1.6.0-unbundle-qtsingleapplication.patch" )
+
+src_configure() {
+ eqmake5 PREFIX="${EPREFIX}"/usr
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}