summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-07-26 00:14:12 -0400
committerTim Harder <radhermit@gentoo.org>2016-07-26 00:20:19 -0400
commit74951ad2de80d815aae14c943e75917070a89bed (patch)
tree44bd82a3e434bd566b8914d1c74324da9ab97a14 /app-editors/gvim/gvim-9999.ebuild
parentapp-editors/vim: version bump to 7.4.2102 (diff)
downloadgentoo-74951ad2de80d815aae14c943e75917070a89bed.tar.gz
gentoo-74951ad2de80d815aae14c943e75917070a89bed.tar.bz2
gentoo-74951ad2de80d815aae14c943e75917070a89bed.zip
app-editors/gvim: version bump to 7.4.2102
Diffstat (limited to 'app-editors/gvim/gvim-9999.ebuild')
-rw-r--r--app-editors/gvim/gvim-9999.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/app-editors/gvim/gvim-9999.ebuild b/app-editors/gvim/gvim-9999.ebuild
index 543f69541838..7bdb32354021 100644
--- a/app-editors/gvim/gvim-9999.ebuild
+++ b/app-editors/gvim/gvim-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
VIM_VERSION="7.4"
PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
PYTHON_REQ_USE=threads
@@ -14,7 +14,7 @@ if [[ ${PV} == 9999* ]] ; then
EGIT_CHECKOUT_DIR=${WORKDIR}/vim-${PV}
else
SRC_URI="https://github.com/vim/vim/archive/v${PV}.tar.gz -> vim-${PV}.tar.gz
- https://dev.gentoo.org/~radhermit/vim/vim-7.4.827-gentoo-patches.tar.bz2"
+ https://dev.gentoo.org/~radhermit/vim/vim-7.4.2102-gentoo-patches.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
fi
@@ -89,11 +89,8 @@ pkg_setup() {
src_prepare() {
if [[ ${PV} != 9999* ]] ; then
- if [[ -d "${WORKDIR}"/patches/ ]]; then
- # Gentoo patches to fix runtime issues, cross-compile errors, etc
- EPATCH_SUFFIX="patch" EPATCH_FORCE="yes" \
- epatch "${WORKDIR}"/patches/
- fi
+ # Gentoo patches to fix runtime issues, cross-compile errors, etc
+ eapply "${WORKDIR}"/patches/
fi
# Fixup a script to use awk instead of nawk
@@ -141,7 +138,7 @@ src_prepare() {
"${S}"/src/Makefile || die 'sed for ExtUtils-ParseXS failed'
fi
- epatch_user
+ default
}
src_configure() {