summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-08-15 18:29:24 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-08-15 18:29:47 +0200
commit4f0586fb53f1caacf2f7920eb0dae9fe80282c0b (patch)
tree82dbec526710fedf8eeb886a1d34f6e108bd4c34 /app-editors/nano/nano-9999.ebuild
parentnet-vpn/tor: bump 0.4.4.3-alpha to 0.4.4.4-rc (diff)
downloadgentoo-4f0586fb53f1caacf2f7920eb0dae9fe80282c0b.tar.gz
gentoo-4f0586fb53f1caacf2f7920eb0dae9fe80282c0b.tar.bz2
gentoo-4f0586fb53f1caacf2f7920eb0dae9fe80282c0b.zip
app-editors/nano: Don't move configs with USE="minimal"
Reported-by: Dragan Kašler <dragan.kasler@gmail.com> Closes: https://bugs.gentoo.org/737244 Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-editors/nano/nano-9999.ebuild')
-rw-r--r--app-editors/nano/nano-9999.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/app-editors/nano/nano-9999.ebuild b/app-editors/nano/nano-9999.ebuild
index 1a12756b35a5..86f22534c12f 100644
--- a/app-editors/nano/nano-9999.ebuild
+++ b/app-editors/nano/nano-9999.ebuild
@@ -77,13 +77,13 @@ src_install() {
sed -i \
-e '/^# include /s:# *::' \
"${ED}"/etc/nanorc || die
- fi
- # Since nano-5.0 these are no longer being "enabled" by default
- # (bug #736848)
- local rcdir="/usr/share/nano"
- mv "${ED}"${rcdir}/extra/* "${ED}"/${rcdir}/ || die
- rmdir "${ED}"${rcdir}/extra || die
+ # Since nano-5.0 these are no longer being "enabled" by default
+ # (bug #736848)
+ local rcdir="/usr/share/nano"
+ mv "${ED}"${rcdir}/extra/* "${ED}"/${rcdir}/ || die
+ rmdir "${ED}"${rcdir}/extra || die
+ fi
use split-usr && dosym ../../bin/nano /usr/bin/nano
}