summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-06-25 19:30:19 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-06-25 19:31:27 +0200
commit5850ad1d1cedd8804c33f2f47977141530733a07 (patch)
tree718e587c82032533899cdf55ac6df7d1b61da0e3 /app-editors/nano
parentwww-apache/anyterm: Fix building with GCC-6 (diff)
downloadgentoo-5850ad1d1cedd8804c33f2f47977141530733a07.tar.gz
gentoo-5850ad1d1cedd8804c33f2f47977141530733a07.tar.bz2
gentoo-5850ad1d1cedd8804c33f2f47977141530733a07.zip
app-editors/nano: Bump to version 2.8.5
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'app-editors/nano')
-rw-r--r--app-editors/nano/Manifest1
-rw-r--r--app-editors/nano/nano-2.8.5.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/app-editors/nano/Manifest b/app-editors/nano/Manifest
index 537a45aeac25..ea363364b783 100644
--- a/app-editors/nano/Manifest
+++ b/app-editors/nano/Manifest
@@ -2,3 +2,4 @@ DIST nano-2.6.3.tar.gz 2019354 SHA256 4f4054e12f2181c8e436163e931a0a565612242ff9
DIST nano-2.7.5.tar.gz 2031723 SHA256 226be22f46359007aa76499623739f4a7d5fa294a2899c70b21bc09b8d81d907 SHA512 a5332a361c4d0d9d0a77ebb11cdcffa976bee4981d5665b2732a9e6d7a2997566d9345332f2e6e5cb74f0a81be4413f54ca8f719962ab10b32d7ec1c9271973c WHIRLPOOL bd28cde96896ad531bb499504bb1438b358b64e7f6080fa24758bee7c222b4d1df0c395d480d0cef54de8e78a7e457db403a9ef2d6a56033e65299b6d7f95634
DIST nano-2.8.3.tar.gz 2773717 SHA256 2b3b7f383a40899db5367d3c4e663ba0088868c0f9aa4edfd7457c9a0eedbdd1 SHA512 ffedd36252bf13d57c9970840bc05b68c2b9211bf222a47a9aa559c078fdd993929c004d9aae3648e3190cbb32eef7ffb7a57de1c02e6e56b230366b9b55d9a1 WHIRLPOOL 63b4a3a0d93506788ba33553da3a6b7943e3559a2eae37b16700027665711f97313cc7199b189f4668d8a04584907dbf2a4b510f73ade8023729e6569890cd80
DIST nano-2.8.4.tar.gz 2785297 SHA256 78a2f3b3f6b500fad995c5e207d2816cbd6b531154aa2a3a2bd50c8fdf7dc57f SHA512 bbcaf710fdb5f403812b584a182ee472421d65c076f5fa2d538603c4cda8292485010157a2670e9890fcffc29d7db5c7334334d54d14f4e154b9bc3fe1ee919c WHIRLPOOL 9cce7539122b915b7b2a48c00b6cfce6ffe4e6af86605865a4e15f99e1a75cf0766f04ba81316dc92677c9fa78daf1513dce2a06c9cc668287cacf71f650fce5
+DIST nano-2.8.5.tar.gz 2795845 SHA256 e2b929b24fba87f7a44285ce8d47af7170e379bee1bf2d04fbc728b7326a558a SHA512 f59e32395b63e64afe8fa9c98785c53f9f841a1fce0677b8591c0f570b3bec24188b5f7acf4fb66cf41a83e0b3ba9436ca4abcfb861c27c7c24f4a5b7dd249db WHIRLPOOL bc83966f2f7e952115185e648fc77517dd31e0e9adace43b3543d5944f08000675a03de9bf9d2841993df86016a52720538a5e8579d35801dd8ffd0416253e17
diff --git a/app-editors/nano/nano-2.8.5.ebuild b/app-editors/nano/nano-2.8.5.ebuild
new file mode 100644
index 000000000000..ce5e828a27c7
--- /dev/null
+++ b/app-editors/nano/nano-2.8.5.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils flag-o-matic
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.sv.gnu.org/nano.git"
+ inherit git-r3 autotools
+else
+ MY_P=${PN}-${PV/_}
+ SRC_URI="https://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="GNU GPL'd Pico clone with more functionality"
+HOMEPAGE="https://www.nano-editor.org/ https://wiki.gentoo.org/wiki/Nano/Basics_Guide"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="debug justify +magic minimal ncurses nls slang +spell static unicode"
+
+LIB_DEPEND=">=sys-libs/ncurses-5.9-r1:0=[unicode?]
+ sys-libs/ncurses:0=[static-libs(+)]
+ magic? ( sys-apps/file[static-libs(+)] )
+ nls? ( virtual/libintl )
+ !ncurses? ( slang? ( sys-libs/slang[static-libs(+)] ) )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+ static? ( ${LIB_DEPEND} )"
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ eautoreconf
+ fi
+ default
+}
+
+src_configure() {
+ use static && append-ldflags -static
+ local myconf=()
+ case ${CHOST} in
+ *-gnu*|*-uclibc*) myconf+=( "--with-wordbounds" ) ;; #467848
+ esac
+ econf \
+ --bindir="${EPREFIX}"/bin \
+ --htmldir=/trash \
+ $(use_enable !minimal color) \
+ $(use_enable !minimal multibuffer) \
+ $(use_enable !minimal nanorc) \
+ --disable-wrapping-as-root \
+ $(use_enable magic libmagic) \
+ $(use_enable spell speller) \
+ $(use_enable justify) \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable unicode utf8) \
+ $(use_enable minimal tiny) \
+ $(usex ncurses --without-slang $(use_with slang)) \
+ "${myconf[@]}"
+}
+
+src_install() {
+ default
+ rm -rf "${D}"/trash
+
+ dodoc doc/sample.nanorc
+ docinto html
+ dodoc doc/faq.html
+ insinto /etc
+ newins doc/sample.nanorc nanorc
+ if ! use minimal ; then
+ # Enable colorization by default.
+ sed -i \
+ -e '/^# include /s:# *::' \
+ "${ED}"/etc/nanorc || die
+ fi
+
+ dodir /usr/bin
+ dosym /bin/nano /usr/bin/nano
+}