summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-editors/qxmledit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-editors/qxmledit')
-rw-r--r--app-editors/qxmledit/Manifest2
-rw-r--r--app-editors/qxmledit/metadata.xml19
-rw-r--r--app-editors/qxmledit/qxmledit-0.8.5.ebuild59
-rw-r--r--app-editors/qxmledit/qxmledit-0.8.8.1.ebuild63
4 files changed, 143 insertions, 0 deletions
diff --git a/app-editors/qxmledit/Manifest b/app-editors/qxmledit/Manifest
new file mode 100644
index 000000000000..f671aec5440c
--- /dev/null
+++ b/app-editors/qxmledit/Manifest
@@ -0,0 +1,2 @@
+DIST qxmledit-0.8.5-src.tgz 6727188 SHA256 aedb70f27493ba50f0c8bde4acdd8913fcf4221611b24f9042769df47aa701c4 SHA512 c974dc0787fdc1831a39e9e36f842ed92ca5b57e9e66e64822eea4646d88a0755f9aa791e4d7724872856561eac213413696fa7b0f61d89b54e29cbc95049a8a WHIRLPOOL 362d898005677dea5bb7372bc78d8b5d9376f2c7555be3086448778202a55fff5766856c39a55561c92b08498ecafaeace033121ba4706b4c1aa923ea45f28d8
+DIST qxmledit-0.8.8-1-src.tgz 8885329 SHA256 d43ccd0029b1094a970d58170a095cbe5fddfe3d93da7c52388783d321386e17 SHA512 5440d33c052507d3b5c840cdd2966c151a77e2027703f7c1d33f80ec786affab915053d2ae17ef72fd856223ca85dbb70d39d8800170449a26ea88632c0069b5 WHIRLPOOL 68f8d73c39ce490f13d88283053ad045125f007132a25d965ffb603ab1de1d42b62944659a76aa9bbb5adc884b37ad90f7eaf4487f314678d8a1923cd16f1078
diff --git a/app-editors/qxmledit/metadata.xml b/app-editors/qxmledit/metadata.xml
new file mode 100644
index 000000000000..64f2a9e844c3
--- /dev/null
+++ b/app-editors/qxmledit/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <maintainer>
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
+ </maintainer>
+ <longdescription lang="en">
+ QXmlEdit is a simple XML editor written in Qt4. Its main
+ features are unusual data visualization modes, it has some
+ nice XML manipulation and presentation features and it is
+ multi-platform. This is one of the few graphical Open Source
+ XSD viewer.
+ </longdescription>
+ <upstream>
+ <remote-id type="google-code">qxmledit</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-editors/qxmledit/qxmledit-0.8.5.ebuild b/app-editors/qxmledit/qxmledit-0.8.5.ebuild
new file mode 100644
index 000000000000..64d14f99aadc
--- /dev/null
+++ b/app-editors/qxmledit/qxmledit-0.8.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib eutils qt4-r2
+
+MY_P="qxmledit-${PV}-src"
+
+DESCRIPTION="Qt4 XML Editor"
+HOMEPAGE="http://code.google.com/p/qxmledit/"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_P}.tgz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+DEPEND=">=dev-qt/qtcore-4.7:4
+ >=dev-qt/qtgui-4.7:4
+ >=dev-qt/qtsql-4.7:4
+ >=dev-qt/qtsvg-4.7:4
+ >=dev-qt/qtxmlpatterns-4.7:4"
+RDEPEND="${DEPEND}"
+
+DOCS="AUTHORS NEWS README ROADMAP TODO"
+
+src_prepare() {
+ # fix doc dir
+ sed -i "/INST_DOC_DIR = / s|/opt/${PN}|/usr/share/doc/${PF}|" \
+ src/QXmlEdit{,Widget}.pro src/sessions/QXmlEditSessions.pro || \
+ die "failed to fix doc installation path"
+ # fix binary installation path
+ sed -i "/INST_DIR = / s|/opt/${PN}|/usr/bin|" \
+ src/QXmlEdit{,Widget}.pro src/sessions/QXmlEditSessions.pro || \
+ die "failed to fix binary installation path"
+ # fix helper libraries installation path
+ sed -i "/INST_LIB_DIR = / s|/opt/${PN}|/usr/$(get_libdir)|" \
+ src/QXmlEdit{,Widget}.pro \
+ src/sessions/QXmlEditSessions.pro || \
+ die "failed to fix library installation path"
+ # fix translations
+ sed -i "/INST_DATA_DIR = / s|/opt|/usr/share|" src/QXmlEdit{,Widget}.pro \
+ src/sessions/QXmlEditSessions.pro || \
+ die "failed to fix translations"
+ # fix include
+ sed -i "/INST_INCLUDE_DIR = / s|/opt|/usr/share|" src/QXmlEditWidget.pro \
+ || die "failed to fix include directory"
+
+ qt4-r2_src_prepare
+}
+
+src_install() {
+ qt4-r2_src_install
+
+ newicon src/images/icon.png ${PN}.png
+ make_desktop_entry QXmlEdit QXmlEdit ${PN} "Qt;Utility;TextEditor"
+}
diff --git a/app-editors/qxmledit/qxmledit-0.8.8.1.ebuild b/app-editors/qxmledit/qxmledit-0.8.8.1.ebuild
new file mode 100644
index 000000000000..55be50079aa2
--- /dev/null
+++ b/app-editors/qxmledit/qxmledit-0.8.8.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib eutils qt4-r2 versionator
+
+MY_PV="$(replace_version_separator 3 '-')"
+
+MY_P="qxmledit-${MY_PV}-src"
+
+DESCRIPTION="Qt4 XML Editor"
+HOMEPAGE="http://code.google.com/p/qxmledit/"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_P}.tgz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+DEPEND=">=dev-qt/qtcore-4.7:4
+ >=dev-qt/qtgui-4.7:4
+ >=dev-qt/qtsql-4.7:4
+ >=dev-qt/qtsvg-4.7:4
+ >=dev-qt/qtxmlpatterns-4.7:4"
+RDEPEND="${DEPEND}"
+
+DOCS="AUTHORS NEWS README ROADMAP TODO"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ # fix doc dir
+ sed -i "/INST_DOC_DIR = / s|/opt/${PN}|/usr/share/doc/${PF}|" \
+ src/QXmlEdit{,Widget}.pro src/sessions/QXmlEditSessions.pro || \
+ die "failed to fix doc installation path"
+ # fix binary installation path
+ sed -i "/INST_DIR = / s|/opt/${PN}|/usr/bin|" \
+ src/QXmlEdit{,Widget}.pro src/sessions/QXmlEditSessions.pro || \
+ die "failed to fix binary installation path"
+ # fix helper libraries installation path
+ sed -i "/INST_LIB_DIR = / s|/opt/${PN}|/usr/$(get_libdir)|" \
+ src/QXmlEdit{,Widget}.pro \
+ src/sessions/QXmlEditSessions.pro || \
+ die "failed to fix library installation path"
+ # fix translations
+ sed -i "/INST_DATA_DIR = / s|/opt|/usr/share|" src/QXmlEdit{,Widget}.pro \
+ src/sessions/QXmlEditSessions.pro || \
+ die "failed to fix translations"
+ # fix include
+ sed -i "/INST_INCLUDE_DIR = / s|/opt|/usr/share|" src/QXmlEditWidget.pro \
+ || die "failed to fix include directory"
+
+ qt4-r2_src_prepare
+}
+
+src_install() {
+ qt4-r2_src_install
+
+ newicon src/images/icon.png ${PN}.png
+ make_desktop_entry QXmlEdit QXmlEdit ${PN} "Qt;Utility;TextEditor"
+}