summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2020-01-29 22:05:27 +0100
committerUlrich Müller <ulm@gentoo.org>2020-01-29 22:05:50 +0100
commitaec2ea4dc24605b4f334e04aad81f9a2976ea012 (patch)
treed739ebe953b8a735ac828e99707bfd315138579c /app-editors/teco
parentacct-user/gerbera: Initial commit (diff)
downloadgentoo-aec2ea4dc24605b4f334e04aad81f9a2976ea012.tar.gz
gentoo-aec2ea4dc24605b4f334e04aad81f9a2976ea012.tar.bz2
gentoo-aec2ea4dc24605b4f334e04aad81f9a2976ea012.zip
app-editors/teco: Fix compilation with -fno-common.
Closes:https://bugs.gentoo.org/707300 Package-Manager: Portage-2.3.85, Repoman-2.3.20 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-editors/teco')
-rw-r--r--app-editors/teco/files/teco-no-common.patch13
-rw-r--r--app-editors/teco/teco-36_p19940820.ebuild3
2 files changed, 15 insertions, 1 deletions
diff --git a/app-editors/teco/files/teco-no-common.patch b/app-editors/teco/files/teco-no-common.patch
new file mode 100644
index 000000000000..18880579e370
--- /dev/null
+++ b/app-editors/teco/files/teco-no-common.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/707300
+
+--- teco-orig/te_subs.c
++++ teco/te_subs.c
+@@ -249,8 +249,6 @@
+ /* leaves bb pointing to end of that text */
+ /* insert2() copies rest of buffer */
+
+-struct buffcell *insert_p;
+-
+ insert1()
+ {
+ int nchars; /* number of chars in cell */
diff --git a/app-editors/teco/teco-36_p19940820.ebuild b/app-editors/teco/teco-36_p19940820.ebuild
index 4f297c289581..4dd048a4f2d5 100644
--- a/app-editors/teco/teco-36_p19940820.ebuild
+++ b/app-editors/teco/teco-36_p19940820.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -25,6 +25,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-double-free.patch
"${FILESDIR}"/${PN}-gcc4.patch
"${FILESDIR}"/${PN}-warnings.patch
+ "${FILESDIR}"/${PN}-no-common.patch
)
src_prepare() {