summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2022-03-02 14:41:38 -0500
committerPatrice Clement <monsieurp@gentoo.org>2022-03-02 21:04:56 +0100
commit0816769373e7ee62685158b65f7cfde287e5d936 (patch)
treed5f8971ccb0f9fdf1ffbc2ec81c34a68d2570972 /app-editors/vim
parentapp-editors/vim-core: always install defaults.vim. (diff)
downloadgentoo-0816769373e7ee62685158b65f7cfde287e5d936.tar.gz
gentoo-0816769373e7ee62685158b65f7cfde287e5d936.tar.bz2
gentoo-0816769373e7ee62685158b65f7cfde287e5d936.zip
app-editors/vim: depend on vim-core unconditionally
We need it for defaults.vim, which cannot be owned by 2 packages simultaneously. Bug: https://bugs.gentoo.org/834498 Signed-off-by: Mike Gilbert <floppym@gentoo.org> Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-editors/vim')
-rw-r--r--app-editors/vim/vim-8.2.4328-r1.ebuild (renamed from app-editors/vim/vim-8.2.4328.ebuild)11
-rw-r--r--app-editors/vim/vim-9999.ebuild11
2 files changed, 4 insertions, 18 deletions
diff --git a/app-editors/vim/vim-8.2.4328.ebuild b/app-editors/vim/vim-8.2.4328-r1.ebuild
index 2b7c3b0992cc..5d9a0aae046a 100644
--- a/app-editors/vim/vim-8.2.4328.ebuild
+++ b/app-editors/vim/vim-8.2.4328-r1.ebuild
@@ -45,7 +45,8 @@ RDEPEND="
lua? ( ${LUA_DEPS}
$(lua_gen_impl_dep 'deprecated' lua5-1)
)
- !minimal? ( ~app-editors/vim-core-${PV} )
+ ~app-editors/vim-core-${PV}
+ !<app-editors/vim-core-8.2.4328-r1
vim-pager? ( app-editors/vim-core[-minimal] )
perl? ( dev-lang/perl:= )
python? ( ${PYTHON_DEPS} )
@@ -318,14 +319,6 @@ src_install() {
fperms a+x ${vimfiles}/macros/manpager.sh
fi
- # Fix an issue of missing defaults.vim when USE=minimal.
- if use minimal ; then
- if [[ ! -f "${vimfiles}/defaults.vim" ]]; then
- insinto ${vimfiles}
- doins runtime/defaults.vim
- fi
- fi
-
domenu runtime/vim.desktop
newbashcomp "${FILESDIR}"/${PN}-completion ${PN}
diff --git a/app-editors/vim/vim-9999.ebuild b/app-editors/vim/vim-9999.ebuild
index 2b7c3b0992cc..5d9a0aae046a 100644
--- a/app-editors/vim/vim-9999.ebuild
+++ b/app-editors/vim/vim-9999.ebuild
@@ -45,7 +45,8 @@ RDEPEND="
lua? ( ${LUA_DEPS}
$(lua_gen_impl_dep 'deprecated' lua5-1)
)
- !minimal? ( ~app-editors/vim-core-${PV} )
+ ~app-editors/vim-core-${PV}
+ !<app-editors/vim-core-8.2.4328-r1
vim-pager? ( app-editors/vim-core[-minimal] )
perl? ( dev-lang/perl:= )
python? ( ${PYTHON_DEPS} )
@@ -318,14 +319,6 @@ src_install() {
fperms a+x ${vimfiles}/macros/manpager.sh
fi
- # Fix an issue of missing defaults.vim when USE=minimal.
- if use minimal ; then
- if [[ ! -f "${vimfiles}/defaults.vim" ]]; then
- insinto ${vimfiles}
- doins runtime/defaults.vim
- fi
- fi
-
domenu runtime/vim.desktop
newbashcomp "${FILESDIR}"/${PN}-completion ${PN}