summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOskari Pirhonen <xxc3ncoredxx@gmail.com>2023-02-16 01:08:47 -0600
committerSam James <sam@gentoo.org>2023-02-18 04:32:39 +0000
commit87781a11938d30a03e4a5bf3eb7b8463d9757494 (patch)
treed0bad445ea5dac565262f481bae62ea059585cb3 /app-editors/vim
parentapp-editors/gvim: remove manual patch application (diff)
downloadgentoo-87781a11938d30a03e4a5bf3eb7b8463d9757494.tar.gz
gentoo-87781a11938d30a03e4a5bf3eb7b8463d9757494.tar.bz2
gentoo-87781a11938d30a03e4a5bf3eb7b8463d9757494.zip
app-editors/vim: remove manual patch application
Signed-off-by: Oskari Pirhonen <xxc3ncoredxx@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors/vim')
-rw-r--r--app-editors/vim/vim-9.0.1000.ebuild14
-rw-r--r--app-editors/vim/vim-9.0.1157.ebuild14
-rw-r--r--app-editors/vim/vim-9999.ebuild14
3 files changed, 24 insertions, 18 deletions
diff --git a/app-editors/vim/vim-9.0.1000.ebuild b/app-editors/vim/vim-9.0.1000.ebuild
index 3a6b2790f37b..c3de4d218ee4 100644
--- a/app-editors/vim/vim-9.0.1000.ebuild
+++ b/app-editors/vim/vim-9.0.1000.ebuild
@@ -68,6 +68,13 @@ BDEPEND="
"
PDEPEND="!minimal? ( app-vim/gentoo-syntax )"
+if [[ ${PV} != 9999* ]]; then
+ # Gentoo patches to fix runtime issues, cross-compile errors, etc
+ PATCHES=(
+ "${WORKDIR}/vim-patches-vim-${VIM_PATCHES_VERSION}-patches"
+ )
+fi
+
pkg_setup() {
# people with broken alphabets run into trouble. bug #82186.
unset LANG LC_ALL
@@ -78,10 +85,7 @@ pkg_setup() {
}
src_prepare() {
- if [[ ${PV} != 9999* ]] ; then
- # Gentoo patches to fix runtime issues, cross-compile errors, etc
- eapply "${WORKDIR}"/vim-patches-vim-${VIM_PATCHES_VERSION}-patches
- fi
+ default
# Fixup a script to use awk instead of nawk
sed -i -e \
@@ -153,8 +157,6 @@ src_prepare() {
# (4) Run ./configure (with wrong args) to remake auto/config.mk
sed -i 's# auto/config\.mk:#:#' src/Makefile || die "Makefile sed failed"
rm src/auto/configure || die "rm failed"
-
- eapply_user
}
src_configure() {
diff --git a/app-editors/vim/vim-9.0.1157.ebuild b/app-editors/vim/vim-9.0.1157.ebuild
index a41d999afbf2..40a78fc412a4 100644
--- a/app-editors/vim/vim-9.0.1157.ebuild
+++ b/app-editors/vim/vim-9.0.1157.ebuild
@@ -68,6 +68,13 @@ BDEPEND="
"
PDEPEND="!minimal? ( app-vim/gentoo-syntax )"
+if [[ ${PV} != 9999* ]]; then
+ # Gentoo patches to fix runtime issues, cross-compile errors, etc
+ PATCHES=(
+ "${WORKDIR}/vim-patches-vim-${VIM_PATCHES_VERSION}-patches"
+ )
+fi
+
pkg_setup() {
# people with broken alphabets run into trouble. bug #82186.
unset LANG LC_ALL
@@ -78,10 +85,7 @@ pkg_setup() {
}
src_prepare() {
- if [[ ${PV} != 9999* ]] ; then
- # Gentoo patches to fix runtime issues, cross-compile errors, etc
- eapply "${WORKDIR}"/vim-patches-vim-${VIM_PATCHES_VERSION}-patches
- fi
+ default
# Fixup a script to use awk instead of nawk
sed -i -e \
@@ -153,8 +157,6 @@ src_prepare() {
# (4) Run ./configure (with wrong args) to remake auto/config.mk
sed -i 's# auto/config\.mk:#:#' src/Makefile || die "Makefile sed failed"
rm src/auto/configure || die "rm failed"
-
- eapply_user
}
src_configure() {
diff --git a/app-editors/vim/vim-9999.ebuild b/app-editors/vim/vim-9999.ebuild
index a41d999afbf2..40a78fc412a4 100644
--- a/app-editors/vim/vim-9999.ebuild
+++ b/app-editors/vim/vim-9999.ebuild
@@ -68,6 +68,13 @@ BDEPEND="
"
PDEPEND="!minimal? ( app-vim/gentoo-syntax )"
+if [[ ${PV} != 9999* ]]; then
+ # Gentoo patches to fix runtime issues, cross-compile errors, etc
+ PATCHES=(
+ "${WORKDIR}/vim-patches-vim-${VIM_PATCHES_VERSION}-patches"
+ )
+fi
+
pkg_setup() {
# people with broken alphabets run into trouble. bug #82186.
unset LANG LC_ALL
@@ -78,10 +85,7 @@ pkg_setup() {
}
src_prepare() {
- if [[ ${PV} != 9999* ]] ; then
- # Gentoo patches to fix runtime issues, cross-compile errors, etc
- eapply "${WORKDIR}"/vim-patches-vim-${VIM_PATCHES_VERSION}-patches
- fi
+ default
# Fixup a script to use awk instead of nawk
sed -i -e \
@@ -153,8 +157,6 @@ src_prepare() {
# (4) Run ./configure (with wrong args) to remake auto/config.mk
sed -i 's# auto/config\.mk:#:#' src/Makefile || die "Makefile sed failed"
rm src/auto/configure || die "rm failed"
-
- eapply_user
}
src_configure() {