summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2020-07-28 14:45:29 -0400
committerAaron Bauman <bman@gentoo.org>2020-07-28 14:45:29 -0400
commit3831172264494f42d621e760593f4d066900d922 (patch)
tree3a31692fd34affb4b8b80d14ac9029f7162213eb /app-editors
parentupdates/2Q2018: drop slotmove for netmail/getmail (diff)
downloadgentoo-3831172264494f42d621e760593f4d066900d922.tar.gz
gentoo-3831172264494f42d621e760593f4d066900d922.tar.bz2
gentoo-3831172264494f42d621e760593f4d066900d922.zip
*/*: Drop more Py2 last-rited pkgs
Bug: https://bugs.gentoo.org/715966 Closes: https://bugs.gentoo.org/714628 Closes: https://bugs.gentoo.org/606680 Closes: https://bugs.gentoo.org/686238 Closes: https://bugs.gentoo.org/710214 Closes: https://bugs.gentoo.org/710028 Closes: https://bugs.gentoo.org/710032 Closes: https://bugs.gentoo.org/656934 Closes: https://bugs.gentoo.org/592718 Closes: https://bugs.gentoo.org/446122 Closes: https://bugs.gentoo.org/547210 Closes: https://bugs.gentoo.org/359785 Closes: https://bugs.gentoo.org/571396 Closes: https://bugs.gentoo.org/600754 Closes: https://bugs.gentoo.org/677830 Closes: https://bugs.gentoo.org/710716 Closes: https://bugs.gentoo.org/651940 Closes: https://bugs.gentoo.org/695132 Closes: https://bugs.gentoo.org/708978 Closes: https://bugs.gentoo.org/710058 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/editra/Manifest1
-rw-r--r--app-editors/editra/editra-0.7.20-r2.ebuild54
-rw-r--r--app-editors/editra/files/editra-0.7.20-wx30.patch44
-rw-r--r--app-editors/editra/metadata.xml8
-rw-r--r--app-editors/leo/Manifest1
-rw-r--r--app-editors/leo/leo-5.6.ebuild36
-rw-r--r--app-editors/leo/metadata.xml9
7 files changed, 0 insertions, 153 deletions
diff --git a/app-editors/editra/Manifest b/app-editors/editra/Manifest
deleted file mode 100644
index e4dbf0ec1afa..000000000000
--- a/app-editors/editra/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST Editra-0.7.20.tar.gz 4072243 BLAKE2B 3a2d38888ea9d7a12a77d4adb57b7e5c926757791e8b48eedd8413b6712cbfb2c616c3cf26f3f49c3a7ac5acf37d373cff8d37c63e255a1d0a9ec1add3dcbbe6 SHA512 e568ce2a5f04300c33223bf7a0e6fbc52d0a51c3472afb9b613fe21cfbeba0b9b453d87837e52c7c48050fc266ff5ff194a42f797053f21f0a25cd5c4579febe
diff --git a/app-editors/editra/editra-0.7.20-r2.ebuild b/app-editors/editra/editra-0.7.20-r2.ebuild
deleted file mode 100644
index 04cfc91b0dfe..000000000000
--- a/app-editors/editra/editra-0.7.20-r2.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils distutils-r1 fdo-mime
-
-MY_PN=${PN/e/E}
-
-DESCRIPTION="Multi-platform text editor supporting over 50 programming languages"
-HOMEPAGE="http://editra.org https://pypi.org/project/Editra/"
-SRC_URI="http://editra.org/uploads/src/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="wxWinLL-3.1"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="spell"
-
-DEPEND="
- dev-python/wxpython:3.0[${PYTHON_USEDEP}]
- >=dev-python/setuptools-0.6[${PYTHON_USEDEP}]"
-# setuptools is RDEPEND because it's used by the runtime for installing plugins
-RDEPEND="${DEPEND}
- spell? ( dev-python/pyenchant[${PYTHON_USEDEP}] )"
-
-PATCHES=( "${FILESDIR}/${P}-wx30.patch" )
-
-S="${WORKDIR}"/${MY_PN}-${PV}
-
-python_compile() {
- # https://code.google.com/p/editra/issues/detail?id=481
- distutils-r1_python_compile --no-clean
-}
-
-python_install() {
- distutils-r1_python_install --no-clean
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- doicon "${S}"/pixmaps/editra.png
- make_desktop_entry editra Editra editra "Utility;TextEditor"
- dodoc FAQ THANKS
-}
-
-pkg_postinst() {
- fdo-mime_desktop_database_update
-}
-
-pkg_postrm() {
- fdo-mime_desktop_database_update
-}
diff --git a/app-editors/editra/files/editra-0.7.20-wx30.patch b/app-editors/editra/files/editra-0.7.20-wx30.patch
deleted file mode 100644
index e5e7b7f918d6..000000000000
--- a/app-editors/editra/files/editra-0.7.20-wx30.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-Description: Updates for better wxPython 3.0 compatibility
-Author: Olly Betts <olly@survex.com>
-Bug-Debian: https://bugs.debian.org/758947
-Forwarded: no
-Last-Update: 2014-08-30
-
---- editra-0.7.20+dfsg.1.orig/src/ed_main.py
-+++ editra-0.7.20+dfsg.1/src/ed_main.py
-@@ -432,7 +432,7 @@ class MainWindow(wx.Frame, viewmgr.Persp
-
- dlg = wx.FileDialog(self, _("Editra: Open"), fdir, "",
- ''.join(syntax.GenFileFilters()),
-- wx.OPEN | wx.MULTIPLE | wx.CHANGE_DIR)
-+ wx.FD_OPEN | wx.FD_MULTIPLE | wx.FD_CHANGE_DIR)
- dlg.SetFilterIndex(_PGET('FFILTER', 'int', 0))
-
- if ebmlib.LockCall(self._mlock, dlg.ShowModal) == wx.ID_OK:
-@@ -680,7 +680,7 @@ class MainWindow(wx.Frame, viewmgr.Persp
- os.path.dirname(sdir),
- title.lstrip(u"*"),
- u''.join(syntax.GenFileFilters()),
-- wx.SAVE | wx.OVERWRITE_PROMPT)
-+ wx.FD_SAVE | wx.FD_OVERWRITE_PROMPT)
-
- if ebmlib.LockCall(self._mlock, dlg.ShowModal) == wx.ID_OK:
- path = dlg.GetPath()
-@@ -713,7 +713,7 @@ class MainWindow(wx.Frame, viewmgr.Persp
- dlg = wx.FileDialog(self, _("Where to Save Profile?"), \
- CONFIG['PROFILE_DIR'], "default.ppb", \
- _("Profile") + " (*.ppb)|*.ppb",
-- wx.SAVE | wx.OVERWRITE_PROMPT)
-+ wx.FD_SAVE | wx.FD_OVERWRITE_PROMPT)
-
- if ebmlib.LockCall(self._mlock, dlg.ShowModal) == wx.ID_OK:
- profiler.TheProfile.Write(dlg.GetPath())
-@@ -732,7 +732,7 @@ class MainWindow(wx.Frame, viewmgr.Persp
- if evt.Id == ID_LOAD_PROFILE:
- dlg = wx.FileDialog(self, _("Load a Custom Profile"),
- CONFIG['PROFILE_DIR'], "default.ppb",
-- _("Profile") + " (*.ppb)|*.ppb", wx.OPEN)
-+ _("Profile") + " (*.ppb)|*.ppb", wx.FD_OPEN)
-
- if ebmlib.LockCall(self._mlock, dlg.ShowModal) == wx.ID_OK:
- profiler.TheProfile.Load(dlg.GetPath())
diff --git a/app-editors/editra/metadata.xml b/app-editors/editra/metadata.xml
deleted file mode 100644
index 0c7ee856e108..000000000000
--- a/app-editors/editra/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>wxwidgets@gentoo.org</email>
- <name>Gentoo wxWidgets Project</name>
- </maintainer>
-</pkgmetadata>
diff --git a/app-editors/leo/Manifest b/app-editors/leo/Manifest
deleted file mode 100644
index db9ba9583b85..000000000000
--- a/app-editors/leo/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST leo-5.6.tar.gz 9255687 BLAKE2B 46a9aa1d90a1663ece57731b3685def3bf050f2c398310aca9d24c07256d23e40a94e505c43bd90c6c5a58fda2021409d3e6510eddd5a1bc0533273c45495475 SHA512 c9f6583be4f6a76d781adccc4076782c6f136b1057796228a398cd31c92d61e1b7a86d151f36352c6b1f677bb3d298b6f347c9874e3782c645fdb6ee38747955
diff --git a/app-editors/leo/leo-5.6.ebuild b/app-editors/leo/leo-5.6.ebuild
deleted file mode 100644
index 2ee3cdc76dc0..000000000000
--- a/app-editors/leo/leo-5.6.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_P="${PN}-editor-${PV}"
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQUIRED_USE="tk"
-inherit distutils-r1
-
-DESCRIPTION="Leo: Literate Editor with Outlines"
-HOMEPAGE="https://github.com/leo-editor/leo-editor/"
-SRC_URI="https://github.com/leo-editor/leo-editor/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc"
-
-RDEPEND="
- app-text/silvercity[${PYTHON_USEDEP}]
- dev-python/PyQt5[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
- cp leo/dist/setup.py leo/dist/leo-install.py . || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( leo/doc/html/. )
- distutils-r1_python_install_all
-}
diff --git a/app-editors/leo/metadata.xml b/app-editors/leo/metadata.xml
deleted file mode 100644
index 4e9fe29019ce..000000000000
--- a/app-editors/leo/metadata.xml
+++ /dev/null
@@ -1,9 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="github">leo-editor/leo-editor</remote-id>
- <remote-id type="sourceforge">leo</remote-id>
- </upstream>
-</pkgmetadata>