summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-09-26 03:25:39 -0400
committerMike Frysinger <vapier@gentoo.org>2015-09-26 04:07:42 -0400
commit40bbbb5a40ced77b0f1884bc9fef7ad344516449 (patch)
treec10ea7eb0342aab7c91a0f0f1d22d6d9c4219fcb /app-editors
parentsys-apps/less: update to EAPI=5 and use subslot w/ncurses #561312 (diff)
downloadgentoo-40bbbb5a40ced77b0f1884bc9fef7ad344516449.tar.gz
gentoo-40bbbb5a40ced77b0f1884bc9fef7ad344516449.tar.bz2
gentoo-40bbbb5a40ced77b0f1884bc9fef7ad344516449.zip
app-editors/nano: update to EAPI=5 and use subslot w/ncurses #561310
Also sync the magic changes from the non-live to the 9999 ebuild.
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/nano/nano-2.4.2.ebuild6
-rw-r--r--app-editors/nano/nano-9999.ebuild8
2 files changed, 7 insertions, 7 deletions
diff --git a/app-editors/nano/nano-2.4.2.ebuild b/app-editors/nano/nano-2.4.2.ebuild
index f324c2e1ac7f..48d87ed39596 100644
--- a/app-editors/nano/nano-2.4.2.ebuild
+++ b/app-editors/nano/nano-2.4.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI="5"
inherit eutils flag-o-matic
if [[ ${PV} == "9999" ]] ; then
@@ -21,8 +21,8 @@ LICENSE="GPL-3"
SLOT="0"
IUSE="debug justify +magic minimal ncurses nls slang +spell static unicode"
-LIB_DEPEND=">=sys-libs/ncurses-5.9-r1:0[unicode?]
- sys-libs/ncurses:0[static-libs(+)]
+LIB_DEPEND=">=sys-libs/ncurses-5.9-r1:0=[unicode?]
+ sys-libs/ncurses:0=[static-libs(+)]
magic? ( sys-apps/file[static-libs(+)] )
nls? ( virtual/libintl )
!ncurses? ( slang? ( sys-libs/slang[static-libs(+)] ) )"
diff --git a/app-editors/nano/nano-9999.ebuild b/app-editors/nano/nano-9999.ebuild
index 8548decc2d0e..48d87ed39596 100644
--- a/app-editors/nano/nano-9999.ebuild
+++ b/app-editors/nano/nano-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI="5"
inherit eutils flag-o-matic
if [[ ${PV} == "9999" ]] ; then
@@ -21,8 +21,8 @@ LICENSE="GPL-3"
SLOT="0"
IUSE="debug justify +magic minimal ncurses nls slang +spell static unicode"
-LIB_DEPEND=">=sys-libs/ncurses-5.9-r1:0[unicode?]
- sys-libs/ncurses:0[static-libs(+)]
+LIB_DEPEND=">=sys-libs/ncurses-5.9-r1:0=[unicode?]
+ sys-libs/ncurses:0=[static-libs(+)]
magic? ( sys-apps/file[static-libs(+)] )
nls? ( virtual/libintl )
!ncurses? ( slang? ( sys-libs/slang[static-libs(+)] ) )"
@@ -41,7 +41,6 @@ src_prepare() {
src_configure() {
use static && append-ldflags -static
- eval export ac_cv_{header_magic_h,lib_magic_magic_open}=$(usex magic)
local myconf=()
case ${CHOST} in
*-gnu*|*-uclibc*) myconf+=( "--with-wordbounds" ) ;; #467848
@@ -53,6 +52,7 @@ src_configure() {
$(use_enable !minimal multibuffer) \
$(use_enable !minimal nanorc) \
--disable-wrapping-as-root \
+ $(use_enable magic libmagic) \
$(use_enable spell speller) \
$(use_enable justify) \
$(use_enable debug) \