summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans Fredrik Nordhaug <hansfn@gmail.com>2021-09-01 09:14:10 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-09-03 08:10:28 +0300
commit80808951eac6910f1e4ae5e8dcbaf5502d604807 (patch)
tree4efcbc4fc170fa6d45acefc65bd38f0b46e764bd /app-editors
parentapp-editors/kakoune: remove empty RDEPEND="${DEPEND}" (diff)
downloadgentoo-80808951eac6910f1e4ae5e8dcbaf5502d604807.tar.gz
gentoo-80808951eac6910f1e4ae5e8dcbaf5502d604807.tar.bz2
gentoo-80808951eac6910f1e4ae5e8dcbaf5502d604807.zip
app-editors/featherpad: Bump to 1.0.0
This is really a minor / patch update. From changelog: Bumped the version to 1.0.0 (some users may have mistaken "0.X.Y" for "unstable"). Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Hans Fredrik Nordhaug <hansfn@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/22175 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/featherpad/Manifest1
-rw-r--r--app-editors/featherpad/featherpad-1.0.0.ebuild37
-rw-r--r--app-editors/featherpad/metadata.xml6
3 files changed, 44 insertions, 0 deletions
diff --git a/app-editors/featherpad/Manifest b/app-editors/featherpad/Manifest
index 78475bb25f5f..4c7622319098 100644
--- a/app-editors/featherpad/Manifest
+++ b/app-editors/featherpad/Manifest
@@ -1 +1,2 @@
DIST featherpad-0.18.0.tar.gz 967643 BLAKE2B a8a84fa71232bdd9448ec4a9c921f8f452212dfb52ec518c3f340e9b600858a9cfca2d7729a0f58c9d1465b77bd28c836de78026c58ff94297de704e7bf670d8 SHA512 3e0d008792dd55bc5e57654f9b032f0a66a60c682499c684cfc3b182fdc57a654bb5fb195b458af66ddd8db929b31e7bfa789bd9bdf33d32454fbbcb090bcd91
+DIST featherpad-1.0.0.tar.gz 1010200 BLAKE2B 22a11a0655ed57f7a7d53949e59c3b989a304b7c3db1f7308af0a52cc00a151cee505b02c19ece286da1be37e76c8874cee4102db3d881ef2c4ad48ecbb2f20a SHA512 9f7e24fa5e89e269693bc0a37f79d987e4914dde2d2b46bd0385886383dab8b35556fbc0f5c5b7b9a2c3a41694174ffa8532c48def87d2972fbc73c1e9c38bf3
diff --git a/app-editors/featherpad/featherpad-1.0.0.ebuild b/app-editors/featherpad/featherpad-1.0.0.ebuild
new file mode 100644
index 000000000000..dc209562867b
--- /dev/null
+++ b/app-editors/featherpad/featherpad-1.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg cmake
+
+DESCRIPTION="Lightweight Qt5 Plain-Text Editor for Linux"
+HOMEPAGE="https://github.com/tsujan/FeatherPad"
+SRC_URI="https://github.com/tsujan/FeatherPad/archive/V${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/FeatherPad-${PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+X"
+
+RDEPEND="app-text/hunspell:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ X? (
+ dev-qt/qtx11extras:5
+ x11-libs/libX11
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-qt/linguist-tools:5"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITHOUT_X11=$(usex !X)
+ )
+ cmake_src_configure
+}
diff --git a/app-editors/featherpad/metadata.xml b/app-editors/featherpad/metadata.xml
index 3fd6253bfc08..d4dadaaf9ad1 100644
--- a/app-editors/featherpad/metadata.xml
+++ b/app-editors/featherpad/metadata.xml
@@ -14,6 +14,12 @@
plain-text editor for Linux. It is independent of any desktop
environment.
</longdescription>
+ <use>
+ <flag name="X">
+ Link application against X11 libraries which adds
+ support for virtual desktop awareness and tab DND.
+ </flag>
+ </use>
<upstream>
<remote-id type="github">tsujan/FeatherPad</remote-id>
</upstream>