summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-16 13:46:23 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-16 13:46:23 +0300
commitaa02d1f844c4d49d52b78adccbed90c4f1b36464 (patch)
treeb61103ec88fb7c1f49d0766a7ac9d9991a97a238 /app-editors
parentapp-editors/vscode: drop 1.70.1-r1, 1.70.2 (diff)
downloadgentoo-aa02d1f844c4d49d52b78adccbed90c4f1b36464.tar.gz
gentoo-aa02d1f844c4d49d52b78adccbed90c4f1b36464.tar.bz2
gentoo-aa02d1f844c4d49d52b78adccbed90c4f1b36464.zip
app-editors/vscodium: add 1.71.2.22258
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vscodium/Manifest3
-rw-r--r--app-editors/vscodium/vscodium-1.71.2.22258.ebuild118
2 files changed, 121 insertions, 0 deletions
diff --git a/app-editors/vscodium/Manifest b/app-editors/vscodium/Manifest
index c71d035d082c..6acd58d87249 100644
--- a/app-editors/vscodium/Manifest
+++ b/app-editors/vscodium/Manifest
@@ -7,3 +7,6 @@ DIST vscodium-1.70.2.22230-arm64.tar.gz 117323455 BLAKE2B 9e2706c5e99f2ed0343ac8
DIST vscodium-1.71.0.22245-amd64.tar.gz 119418373 BLAKE2B aecb45c00e67d0b6a62560797f02c34f521660fb67526cb77943113c99d8b39b2ac97b12d1b9b8fad85654b4dfa59fb9a5e28f13ddf2deae71e18e0fcfcf92bd SHA512 a284a17e56a09e29b4a1ad6aec3e4e68bc6d6a8d92f0d6744bdc2f708c0acbe4393c9724c4c2eb6256c7198518d48cd0fde3237424bec020887f1b0e28742276
DIST vscodium-1.71.0.22245-arm.tar.gz 101458849 BLAKE2B 008b95419df2e1e02876b7b7c8bfe567b3291eccca7de418ab899716163a68b536febd6329119f4532017e20c274d479e788a3d3d5bb8d1b3af92fc96afe42f0 SHA512 0700d85e8db1733d3d80ddeaca68132bdeccd7dfc89cda923103739db9d00305087a6544639d4ed802c75eeb2887a998f1b4154d7d0be4db5d11da40e34325be
DIST vscodium-1.71.0.22245-arm64.tar.gz 112480037 BLAKE2B 730fe3e6564c7c72ddd9bbcc8e13f2ceb298eeb598267d38858660c5e99a0e490916b335096e59bda4cea278d19b00b54cd91f32e7933a7853ee32a6de631361 SHA512 b545b77e7e95ea5b7022310ec8fa50ed290aa7002f0f6c925a10f28eba07cf20ae18ada3f7b37f6aa1ebcc4a2eea76246ef4c511c12b8fa952f3ecadda92ff8f
+DIST vscodium-1.71.2.22258-amd64.tar.gz 119405578 BLAKE2B dc6275d923dd48db78f6d9fdd219de822d16ba312fbcda3b1c5764f73321f38ddb62a338dfbde59df8f9e86b00011e71d9dd432e392b98b2f6eb19699df12df2 SHA512 5f3f8cbdac8aa3c8c9c4a954c62dffe8764db048fb4e8e5cb679ee9e7b68bf32a572093302ba035eea3358a7c3b18b40b5080ce04d24ef1558f858aa4d29f4f9
+DIST vscodium-1.71.2.22258-arm.tar.gz 101454282 BLAKE2B b3ef1f4c1d16cba4ffe1cad177bb31611b2a5fc94a8b6b47629bdb570617245ebb5c0e417240ea4e7cd6ac643e031914b1786179de4653f707b522e0491bd944 SHA512 64d5fc48f0de1358cc30a2200d60c8a739bf579058f280e1bb4dd2c2db0241169d7bc4404b8b631554e4ecf764dc2587db31c81af73116019dbef15a4cf675ea
+DIST vscodium-1.71.2.22258-arm64.tar.gz 112485387 BLAKE2B 879f16278a1b221283ef1f217634e589aaa37afad295c26ddb005fcca0df20bbc2c2c80b8c8f59d1dfff9bd33bbcbe8a27482996a4426c776e4a23d0a754ca0e SHA512 9bb531e3f08be4d5578fbc68c51c0a2e7797a2c89602f3133729b12bac3ca1ad48cc16ed71049ed6cdf4aef74a0ce518108d757de7fee175470cdba97b54712a
diff --git a/app-editors/vscodium/vscodium-1.71.2.22258.ebuild b/app-editors/vscodium/vscodium-1.71.2.22258.ebuild
new file mode 100644
index 000000000000..dc168f81f50b
--- /dev/null
+++ b/app-editors/vscodium/vscodium-1.71.2.22258.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop pax-utils xdg optfeature
+
+DESCRIPTION="A community-driven, freely-licensed binary distribution of Microsoft's VSCode"
+HOMEPAGE="https://vscodium.com/"
+SRC_URI="
+ amd64? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-x64-${PV}.tar.gz -> ${P}-amd64.tar.gz )
+ arm? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-armhf-${PV}.tar.gz -> ${P}-arm.tar.gz )
+ arm64? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-arm64-${PV}.tar.gz -> ${P}-arm64.tar.gz )
+"
+
+RESTRICT="strip bindist"
+
+LICENSE="
+ Apache-2.0
+ BSD
+ BSD-1
+ BSD-2
+ BSD-4
+ CC-BY-4.0
+ ISC
+ LGPL-2.1+
+ MIT
+ MPL-2.0
+ openssl
+ PYTHON
+ TextMate-bundle
+ Unlicense
+ UoI-NCSA
+ W3C
+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64"
+IUSE=""
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ app-accessibility/at-spi2-core:2
+ app-crypt/libsecret[crypt]
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/mesa
+ sys-apps/util-linux
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="
+ /opt/vscodium/chrome_crashpad_handler
+ /opt/vscodium/chrome-sandbox
+ /opt/vscodium/codium
+ /opt/vscodium/libEGL.so
+ /opt/vscodium/libffmpeg.so
+ /opt/vscodium/libGLESv2.so
+ /opt/vscodium/libvk_swiftshader.so
+ /opt/vscodium/libvulkan.so*
+ /opt/vscodium/resources/app/extensions/*
+ /opt/vscodium/resources/app/node_modules.asar.unpacked/*
+ /opt/vscodium/swiftshader/libEGL.so
+ /opt/vscodium/swiftshader/libGLESv2.so
+"
+
+S="${WORKDIR}"
+
+src_install() {
+ # Cleanup
+ rm "${S}/resources/app/LICENSE.txt" || die
+
+ # Disable update server
+ sed -i "/updateUrl/d" "${S}"/resources/app/product.json || die
+
+ # Install
+ pax-mark m codium
+ insinto "/opt/${PN}"
+ doins -r *
+ fperms +x /opt/${PN}/{,bin/}codium
+ fperms +x /opt/${PN}/chrome_crashpad_handler
+ fperms 4711 /opt/${PN}/chrome-sandbox
+ fperms 755 /opt/${PN}/resources/app/extensions/git/dist/{askpass,git-editor}{,-empty}.sh
+ fperms -R +x /opt/${PN}/resources/app/out/vs/base/node
+ fperms +x /opt/${PN}/resources/app/node_modules.asar.unpacked/@vscode/ripgrep/bin/rg
+ dosym "../../opt/${PN}/bin/codium" "usr/bin/vscodium"
+ dosym "../../opt/${PN}/bin/codium" "usr/bin/codium"
+ domenu "${FILESDIR}/vscodium.desktop"
+ domenu "${FILESDIR}/vscodium-url-handler.desktop"
+ domenu "${FILESDIR}/vscodium-wayland.desktop"
+ domenu "${FILESDIR}/vscodium-url-handler-wayland.desktop"
+ newicon "resources/app/resources/linux/code.png" "vscodium.png"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog "When compared to the regular VSCode, VSCodium has a few quirks"
+ elog "More information at: https://github.com/VSCodium/vscodium/blob/master/DOCS.md"
+ optfeature "keyring support inside vscode" "gnome-base/gnome-keyring"
+}